summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-13 14:29:41 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-13 14:29:41 +0000
commit3d8cec75b1fc83a877e447524209f6dfb7180599 (patch)
treec937d4374de9d6541d99f20e41e07dd8dac85a8b /media-libs/aalib
parent*** empty log message *** (diff)
downloadhistorical-3d8cec75b1fc83a877e447524209f6dfb7180599.tar.gz
historical-3d8cec75b1fc83a877e447524209f6dfb7180599.tar.bz2
historical-3d8cec75b1fc83a877e447524209f6dfb7180599.zip
Maintainence and FHS 2.1 fixes
Added a lot of USE flags GGI support and lcms support for libmng
Diffstat (limited to 'media-libs/aalib')
-rw-r--r--media-libs/aalib/aalib-1.2-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-libs/aalib/aalib-1.2-r1.ebuild b/media-libs/aalib/aalib-1.2-r1.ebuild
new file mode 100644
index 000000000000..1f23799b825e
--- /dev/null
+++ b/media-libs/aalib/aalib-1.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/aalib/aalib-1.2-r1.ebuild,v 1.1 2001/02/13 14:29:40 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A ASCI-Graphics Library"
+SRC_URI="ftp://ftp.ta.jcu.cz/pub/aa/${A}"
+HOMEPAGE="http://www.ta.jcu.cz/aa/"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ slang? ( >=sys-libs/slang-1.4.2 )
+ X? ( >=x11-base/xfree-4.0.1 )"
+
+src_compile() {
+
+ local myconf
+ if [ "`use slang`" ]
+ then
+ myconf="--with-slang-driver=yes"
+ else
+ myconf="--with-slang-driver=no"
+ fi
+ if [ "`use X`" ]
+ then
+ myconf="${myconf} --with-x11-driver=yes"
+ else
+ myconf="${myconf} --with-x11-driver=no"
+ fi
+
+ try ./configure --prefix=/usr --infodir=/usr/share/info --host=${CHOST} ${myconf}
+ try make
+
+}
+
+src_install () {
+
+ try make prefix=${D}/usr infodir=${D}/usr/share/info install
+
+ dodoc ANNOUNCE AUTHORS ChangeLog COPYING NEWS README*
+
+}
+