summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-11-09 09:57:53 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-11-09 09:57:53 +0000
commit7d0f1c8673fb18bf7e3d2c748a96c5d8128423e1 (patch)
treeebec441c4df5826890797d4ff3cad9ec60ec22eb /media-libs/SoGtk
parentfixes/cleanup (diff)
downloadhistorical-7d0f1c8673fb18bf7e3d2c748a96c5d8128423e1.tar.gz
historical-7d0f1c8673fb18bf7e3d2c748a96c5d8128423e1.tar.bz2
historical-7d0f1c8673fb18bf7e3d2c748a96c5d8128423e1.zip
sandbox + NLS fixes
Diffstat (limited to 'media-libs/SoGtk')
-rw-r--r--media-libs/SoGtk/ChangeLog5
-rw-r--r--media-libs/SoGtk/SoGtk-20010601-r1.ebuild29
2 files changed, 28 insertions, 6 deletions
diff --git a/media-libs/SoGtk/ChangeLog b/media-libs/SoGtk/ChangeLog
index 1261334fc737..14aec52e34b5 100644
--- a/media-libs/SoGtk/ChangeLog
+++ b/media-libs/SoGtk/ChangeLog
@@ -1,12 +1,13 @@
# ChangeLog for media-libs/SoGtk
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/SoGtk/ChangeLog,v 1.2 2002/11/09 07:56:01 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/SoGtk/ChangeLog,v 1.3 2002/11/09 09:57:53 seemant Exp $
*SoGtk-20010601-r1 (1 Feb 2002)
08 Nov 2002; Seemant Kulleen <seemant@gentoo.org> SoGTK-20010601-r1.ebuild :
- Changed make install to einstall
+ Changes to fix sandbox violations, also NLS fixes (USE based). Closes bug
+ #10438 by torgeir@trenger.ro (Torgeir Hansen)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
diff --git a/media-libs/SoGtk/SoGtk-20010601-r1.ebuild b/media-libs/SoGtk/SoGtk-20010601-r1.ebuild
index 9c5b3e2a13fe..ff66c8db086e 100644
--- a/media-libs/SoGtk/SoGtk-20010601-r1.ebuild
+++ b/media-libs/SoGtk/SoGtk-20010601-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/SoGtk/SoGtk-20010601-r1.ebuild,v 1.10 2002/11/09 07:56:01 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/SoGtk/SoGtk-20010601-r1.ebuild,v 1.11 2002/11/09 09:57:53 seemant Exp $
+
+IUSE="nls doc"
S=${WORKDIR}/${PN}
DESCRIPTION="A Gtk Interface for coin"
@@ -13,19 +15,38 @@ KEYWORDS="x86 sparc sparc64"
DEPEND="virtual/x11
<x11-libs/gtkglarea-1.99.0
- media-libs/coin"
+ media-libs/coin
+ sys-apps/supersed
+ nls? ( sys-devel/gettext )
+ doc? ( app-doc/doxygen )"
src_compile() {
./bootstrap --add
- econf || die
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="${myconf} --disable-nls"
+ touch intl/libgettext.h
+ fi
+ use doc && myconf="${myconf} --with-html --with-man"
+
+ econf \
+ --with-x \
+ ${myconf} || die
+
+ ssed -i "s:ENABLE_NLS 1:ENABLE_NLS 0:" config.h
make || die
}
src_install () {
- einstall || die
+ einstall \
+ bindir=${D}/usr/bin \
+ includedir=${D}/usr/include \
+ libdir=${D}/usr/lib || die
cd ${S}
dodoc AUTHORS COPYING ChangeLog* LICENSE* NEWS README*