summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2007-07-14 21:14:31 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2007-07-14 21:14:31 +0000
commitffc0ee64df2a8317665cee5e8bba6f23ecad1e4f (patch)
treefcd7bd1d20141678c94d0722d60be512ffbdc2c4 /media-gfx
parentremoved old version. (diff)
downloadhistorical-ffc0ee64df2a8317665cee5e8bba6f23ecad1e4f.tar.gz
historical-ffc0ee64df2a8317665cee5e8bba6f23ecad1e4f.tar.bz2
historical-ffc0ee64df2a8317665cee5e8bba6f23ecad1e4f.zip
version bump
Package-Manager: portage-2.1.3_rc8
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/exiv2/ChangeLog7
-rw-r--r--media-gfx/exiv2/exiv2-0.15.ebuild69
-rw-r--r--media-gfx/exiv2/files/digest-exiv2-0.153
-rw-r--r--media-gfx/iscan/ChangeLog7
-rw-r--r--media-gfx/iscan/files/digest-iscan-2.7.030
-rw-r--r--media-gfx/iscan/iscan-2.7.0.ebuild316
6 files changed, 430 insertions, 2 deletions
diff --git a/media-gfx/exiv2/ChangeLog b/media-gfx/exiv2/ChangeLog
index 5e5694187569..232e7f123a89 100644
--- a/media-gfx/exiv2/ChangeLog
+++ b/media-gfx/exiv2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/exiv2
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/ChangeLog,v 1.28 2007/07/14 21:07:08 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/ChangeLog,v 1.29 2007/07/14 21:10:28 sbriesen Exp $
+
+*exiv2-0.15 (14 Jul 2007)
+
+ 14 Jul 2007; Stefan Briesenick <sbriesen@gentoo.org> +exiv2-0.15.ebuild:
+ version bump
14 Jul 2007; Stefan Briesenick <sbriesen@gentoo.org> -exiv2-0.9.1.ebuild:
removed old version.
diff --git a/media-gfx/exiv2/exiv2-0.15.ebuild b/media-gfx/exiv2/exiv2-0.15.ebuild
new file mode 100644
index 000000000000..1f54c6156099
--- /dev/null
+++ b/media-gfx/exiv2/exiv2-0.15.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/exiv2/exiv2-0.15.ebuild,v 1.1 2007/07/14 21:10:28 sbriesen Exp $
+
+inherit eutils
+
+DESCRIPTION="EXIF and IPTC metadata C++ library and command line utility"
+HOMEPAGE="http://www.exiv2.org/"
+SRC_URI="http://www.exiv2.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+
+IUSE="doc nls zlib unicode"
+IUSE_LINGUAS="de es fi fr pl ru"
+
+for X in ${IUSE_LINGUAS}; do IUSE="${IUSE} linguas_${X}"; done
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ nls? ( virtual/libintl )
+ virtual/libiconv"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use unicode; then
+ for i in doc/cmd.txt; do
+ echo ">>> Converting "${i}" to UTF-8"
+ iconv -f LATIN1 -t UTF-8 "${i}" > "${i}~" && mv -f "${i}~" "${i}" || rm -f "${i}~"
+ done
+ fi
+
+ if use doc; then
+ echo ">>> Updating doxygen config"
+ doxygen &>/dev/null -u config/Doxyfile
+ fi
+}
+
+src_compile() {
+ local myconf="$(use_enable nls)"
+ use zlib || myconf="${myconf} --without-zlib" # plain 'use_with' fails
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake doc || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README doc/{ChangeLog,cmd.txt}
+ use doc && dohtml -r doc/html/.
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "PLEASE PLEASE take note of this:"
+ ewarn "Please make *sure* to run revdep-rebuild now"
+ ewarn "Certain things on your system may have linked against a"
+ ewarn "different version of exiv2 -- those things need to be"
+ ewarn "recompiled. Sorry for the inconvenience!"
+ ewarn
+}
diff --git a/media-gfx/exiv2/files/digest-exiv2-0.15 b/media-gfx/exiv2/files/digest-exiv2-0.15
new file mode 100644
index 000000000000..fbd92cb1983e
--- /dev/null
+++ b/media-gfx/exiv2/files/digest-exiv2-0.15
@@ -0,0 +1,3 @@
+MD5 bb18d19e1d6fb255dadda456cadec00e exiv2-0.15.tar.gz 1133249
+RMD160 b879bcbe8255ae83af7d1cfadb84b01dbc5e97f2 exiv2-0.15.tar.gz 1133249
+SHA256 b72d82e9117308063471993f3832e58064c0599dec3df2bf2a7ce54450984a3e exiv2-0.15.tar.gz 1133249
diff --git a/media-gfx/iscan/ChangeLog b/media-gfx/iscan/ChangeLog
index 71a04d38962a..2a8a2d31b8f3 100644
--- a/media-gfx/iscan/ChangeLog
+++ b/media-gfx/iscan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/iscan
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan/ChangeLog,v 1.19 2007/05/17 22:57:18 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan/ChangeLog,v 1.20 2007/07/14 21:14:31 sbriesen Exp $
+
+*iscan-2.7.0 (14 Jul 2007)
+
+ 14 Jul 2007; Stefan Briesenick <sbriesen@gentoo.org> +iscan-2.7.0.ebuild:
+ version bump
17 May 2007; Stefan Briesenick <sbriesen@gentoo.org> iscan-2.6.0.ebuild:
fixed autotools stuff.
diff --git a/media-gfx/iscan/files/digest-iscan-2.7.0 b/media-gfx/iscan/files/digest-iscan-2.7.0
new file mode 100644
index 000000000000..ce800cfc2198
--- /dev/null
+++ b/media-gfx/iscan/files/digest-iscan-2.7.0
@@ -0,0 +1,30 @@
+MD5 c958c0932f4ffb9db11cb62a7a37008e iscan-2.7.0-1.c2.tar.gz 1296863
+RMD160 41c555a2a40b51a1b38b7409307640de325a8bb3 iscan-2.7.0-1.c2.tar.gz 1296863
+SHA256 a20ab0620ce06950dc86531a1c9b96437111ca472c23b40b7186b9d4d2c7a00c iscan-2.7.0-1.c2.tar.gz 1296863
+MD5 08e81ee1d522c5e33edaac26afd0ded8 iscan-plugin-gt-7200-1.0.0-1.c2.i386.rpm 62336
+RMD160 7862ae8f8e4362ba9535b9d492e742d9716da91d iscan-plugin-gt-7200-1.0.0-1.c2.i386.rpm 62336
+SHA256 11789e2074670b1098cea9366b3e33bb72ce316c0ced6e09086f3a13eeccb86f iscan-plugin-gt-7200-1.0.0-1.c2.i386.rpm 62336
+MD5 060e7ab5b38371a681facae2995b8a74 iscan-plugin-gt-7300-1.0.0-1.c2.i386.rpm 77271
+RMD160 9d3a95a1eefd5a63b991d06ed58356aeb814b7d8 iscan-plugin-gt-7300-1.0.0-1.c2.i386.rpm 77271
+SHA256 a6cfce5c1da99ee34b4186cdf7e611a685be8da95b08f8295fdeafcb4d0fc339 iscan-plugin-gt-7300-1.0.0-1.c2.i386.rpm 77271
+MD5 f76725766f44debe3f3fec06d0e2023b iscan-plugin-gt-9400-1.0.0-1.c2.i386.rpm 140610
+RMD160 aaa768cffc851d2168e358c6f4e30b8125ef8e86 iscan-plugin-gt-9400-1.0.0-1.c2.i386.rpm 140610
+SHA256 0172f3331dfefac27fffe3723b7b403b1fbc5d0cd0c3e835bdef7d925dfeab3e iscan-plugin-gt-9400-1.0.0-1.c2.i386.rpm 140610
+MD5 8b1c398ef58769d9ceb77ad771515de3 iscan-plugin-gt-f500-1.0.0-1.c2.i386.rpm 126130
+RMD160 a5ea991156fb8fbe460c5a8198467837eedfa6bc iscan-plugin-gt-f500-1.0.0-1.c2.i386.rpm 126130
+SHA256 fe87d16ce22c28e2c320286758bea32ea4cad75c83debd6fe95670b704701464 iscan-plugin-gt-f500-1.0.0-1.c2.i386.rpm 126130
+MD5 b72a512a927b9f2020af817c5a541ae8 iscan-plugin-gt-f520-1.0.0-1.c2.i386.rpm 125919
+RMD160 8743c98fb45b055adc1db38cfd312de9517cccee iscan-plugin-gt-f520-1.0.0-1.c2.i386.rpm 125919
+SHA256 2f0dd2257e19c808062ddbaa4a1f4cf6899944cacce67f46136008fbe60ae61a iscan-plugin-gt-f520-1.0.0-1.c2.i386.rpm 125919
+MD5 5f4137fd69198617b95bd59261affd75 iscan-plugin-gt-f600-1.0.0-1.c2.i386.rpm 151280
+RMD160 2779029ea507525042122a0ca5581a3b0fd5cbc8 iscan-plugin-gt-f600-1.0.0-1.c2.i386.rpm 151280
+SHA256 4735e468c060250a2e6b9adca72ed43c9e8523db5b95d8edad7d0e91f0ac13d2 iscan-plugin-gt-f600-1.0.0-1.c2.i386.rpm 151280
+MD5 cf191e84b03b28a8b0f629d60ba0b36e iscan-plugin-gt-f700-2.0.0-0.c2.i386.rpm 150711
+RMD160 52a0aee4787c5dd8b64a87a40c988f4c5242cde5 iscan-plugin-gt-f700-2.0.0-0.c2.i386.rpm 150711
+SHA256 c3f31a4b9c07c0a9a83033de0d9b873d282f267dc7de2855083c1a8413c4c591 iscan-plugin-gt-f700-2.0.0-0.c2.i386.rpm 150711
+MD5 bda9d1dfe5c9524084b01e46a7a9f5e3 iscan-plugin-gt-s600-2.0.0-1.c2.i386.rpm 140478
+RMD160 4a86fa7626c895e90e7a77ef1d07c93165a5afe3 iscan-plugin-gt-s600-2.0.0-1.c2.i386.rpm 140478
+SHA256 75d66ae95407b879ad4ea14d67e5ecf11e0e12159fd5a8521b4589299dffdb0f iscan-plugin-gt-s600-2.0.0-1.c2.i386.rpm 140478
+MD5 02c151a49608ae911b1e200672ed236f iscan-plugin-gt-x750-1.0.0-1.c2.i386.rpm 163386
+RMD160 aeb024f903c79d64cb79ab8c15d3f6fb0c7ece8d iscan-plugin-gt-x750-1.0.0-1.c2.i386.rpm 163386
+SHA256 7ebd3a9cf7f35b5abc5cd8c6b5c27dd98b2b6c39ad621c9ab753f3046b9578a4 iscan-plugin-gt-x750-1.0.0-1.c2.i386.rpm 163386
diff --git a/media-gfx/iscan/iscan-2.7.0.ebuild b/media-gfx/iscan/iscan-2.7.0.ebuild
new file mode 100644
index 000000000000..ce48f16c6533
--- /dev/null
+++ b/media-gfx/iscan/iscan-2.7.0.ebuild
@@ -0,0 +1,316 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan/iscan-2.7.0.ebuild,v 1.1 2007/07/14 21:14:31 sbriesen Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils toolchain-funcs flag-o-matic autotools rpm
+
+SRC_REV="1" # revision used by upstream
+
+# DISCLAIMER:
+# -> first try to remove GCC 3.3 stuff since 3.4 is stable
+# -> please open BugZilla if you still need it!
+
+# HINTS:
+# -> non-free modules are x86 only
+# -> isane frontend needs non-free modules
+# -> sane-epkowa should be usable on every arch
+# -> ${P}-${SRC_REV}.tar.gz (for gcc 3.2/3.3)
+# -> ${P}-${SRC_REV}.c2.tar.gz (for gcc 3.4 or later)
+
+# PLUGINS:
+# -> iscan-plugin-gt-7200 == Perfection 1250 PHOTO
+# -> iscan-plugin-gt-7300 == Perfection 1260 PHOTO
+# -> iscan-plugin-gt-9400 == Perfection 3170 PHOTO (esfw32.bin)
+# -> iscan-plugin-gt-f500 == Perfection 2480/2580 PHOTO (esfw41.bin)
+# -> iscan-plugin-gt-f520 == Perfection 3490/3590 PHOTO (esfw52.bin)
+# -> iscan-plugin-gt-f600 == Perfection 4180 PHOTO (esfw43.bin)
+# -> iscan-plugin-gt-x750 == Perfection 4490 PHOTO (esfw54.bin)
+# -> iscan-plugin-gt-s600 == Perfection V10/V100 PHOTO (esfw66.bin)
+# -> iscan-plugin-gt-f700 == Perfection V350 PHOTO (esfw68.bin)
+
+# FIXME:
+# Make jpeg/png optional. The problem is, that the
+# configure script ignores --disable-*, if the
+# corresponding lib is found on the system.
+# Furthermore, isane doesn't compile w/o libusb,
+# this should be fixed somehow.
+
+# available x86 plugins (will be assembled below)
+PLUGINS="
+ v1180/7200-1.0.0-1
+ v1180/7300-1.0.0-1
+ v1180/9400-1.0.0-1
+ v1180/f500-1.0.0-1
+ v1180/f520-1.0.0-1
+ v1180/f600-1.0.0-1
+ v1180/x750-1.0.0-1
+ 2.3.0/f700-2.0.0-0
+ 2.3.0/s600-2.0.0-1"
+
+# Firmware files within plugin RPMs
+FIRMWARE=( "esfw41.bin Perfection 2480/2580 PHOTO"
+ "esfw32.bin Perfection 3170 PHOTO"
+ "esfw52.bin Perfection 3490/3590 PHOTO"
+ "esfw43.bin Perfection 4180 PHOTO"
+ "esfw54.bin Perfection 4490 PHOTO"
+ "esfw66.bin Perfection V10/V100 PHOTO"
+ "esfw68.bin Perfection V350 PHOTO" )
+
+#SRC_GCC33="http://lx1.avasys.jp/iscan/${PV}/${P}-${SRC_REV}.tar.gz"
+SRC_GCC34="http://lx1.avasys.jp/iscan/${PV}/${P}-${SRC_REV}.c2.tar.gz"
+#BIN_GCC33=""
+BIN_GCC34=""
+
+for X in ${PLUGINS}; do
+ #BIN_GCC33="${BIN_GCC33} http://lx1.avasys.jp/iscan/${X%%/*}/iscan-plugin-gt-${X##*/}.i386.rpm"
+ BIN_GCC34="${BIN_GCC34} http://lx1.avasys.jp/iscan/${X%%/*}/iscan-plugin-gt-${X##*/}.c2.i386.rpm"
+done
+
+# feel free to add your arch, every non-x86
+# arch doesn't install any x86-only stuff.
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="EPSON Image Scan! for Linux (including sane-epkowa backend and firmware)"
+HOMEPAGE="http://www.avasys.jp/english/linux_e/dl_scan.html"
+#SRC_URI="x86? ( ${SRC_GCC33} ${BIN_GCC33} ) ${SRC_GCC34} ${BIN_GCC34}"
+SRC_URI="${SRC_GCC34} ${BIN_GCC34}"
+LICENSE="GPL-2 EAPL EPSON"
+SLOT="0"
+
+IUSE="X gimp unicode"
+IUSE_LINGUAS="de es fr it ja ko nl pt zh_CN zh_TW"
+
+for X in ${IUSE_LINGUAS}; do IUSE="${IUSE} linguas_${X}"; done
+
+QA_TEXTRELS="
+ usr/lib/iscan/libesint41.so.2.0.0
+ usr/lib/iscan/libesint52.so.2.0.0"
+
+DEPEND="media-gfx/sane-backends
+ media-libs/libpng
+ media-libs/jpeg
+ >=sys-fs/udev-103
+ >=dev-libs/libusb-0.1.12
+ x86? (
+ X? (
+ sys-devel/gettext
+ >=x11-libs/gtk+-2.0
+ gimp? ( media-gfx/gimp )
+ )
+ )"
+
+snapscan_firmware() {
+ local i
+ echo "#-------------- EPSON Image Scan! for Linux Scanner-Firmware --------------"
+ for i in "${FIRMWARE[@]}"; do
+ echo
+ echo "# ${i#* } (${i%% *})"
+ echo "#firmware /usr/share/iscan/${i%% *}"
+ done
+ echo
+ cat 2>/dev/null "${1}"
+}
+
+usermap_to_udev() {
+ local ACTION='MODE="0660", GROUP="scanner"'
+ local DEVICE='\1ATTRS{idVendor}=="\L\2\E", ATTRS{idProduct}=="\L\3\E"'
+ echo '# udev rules file for iscan devices (udev >= 0.98)'
+ echo '#'
+ echo 'ACTION!="add", GOTO="iscan_rules_end"'
+ echo 'SUBSYSTEM!="usb*", GOTO="iscan_rules_end"'
+ echo
+ sed -n -e "s|^\(# SEIKO EPSON.*\)|\1|p" \
+ -e "s|^\(#*\)i*scan-device *0x0003 *0x\([^ ]\+\) *0x\([^ ]\+\)*.*|${DEVICE}, ${ACTION}|p" "${1}"
+ echo
+ echo 'LABEL="iscan_rules_end"'
+}
+
+pkg_setup() {
+ local i
+ if ! use x86 && ( use X || use gimp ); then
+ ewarn
+ ewarn "The iscan application needs CSS x86-only libs and"
+ ewarn "thus can't be built currently. You can still use"
+ ewarn "'xscanimage', 'xsane' or 'kooka' with sane-epkowa"
+ ewarn "backend. But some low-end scanners are also not"
+ ewarn "supported, because they need these x86 libs, too."
+ ewarn
+ fi
+
+ # Select correct tarball for installed GCC. This is not a perfect
+ # solution and should be expanded to other working GCC versions.
+ einfo "GCC version: $(gcc-fullversion)"
+ case "$(gcc-version)" in
+ # 3.[23])
+ # if use x86; then
+ # MY_A="${SRC_GCC33##*/}"
+ # for i in ${BIN_GCC33}; do MY_A="${MY_A} ${i##*/}"; done
+ # else # fallback to GCC 3.4, should not harm.
+ # MY_A="${SRC_GCC34##*/}"
+ # for i in ${BIN_GCC34}; do MY_A="${MY_A} ${i##*/}"; done
+ # fi
+ # ;;
+ 3.4|4.[01234]) # 4.x seems to work (tested with Perfection 3490 PHOTO)
+ MY_A="${SRC_GCC34##*/}"
+ for i in ${BIN_GCC34}; do MY_A="${MY_A} ${i##*/}"; done
+ ;;
+ *)
+ if use x86; then
+ #die "Your GCC version is not supported. You need either 3.2, 3.3, 3.4 or 4.x!"
+ die "Your GCC version is not supported. You need either 3.4 or 4.x!"
+ else
+ MY_A="${SRC_GCC34##*/}" # fallback to GCC 3.4, should not harm.
+ for i in ${BIN_GCC34}; do MY_A="${MY_A} ${i##*/}"; done
+ fi
+ ;;
+ esac
+}
+
+src_unpack() {
+ local i
+
+ cd "${WORKDIR}"
+ for i in ${MY_A}; do
+ case "${i}" in
+ *.rpm)
+ echo ">>> Unpacking ${i}"
+ rpm_unpack "${DISTDIR}/${i}" || die "failure unpacking ${i}"
+ ;;
+ *)
+ unpack "${i}"
+ ;;
+ esac
+ done
+
+ cd "${S}"
+
+ # convert japanese docs to UTF-8
+ if use unicode && use linguas_ja; then
+ for i in {NEWS,README}.ja non-free/*.ja.txt; do
+ if [ -f "${i}" ]; then
+ echo ">>> Converting ${i} to UTF-8"
+ iconv -f eucjp -t utf8 -o "${i}~" "${i}" && mv -f "${i}~" "${i}" || rm -f "${i}~"
+ fi
+ done
+ fi
+
+ # disable iscan frontend + none-free modules
+ if ! ( use x86 && use X ); then
+ sed -i -e "s:PKG_CHECK_MODULES(GTK,.*):AC_DEFINE([HAVE_GTK_2], 0):g" \
+ -e "s:\(PKG_CHECK_MODULES(GDK_IMLIB,.*)\):#\1:g" configure.ac
+ sed -i -e 's:^\([[:space:]]*\)frontend[[:space:]]*\\:\1\\:g' \
+ -e 's:^\([[:space:]]*\)non-free[[:space:]]*\\:\1\\:g' \
+ -e 's:^\([[:space:]]*\)po[[:space:]]*\\:\1\\:g' Makefile*
+ sed -i -e 's:iscan.1::g' doc/Makefile*
+ fi
+
+ # autotool stuff
+ eautoconf
+}
+
+src_compile() {
+ append-flags -D_GNU_SOURCE # needed for 'strndup'
+ econf --enable-jpeg --enable-png --with-pic || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ local MY_LIB="/usr/$(get_libdir)"
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # --disable-static doesn't work, so we just remove obsolete static lib
+ sed -i -e "s:^\(old_library=\):# \1:g" "${D}${MY_LIB}/sane/libsane-epkowa.la"
+ rm -f "${D}${MY_LIB}/sane/libsane-epkowa.a"
+
+ # install scanner plugins (x86-only)
+ if use x86; then
+ dodir ${MY_LIB}/iscan
+ cp -df "${WORKDIR}"/usr/lib/iscan/* "${D}${MY_LIB}"/iscan/.
+ fi
+
+ # install scanner firmware (could be used by sane-backends)
+ insinto /usr/share/iscan
+ doins "${WORKDIR}"/usr/share/iscan/*
+
+ # install docs
+ dodoc AUTHORS NEWS README doc/epkowa.desc
+ use linguas_ja && dodoc NEWS.ja README.ja
+
+ # remove 'make-udev-rules', we use our own stuff below
+ rm -f "${D}usr/lib/iscan/make-udev-rules"
+
+ # install USB hotplug stuff
+ dodir /etc/udev/rules.d
+ usermap_to_udev utils/hotplug/iscan.usermap \
+ > "${D}etc/udev/rules.d/99-iscan.rules"
+
+ # install sane config
+ insinto /etc/sane.d
+ doins backend/epkowa.conf
+
+ # link iscan so it is seen as a plugin in gimp
+ if use x86 && use X && use gimp; then
+ local plugindir
+ if [ -x /usr/bin/gimptool ]; then
+ plugindir="$(gimptool --gimpplugindir)/plug-ins"
+ elif [ -x /usr/bin/gimptool-2.0 ]; then
+ plugindir="$(gimptool-2.0 --gimpplugindir)/plug-ins"
+ else
+ die "Can't find GIMP plugin directory."
+ fi
+ dodir "${plugindir}"
+ dosym /usr/bin/iscan "${plugindir}"
+ fi
+
+ # install desktop entry
+ if use x86 && use X; then
+ make_desktop_entry iscan "Image Scan! for Linux ${PV}" scanner.png
+ fi
+}
+
+pkg_postinst() {
+ local i
+ local DLL_CONF="/etc/sane.d/dll.conf"
+ local EPKOWA_CONF="/etc/sane.d/epkowa.conf"
+ local SNAPSCAN_CONF="/etc/sane.d/snapscan.conf"
+ elog
+ if grep -q "^[ \t]*\<epkowa\>" ${DLL_CONF}; then
+ elog "Please edit ${EPKOWA_CONF} to suit your needs."
+ elif grep -q "\<epkowa\>" ${DLL_CONF}; then
+ elog "Hint: to enable the backend, add 'epkowa' to ${DLL_CONF}"
+ elog "Then edit ${EPKOWA_CONF} to suit your needs."
+ else
+ echo "epkowa" >> ${DLL_CONF}
+ elog "A new entry 'epkowa' was added to ${DLL_CONF}"
+ elog "Please edit ${EPKOWA_CONF} to suit your needs."
+ fi
+ elog
+ elog "You can also use the 'snapscan' backend if you have a recent"
+ elog "sane-backend installation. Firmware files for some newer"
+ elog "EPSON scanners were installed into /usr/share/iscan:"
+ elog
+ for i in "${FIRMWARE[@]}"; do
+ elog " ${i%% *}: ${i#* }"
+ done
+ elog
+ if ! grep 2>/dev/null -q "/usr/share/iscan/.*\.bin" "${SNAPSCAN_CONF}"; then
+ snapscan_firmware "${SNAPSCAN_CONF}" > "${SNAPSCAN_CONF}~~~" \
+ && mv -f "${SNAPSCAN_CONF}~~~" "${SNAPSCAN_CONF}" \
+ || rm -f "${SNAPSCAN_CONF}~~~"
+ elog "The firmware entries were added to ${SNAPSCAN_CONF}"
+ else
+ elog "Please edit ${SNAPSCAN_CONF} to suit your needs."
+ fi
+ elog "Hint: not all models are supported by 'snapscan' yet!"
+ elog
+ elog "You can check which backend fits best for your scanner:"
+ elog "http://www.sane-project.org/cgi-bin/driver.pl?manu=Epson&bus=any"
+ elog
+ if [[ -f "/etc/udev/rules.d/75-iscan.rules" ]]; then
+ elog "WARNING: please remove old /etc/udev/rules.d/75-iscan.rules"
+ elog
+ fi
+}