summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-03-02 18:31:04 +0000
committerMichael Januszewski <spock@gentoo.org>2004-03-02 18:31:04 +0000
commit4d0f543caa5c0f8f2ef9babe90a97bffbf25fd80 (patch)
tree4a553220e1f2ca4b03349cd843c38be0d843276c /media-gfx
parentAdded blitz-0.7-ebuild to unstable (diff)
downloadhistorical-4d0f543caa5c0f8f2ef9babe90a97bffbf25fd80.tar.gz
historical-4d0f543caa5c0f8f2ef9babe90a97bffbf25fd80.tar.bz2
historical-4d0f543caa5c0f8f2ef9babe90a97bffbf25fd80.zip
New Bootsplash version
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/bootsplash/ChangeLog10
-rw-r--r--media-gfx/bootsplash/Manifest4
-rw-r--r--media-gfx/bootsplash/bootsplash-0.6-r10.ebuild193
-rw-r--r--media-gfx/bootsplash/files/digest-bootsplash-0.6-r101
-rw-r--r--media-gfx/kolourpaint/Manifest4
5 files changed, 210 insertions, 2 deletions
diff --git a/media-gfx/bootsplash/ChangeLog b/media-gfx/bootsplash/ChangeLog
index 2d3116854e81..fc337306a278 100644
--- a/media-gfx/bootsplash/ChangeLog
+++ b/media-gfx/bootsplash/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-gfx/bootsplash
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/ChangeLog,v 1.25 2004/03/01 22:04:30 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/ChangeLog,v 1.26 2004/03/02 18:31:04 spock Exp $
+
+*bootsplash-0.6-r10 (02 Mar 2004)
+
+ 02 Mar 2004; Michal Januszewski <spock@gentoo.org>
+ bootsplash-0.6-r10.ebuild:
+ This revision includes a new version (3.1.4) of the Bootsplash patch, fixes a
+ minor issue with the compilation of progress.c and closes bugs #43476, #42114
+ and #42906.
01 Mar 2004; Michal Januszewski <spock@gentoo.org> bootsplash-0.6-r8.ebuild:
Bump to stable.
diff --git a/media-gfx/bootsplash/Manifest b/media-gfx/bootsplash/Manifest
index 8e0b587fb01e..b771f6368a6a 100644
--- a/media-gfx/bootsplash/Manifest
+++ b/media-gfx/bootsplash/Manifest
@@ -1,10 +1,12 @@
MD5 6753b4abc8e2131ec651f1e0012f4925 bootsplash-0.6-r8.ebuild 5169
MD5 000b763c35a5c1604070379a0c3a2a44 bootsplash-0.6-r3.ebuild 3437
MD5 fbd2d9894a5ecd9f94a43d7f9831e9ac bootsplash-0.6-r7.ebuild 5169
+MD5 1b918b035b4a9d6fbe09c49e8a186b55 bootsplash-0.6-r10.ebuild 5443
MD5 bc17a454fc8e42f87d415dc23238c996 bootsplash-0.6-r9.ebuild 5017
-MD5 f7c29f9050e58c270956043f01d1fe6d ChangeLog 4581
+MD5 9b46a169065b5eb1b170c662f1703332 ChangeLog 4873
MD5 d94d306da3804e41296e1bf04c7c9cae metadata.xml 255
MD5 250d9fd431815e7ee0ebdad859d9796a files/digest-bootsplash-0.6-r3 70
MD5 f0780470a69548577745c4a344633a72 files/digest-bootsplash-0.6-r7 70
MD5 6a993c12a7aad0735a4783e1f7c2c968 files/digest-bootsplash-0.6-r8 70
MD5 80d57c4a370abbf5613da61aabfca6a7 files/digest-bootsplash-0.6-r9 70
+MD5 415eead25ab7491fad79afd276c53124 files/digest-bootsplash-0.6-r10 71
diff --git a/media-gfx/bootsplash/bootsplash-0.6-r10.ebuild b/media-gfx/bootsplash/bootsplash-0.6-r10.ebuild
new file mode 100644
index 000000000000..12a4c123bd89
--- /dev/null
+++ b/media-gfx/bootsplash/bootsplash-0.6-r10.ebuild
@@ -0,0 +1,193 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/bootsplash/bootsplash-0.6-r10.ebuild,v 1.1 2004/03/02 18:31:04 spock Exp $
+
+S=${WORKDIR}/${PF}
+DESCRIPTION="Graphical backgrounds for frame buffer consoles"
+HOMEPAGE="http://www.bootsplash.org/ http://linux.tkdack.com/"
+SRC_URI="http://dev.gentoo.org/~spock/portage/distfiles/${PF}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND=">=media-libs/freetype-2
+ media-libs/libmng"
+
+src_compile() {
+ # compile utils
+ # the util builds but the rc scripts have not been modified
+ # animated boot up require patches to the baselayout package
+ cd ${S}/utils
+
+ emake -C fbmngplay || die
+ emake -C fbtruetype || die
+ emake -C splashutils || die
+
+ cd ${S}
+}
+
+src_install() {
+ # Splash utilities
+ exeinto /sbin
+ doexe utils/fbmngplay/fbmngplay{,.static}
+ doexe utils/fbtruetype/fbtruetype{,.static}
+ newexe utils/splashutils/splash splash.bin
+ doexe misc/splash
+ doexe utils/splashutils/{fbresolution,getkey,progress}
+
+ dodir /etc/${PN}
+ cp -pR themes/* ${D}/etc/${PN}
+
+ # link default config for boot images if not already set
+ if [ ! -e ${ROOT}/etc/bootsplash/default ]; then
+ use livecd \
+ && dosym ./livecd-2004.0 /etc/bootsplash/default \
+ || dosym ./gentoo /etc/bootsplash/default
+ fi
+
+ exeinto /etc/init.d
+ doexe misc/bootsplash
+
+ insinto /etc/conf.d
+ doins misc/bootsplash.conf
+
+ insinto /usr/share/${PN}
+ doins kernel/*.bz2 misc/grub.conf.sample
+
+ sed -i "s:${PN}:${PF}:g" bootsplash_patch
+ into /
+ dosbin bootsplash_patch
+ fperms 0754 /sbin/bootsplash_patch
+}
+
+pkg_postinst() {
+ # Has to be done here so that the initrd images are created properly
+ if [ "${ROOT}" = "/" ]
+ then
+ for SIZE in 800x600 1024x768 1280x1024 1600x1200
+ do
+ /sbin/splash -s -f \
+ /etc/bootsplash/gentoo/config/bootsplash-${SIZE}.cfg \
+ > /usr/share/${PN}/initrd-${SIZE}
+ done
+ fi
+
+ echo ""
+ einfo "Execute \"bootsplash_patch\" to have your kernel sources in"
+ einfo "/usr/src/linux patched with the Framebuffer Bootsplash patches."
+ einfo
+ einfo "You can also use:"
+ einfo " bootsplash_patch /path/to/your/custom/kernel/"
+ einfo "to patch your custom kernel sources."
+ echo ""
+ ewarn "If you have already patched the kernel then you only need to copy"
+ ewarn "an initrd from /usr/share/${PN} to /boot"
+ echo ""
+ einfo "Run:"
+ einfo " rc-update add bootsplash default"
+ einfo "to change the console images after startup"
+ echo ""
+ einfo "Please note that in case /usr is a separate partition"
+ einfo "you'll need to use the statically linked versions of Bootplash"
+ einfo 'utilities (fbmngplay.static, fbtruetype.static) during boot-time.'
+ echo ""
+ einfo "If you would like to have a better quality background picture"
+ einfo "from the Gentoo theme and you don't care about a few more kilobytes"
+ einfo "of used memory, try the gentoo-highquality theme which you can"
+ einfo "download from:"
+ einfo "http://dev.gentoo.org/~spock/stuff/bootsplash/gentoo-highquality.tar.bz2"
+ echo ""
+ einfo "After the download is complete, unpack the files to /etc/bootsplash/"
+ echo ""
+}
+
+pkg_config() {
+
+ if [ "${LINUX}" == "" ]; then
+ LINUX='/usr/src/linux'
+ fi
+
+ eval `sed -n -e 's/^\([A-Z]*\) = \([0-9]*\)$/\1=\2/p' -e 's/^\([A-Z]*\) = \(-[-a-z0-9]*\)$/\1=\2/p' ${LINUX}/Makefile`
+
+ if [ -z "$VERSION" -o -z "$PATCHLEVEL" -o -z "$SUBLEVEL" ]
+ then
+ die "Unable to determine kernel version in ${LINUX}"
+ fi
+
+ KB="${VERSION}.${PATCHLEVEL}"
+ KV_MINOR="${SUBLEVEL}"
+
+ ewarn
+ ewarn "Patching the kernel (branch: ${KB}) in ${LINUX} ..."
+ ewarn
+
+ cd ${ROOT}/${LINUX}
+
+ if [ "${KB}" == "2.4" ]; then
+
+ if [ -f drivers/video/fbcon-splash.c ]; then
+ eerror
+ eerror "It appears your kernel has already been patched."
+ eerror
+ exit 1
+ fi
+
+ if [ ${KV_MINOR} -ge 22 ]; then
+ bzip2 -dc \
+ ${ROOT}/usr/share/${PN}/${PN}-3.0.7-2.4.22-vanilla.diff.bz2 \
+ | patch -p1 || die
+ else
+ bzip2 -dc \
+ ${ROOT}/usr/share/${PN}/${PN}-3.0.7-2.4.20-vanilla.diff.bz2 \
+ | patch -p1 || die
+ fi
+
+ elif [ "${KB}" == "2.6" ]; then
+
+ if [ -d drivers/video/bootsplash ]; then
+ eerror
+ eerror "It appears your kernel has already been patched."
+ eerror
+ exit 1
+ fi
+
+ if [ ${KV_MINOR} -ge 3 ]; then
+ bzip2 -dc \
+ ${ROOT}/usr/share/${PN}/${PN}-3.1.4-2.6.3.diff.bz2 \
+ | patch -p1 || die
+ else
+ bzip2 -dc \
+ ${ROOT}/usr/share/${PN}/${PN}-3.1.3-2.6.0-test9.diff.bz2 \
+ | patch -p1 || die
+ fi
+ else
+ die "Sorry, this kernel branch is not supported."
+ fi
+
+ ewarn
+ ewarn " ... complete."
+ einfo
+ einfo "Your kernel has been patched, rebuild with the following options"
+ einfo "enabled (do not build them as modules!):"
+ einfo " Block Devices ->"
+ einfo " [*] RAM disk support"
+ einfo " [*] Loopback device support"
+ einfo " [*] Initial RAM disk (initrd) support"
+ einfo
+ einfo " Console Drivers ->"
+ einfo " [*] Video mode selection support"
+ einfo " Frame-buffer support ->"
+ einfo " [*] Support for frame buffer devices"
+ einfo " [*] VESA VGA graphics console"
+ einfo " [*] Use splash screen instead of boot logo"
+ einfo
+ einfo "Copy an initrd from /usr/share/${PN} to /boot"
+ einfo
+ einfo "Look at \"/usr/share/${PN}/grub.conf.sample\" for an example"
+ einfo "grub.conf file with the appropriate changes to enable the"
+ einfo "framebuffer boot screens"
+ einfo
+ einfo "Ensure you make the appropriate changes to your grub.conf"
+ einfo
+}
diff --git a/media-gfx/bootsplash/files/digest-bootsplash-0.6-r10 b/media-gfx/bootsplash/files/digest-bootsplash-0.6-r10
new file mode 100644
index 000000000000..ca837fbdb882
--- /dev/null
+++ b/media-gfx/bootsplash/files/digest-bootsplash-0.6-r10
@@ -0,0 +1 @@
+MD5 1393c684116d73fd42448215271ae2a0 bootsplash-0.6-r10.tar.bz2 499990
diff --git a/media-gfx/kolourpaint/Manifest b/media-gfx/kolourpaint/Manifest
new file mode 100644
index 000000000000..60bb0f7d0289
--- /dev/null
+++ b/media-gfx/kolourpaint/Manifest
@@ -0,0 +1,4 @@
+MD5 69f1a71d777a90453ff09246fe323c96 kolourpaint-1.0.ebuild 450
+MD5 b7f6abd71ba754904025325dd95f3e0f ChangeLog 376
+MD5 1b6808bbd78c9161f8b7efb090d966f8 metadata.xml 162
+MD5 b2b6b85c61f0d0fae1de53bb0a906f44 files/digest-kolourpaint-1.0 68