summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Bellinson <thread@gentoo.org>2001-06-22 05:13:25 +0000
committerAdam Bellinson <thread@gentoo.org>2001-06-22 05:13:25 +0000
commit398f6e61543e2f0a890cc2886c33e59e59437b82 (patch)
tree181be6d6ad9c249d846fa37d094fc2bf7c6f6994 /media-gfx
parent- xfig, the editor for all them .fig files. (diff)
downloadhistorical-398f6e61543e2f0a890cc2886c33e59e59437b82.tar.gz
historical-398f6e61543e2f0a890cc2886c33e59e59437b82.tar.bz2
historical-398f6e61543e2f0a890cc2886c33e59e59437b82.zip
*** empty log message ***
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/qiv/files/fix_prefix.pl21
1 files changed, 21 insertions, 0 deletions
diff --git a/media-gfx/qiv/files/fix_prefix.pl b/media-gfx/qiv/files/fix_prefix.pl
new file mode 100644
index 000000000000..5f431ba32e22
--- /dev/null
+++ b/media-gfx/qiv/files/fix_prefix.pl
@@ -0,0 +1,21 @@
+
+# this will hopefully be replaced by a leaner
+# sed method later by someone with a clue.
+#
+open MAKEFILE, "${ARGV[0]}/Makefile";
+open TMP, ">${ARGV[0]}/tmp";
+
+while ( <MAKEFILE> ) {
+ last if $_ =~ /^PREFIX/;
+ print TMP $_;
+}
+
+print TMP "PREFIX = ${ARGV[1]}\n";
+
+print TMP while <MAKEFILE>;
+
+close MAKEFILE;
+close TMP;
+
+system "cp ${ARGV[0]}/tmp ${ARGV[0]}/Makefile";
+#unlink "${ARGV[0]}/tmp";