summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-12-09 12:16:38 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-12-09 12:16:38 +0000
commit126e954ec89dfd21e3d2feb374e37ff0fafbec09 (patch)
tree0bdc7f4a7e395b35b4633e5bd08afb155579fe6a /media-gfx/photivo/photivo-9999.ebuild
parentInitial commit for photivo. Move live ebuild from qt overlay. Bug #347707. Th... (diff)
downloadhistorical-126e954ec89dfd21e3d2feb374e37ff0fafbec09.tar.gz
historical-126e954ec89dfd21e3d2feb374e37ff0fafbec09.tar.bz2
historical-126e954ec89dfd21e3d2feb374e37ff0fafbec09.zip
Initial commit for photivo. Move live ebuild from qt overlay. Bug #347707. Thanks to Marios Andreopoulos <opensource@andmarios.com>
Package-Manager: portage-2.1.11.33/cvs/Linux x86_64 Manifest-Sign-Key: 0xB4AFF2C2
Diffstat (limited to 'media-gfx/photivo/photivo-9999.ebuild')
-rw-r--r--media-gfx/photivo/photivo-9999.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/media-gfx/photivo/photivo-9999.ebuild b/media-gfx/photivo/photivo-9999.ebuild
new file mode 100644
index 000000000000..d8837db2518d
--- /dev/null
+++ b/media-gfx/photivo/photivo-9999.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/photivo/photivo-9999.ebuild,v 1.1 2012/12/09 12:16:37 hwoarang Exp $
+
+EAPI=4
+
+inherit qt4-r2 mercurial
+
+DESCRIPTION="Photo processor for RAW and Bitmap images"
+HOMEPAGE="http://www.photivo.org"
+EHG_REPO_URI="https://photivo.googlecode.com/hg/"
+EHG_REVISION="default"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="gimp"
+
+RDEPEND="x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ || ( media-libs/jpeg:62 media-libs/libjpeg-turbo )
+ media-gfx/exiv2
+ media-libs/cimg
+ media-libs/lcms:2
+ media-libs/lensfun
+ sci-libs/fftw:3.0
+ media-libs/liblqr
+ media-gfx/graphicsmagick[q16,-lcms]
+ gimp? ( media-gfx/gimp )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/hg
+
+src_prepare() {
+ # remove ccache dependency
+ local File
+ for File in $(find "${S}" -type f); do
+ if grep -sq ccache ${File}; then
+ sed -e 's/ccache//' -i "${File}"
+ fi
+ done
+
+ # useless check (no pkgconfig file is provided)
+ sed -e "/PKGCONFIG += CImg/d" \
+ -i photivoProject/photivoProject.pro || die
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local config="WithSystemCImg"
+ if ! use gimp ; then
+ config+=" WithoutGimp"
+ fi
+
+ eqmake4 "CONFIG+=${config}"
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ if use gimp; then
+ exeinto $(gimptool-2.0 --gimpplugindir)/plug-ins
+ doexe ptGimp
+ doexe "mm extern photivo.py"
+ fi
+}