summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-07 22:08:09 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-07 22:08:09 +0000
commitfc35ea6cb76c8d37de6d5d88bf08cc1e958975f5 (patch)
tree9a0c4d155b6f45e4700c7e93ca9c02e43225bcf2 /media-gfx/blender
parentFix use invocation (diff)
downloadhistorical-fc35ea6cb76c8d37de6d5d88bf08cc1e958975f5.tar.gz
historical-fc35ea6cb76c8d37de6d5d88bf08cc1e958975f5.tar.bz2
historical-fc35ea6cb76c8d37de6d5d88bf08cc1e958975f5.zip
Fix use invocation
Diffstat (limited to 'media-gfx/blender')
-rw-r--r--media-gfx/blender/ChangeLog6
-rw-r--r--media-gfx/blender/blender-2.28.ebuild18
-rw-r--r--media-gfx/blender/blender-2.28a.ebuild18
-rw-r--r--media-gfx/blender/blender-2.28c.ebuild18
4 files changed, 32 insertions, 28 deletions
diff --git a/media-gfx/blender/ChangeLog b/media-gfx/blender/ChangeLog
index e7a009f6f0bb..05730cdd2264 100644
--- a/media-gfx/blender/ChangeLog
+++ b/media-gfx/blender/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/blender
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/ChangeLog,v 1.32 2004/04/27 21:40:49 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/ChangeLog,v 1.33 2004/06/07 22:08:09 agriffis Exp $
+
+ 07 Jun 2004; Aron Griffis <agriffis@gentoo.org> blender-2.28.ebuild,
+ blender-2.28a.ebuild, blender-2.28c.ebuild:
+ Fix use invocation
27 Apr 2004; Aron Griffis <agriffis@gentoo.org> blender-2.28c.ebuild,
blender-2.30.ebuild, blender-2.31.ebuild, blender-2.31a.ebuild,
diff --git a/media-gfx/blender/blender-2.28.ebuild b/media-gfx/blender/blender-2.28.ebuild
index 07aa3f29f504..d7843eda92b2 100644
--- a/media-gfx/blender/blender-2.28.ebuild
+++ b/media-gfx/blender/blender-2.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/blender-2.28.ebuild,v 1.4 2004/03/21 09:40:34 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/blender-2.28.ebuild,v 1.5 2004/06/07 22:08:09 agriffis Exp $
inherit flag-o-matic
replace-flags -march=pentium4 -march=pentium3
@@ -33,50 +33,50 @@ src_compile() {
local myconf=""
# SDL Support
- if [ -n "`use sdl`" ]
+ if use sdl
then
myconf="${myconf} --with-sdl=/usr"
fi
# JPG Support (Should be there by default, but I'll put it in anyways)
- if [ -n "`use jpeg`" ]
+ if use jpeg
then
myconf="${myconf} --with-libjpeg=/usr"
fi
# PNG Support (Same as above)
- if [ -n "`use png`" ]
+ if use png
then
myconf="${myconf} --with-libpng=/usr"
fi
# ./configure points at the wrong mozilla directories and will fail
# with this enabled. (A simple patch should take care of this)
- #if [ -n "`use mozilla`" ]
+ #if use mozilla
#then
# myconf="${myconf} --with-mozilla=/usr"
#fi
# TrueType support (For text objects)
- if [ -n "`use truetype`" ]
+ if use truetype
then
myconf="${myconf} --with-freetype2=/usr"
fi
# Build Staticly
- if [ -n "`use blender-static`" ]
+ if use blender-static
then
myconf="${myconf} --enable-blenderstatic"
fi
# Build the game engine (Fails in 2.28)
- if [ -n "`use blender-game`" ]
+ if use blender-game
then
myconf="${myconf} --enable-gameblender"
fi
# Build the plugin (Will probably fail, especially without mozilla)
- if [ -n "`use blender-plugin`" ]
+ if use blender-plugin
then
myconf="${myconf} --enable-blenderplugin"
fi
diff --git a/media-gfx/blender/blender-2.28a.ebuild b/media-gfx/blender/blender-2.28a.ebuild
index b381bcc48d38..b316fae7eced 100644
--- a/media-gfx/blender/blender-2.28a.ebuild
+++ b/media-gfx/blender/blender-2.28a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/blender-2.28a.ebuild,v 1.3 2004/03/21 09:40:34 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/blender-2.28a.ebuild,v 1.4 2004/06/07 22:08:09 agriffis Exp $
inherit flag-o-matic
replace-flags -march=pentium4 -march=pentium3
@@ -33,50 +33,50 @@ src_compile() {
local myconf=""
# SDL Support
- if [ -n "`use sdl`" ]
+ if use sdl
then
myconf="${myconf} --with-sdl=/usr"
fi
# JPG Support (Should be there by default, but I'll put it in anyways)
- if [ -n "`use jpeg`" ]
+ if use jpeg
then
myconf="${myconf} --with-libjpeg=/usr"
fi
# PNG Support (Same as above)
- if [ -n "`use png`" ]
+ if use png
then
myconf="${myconf} --with-libpng=/usr"
fi
# ./configure points at the wrong mozilla directories and will fail
# with this enabled. (A simple patch should take care of this)
- #if [ -n "`use mozilla`" ]
+ #if use mozilla
#then
# myconf="${myconf} --with-mozilla=/usr"
#fi
# TrueType support (For text objects)
- if [ -n "`use truetype`" ]
+ if use truetype
then
myconf="${myconf} --with-freetype2=/usr"
fi
# Build Staticly
- if [ -n "`use blender-static`" ]
+ if use blender-static
then
myconf="${myconf} --enable-blenderstatic"
fi
# Build the game engine (Fails in 2.28)
- if [ -n "`use blender-game`" ]
+ if use blender-game
then
myconf="${myconf} --enable-gameblender"
fi
# Build the plugin (Will probably fail, especially without mozilla)
- if [ -n "`use blender-plugin`" ]
+ if use blender-plugin
then
myconf="${myconf} --enable-blenderplugin"
fi
diff --git a/media-gfx/blender/blender-2.28c.ebuild b/media-gfx/blender/blender-2.28c.ebuild
index f77d9e1f8dd3..59d0e1c5d2cb 100644
--- a/media-gfx/blender/blender-2.28c.ebuild
+++ b/media-gfx/blender/blender-2.28c.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/blender-2.28c.ebuild,v 1.5 2004/04/27 21:40:49 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/blender-2.28c.ebuild,v 1.6 2004/06/07 22:08:09 agriffis Exp $
inherit flag-o-matic eutils
replace-flags -march=pentium4 -march=pentium3
@@ -40,50 +40,50 @@ src_compile() {
local myconf=""
# SDL Support
- if [ -n "`use sdl`" ]
+ if use sdl
then
myconf="${myconf} --with-sdl=/usr"
fi
# JPG Support (Should be there by default, but I'll put it in anyways)
- if [ -n "`use jpeg`" ]
+ if use jpeg
then
myconf="${myconf} --with-libjpeg=/usr"
fi
# PNG Support (Same as above)
- if [ -n "`use png`" ]
+ if use png
then
myconf="${myconf} --with-libpng=/usr"
fi
# ./configure points at the wrong mozilla directories and will fail
# with this enabled. (A simple patch should take care of this)
- if [ -n "`use mozilla`" ]
+ if use mozilla
then
myconf="${myconf} --with-mozilla=/usr"
fi
# TrueType support (For text objects)
- if [ -n "`use truetype`" ]
+ if use truetype
then
myconf="${myconf} --with-freetype2=/usr"
fi
# Build Staticly
- if [ -n "`use static`" ]
+ if use static
then
myconf="${myconf} --enable-blenderstatic"
fi
# Build the game engine (Fails in 2.28)
- #if [ -n "`use blender-game`" ]
+ #if use blender-game
#then
# myconf="${myconf} --enable-gameblender"
#fi
# Build the plugin (Will fail, requires gameblender)
- #if [ -n "`use blender-plugin`" ]
+ #if use blender-plugin
#then
# myconf="${myconf} --enable-blenderplugin"
#fi