summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2003-09-29 23:27:37 +0000
committerLuca Barbato <lu_zero@gentoo.org>2003-09-29 23:27:37 +0000
commitb64b73f5559a6b80209a2fe0934920650a457d9b (patch)
treef2202895e4fc20b0da50ad0db5068a8b1cc2e6b9 /media-gfx/blender
parentVersion Bump (diff)
downloadhistorical-b64b73f5559a6b80209a2fe0934920650a457d9b.tar.gz
historical-b64b73f5559a6b80209a2fe0934920650a457d9b.tar.bz2
historical-b64b73f5559a6b80209a2fe0934920650a457d9b.zip
Version Bump
Diffstat (limited to 'media-gfx/blender')
-rw-r--r--media-gfx/blender/Manifest6
-rw-r--r--media-gfx/blender/blender-2.28.ebuild63
-rw-r--r--media-gfx/blender/blender-2.28a.ebuild89
-rw-r--r--media-gfx/blender/files/digest-blender-2.28a1
4 files changed, 155 insertions, 4 deletions
diff --git a/media-gfx/blender/Manifest b/media-gfx/blender/Manifest
index 9a3314b513f3..ee56856f8103 100644
--- a/media-gfx/blender/Manifest
+++ b/media-gfx/blender/Manifest
@@ -1,8 +1,8 @@
-MD5 e9ff87d45f16fb322ff0c48e5c27a30a ChangeLog 2204
-MD5 a1eb309d0e49732c58593f26f8d62064 blender-2.28a.ebuild 2341
+MD5 faff44db620340e240c65e092a6b7c58 ChangeLog 2204
+MD5 09559b4b2aa8fbab7e5af43a176f3207 blender-2.28a.ebuild 2342
MD5 ecab9de91cc4b34b45b458106b829968 blender-2.26.ebuild 648
MD5 ed130114bbcba0dbc4dbe9e36dc31e97 blender-2.27.ebuild 648
-MD5 a1eb309d0e49732c58593f26f8d62064 blender-2.28.ebuild 2341
+MD5 70757412470746539ae26ed8a79d1e4a blender-2.28.ebuild 2341
MD5 b85001a84dca16ebd1b349e4bd715e06 blender-2.23-r1.ebuild 1098
MD5 a855ab3ef355897d6896804f54ce21bd files/blender-2.12 36
MD5 21158d7f37f745ab78dcb437e3f5fac7 files/digest-blender-2.28 66
diff --git a/media-gfx/blender/blender-2.28.ebuild b/media-gfx/blender/blender-2.28.ebuild
index c9f6e7deb5a2..e286ee8db989 100644
--- a/media-gfx/blender/blender-2.28.ebuild
+++ b/media-gfx/blender/blender-2.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/blender-2.28.ebuild,v 1.1 2003/07/26 19:41:31 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/blender-2.28.ebuild,v 1.2 2003/09/29 23:26:51 lu_zero Exp $
inherit flag-o-matic
replace-flags -march=pentium4 -march=pentium3
@@ -17,12 +17,73 @@ LICENSE="GPL-2 | BL"
KEYWORDS="~x86 ~ppc"
DEPEND="virtual/x11
+ blender-game? ( dev-games/ode )
+ sdl? ( media-libs/libsdl )
+ jpeg? ( media-libs/jpeg )
+ png? ( media-libs/libpng )
+ mozilla? ( net-www/mozilla )
+ truetype? ( >=freetype-2.0 )
+ fmod? ( media-libs/fmod )
>=openal-20020127
>=libsdl-1.2
>=libvorbis-1.0
>=openssl-0.9.6"
+src_compile() {
+ local myconf=""
+ # SDL Support
+ if [ -n "`use sdl`" ]
+ then
+ myconf="${myconf} --with-sdl=/usr"
+ fi
+
+ # JPG Support (Should be there by default, but I'll put it in anyways)
+ if [ -n "`use jpeg`" ]
+ then
+ myconf="${myconf} --with-libjpeg=/usr"
+ fi
+
+ # PNG Support (Same as above)
+ if [ -n "`use png`" ]
+ then
+ myconf="${myconf} --with-libpng=/usr"
+ fi
+
+ # ./configure points at the wrong mozilla directories and will fail
+ # with this enabled. (A simple patch should take care of this)
+ #if [ -n "`use mozilla`" ]
+ #then
+ # myconf="${myconf} --with-mozilla=/usr"
+ #fi
+
+ # TrueType support (For text objects)
+ if [ -n "`use truetype`" ]
+ then
+ myconf="${myconf} --with-freetype2=/usr"
+ fi
+
+ # Build Staticly
+ if [ -n "`use blender-static`" ]
+ then
+ myconf="${myconf} --enable-blenderstatic"
+ fi
+
+ # Build the game engine (Fails in 2.28)
+ if [ -n "`use blender-game`" ]
+ then
+ myconf="${myconf} --enable-gameblender"
+ fi
+
+ # Build the plugin (Will probably fail, especially without mozilla)
+ if [ -n "`use blender-plugin`" ]
+ then
+ myconf="${myconf} --enable-blenderplugin"
+ fi
+
+ econf ${myconf} || die
+ emake || die
+}
src_install() {
einstall || die
}
diff --git a/media-gfx/blender/blender-2.28a.ebuild b/media-gfx/blender/blender-2.28a.ebuild
new file mode 100644
index 000000000000..9275d94b667f
--- /dev/null
+++ b/media-gfx/blender/blender-2.28a.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/blender-2.28a.ebuild,v 1.1 2003/09/29 23:26:51 lu_zero Exp $
+
+inherit flag-o-matic
+replace-flags -march=pentium4 -march=pentium3
+
+IUSE=""
+
+S=${WORKDIR}/${P}
+DESCRIPTION="3D Creation/Animation/Publishing System"
+HOMEPAGE="http://www.blender.org/"
+SRC_URI="http://download.blender.org/source/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2 | BL"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="virtual/x11
+ blender-game? ( dev-games/ode )
+ sdl? ( media-libs/libsdl )
+ jpeg? ( media-libs/jpeg )
+ png? ( media-libs/libpng )
+ mozilla? ( net-www/mozilla )
+ truetype? ( >=freetype-2.0 )
+ fmod? ( media-libs/fmod )
+ >=openal-20020127
+ >=libsdl-1.2
+ >=libvorbis-1.0
+ >=openssl-0.9.6"
+
+src_compile() {
+ local myconf=""
+
+ # SDL Support
+ if [ -n "`use sdl`" ]
+ then
+ myconf="${myconf} --with-sdl=/usr"
+ fi
+
+ # JPG Support (Should be there by default, but I'll put it in anyways)
+ if [ -n "`use jpeg`" ]
+ then
+ myconf="${myconf} --with-libjpeg=/usr"
+ fi
+
+ # PNG Support (Same as above)
+ if [ -n "`use png`" ]
+ then
+ myconf="${myconf} --with-libpng=/usr"
+ fi
+
+ # ./configure points at the wrong mozilla directories and will fail
+ # with this enabled. (A simple patch should take care of this)
+ #if [ -n "`use mozilla`" ]
+ #then
+ # myconf="${myconf} --with-mozilla=/usr"
+ #fi
+
+ # TrueType support (For text objects)
+ if [ -n "`use truetype`" ]
+ then
+ myconf="${myconf} --with-freetype2=/usr"
+ fi
+
+ # Build Staticly
+ if [ -n "`use blender-static`" ]
+ then
+ myconf="${myconf} --enable-blenderstatic"
+ fi
+
+ # Build the game engine (Fails in 2.28)
+ if [ -n "`use blender-game`" ]
+ then
+ myconf="${myconf} --enable-gameblender"
+ fi
+
+ # Build the plugin (Will probably fail, especially without mozilla)
+ if [ -n "`use blender-plugin`" ]
+ then
+ myconf="${myconf} --enable-blenderplugin"
+ fi
+
+ econf ${myconf} || die
+ emake || die
+}
+src_install() {
+ einstall || die
+}
diff --git a/media-gfx/blender/files/digest-blender-2.28a b/media-gfx/blender/files/digest-blender-2.28a
new file mode 100644
index 000000000000..da72a75671d1
--- /dev/null
+++ b/media-gfx/blender/files/digest-blender-2.28a
@@ -0,0 +1 @@
+MD5 c68c0f761cb840767e6ad22819e9d175 blender-2.28a.tar.bz2 4757584