summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorScott W Taylor <swtaylor@gentoo.org>2004-11-16 23:34:09 +0000
committerScott W Taylor <swtaylor@gentoo.org>2004-11-16 23:34:09 +0000
commit22e6361d71849c459d67f504b193953d689efc5d (patch)
tree6f2bc8e2b6630e78f93f88e1590cc7d2f316a7ec /mail-mta
parentVersion bumps for cvs based ebuilds. (diff)
downloadhistorical-22e6361d71849c459d67f504b193953d689efc5d.tar.gz
historical-22e6361d71849c459d67f504b193953d689efc5d.tar.bz2
historical-22e6361d71849c459d67f504b193953d689efc5d.zip
enable maildropldap
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/courier/ChangeLog6
-rw-r--r--mail-mta/courier/Manifest4
-rw-r--r--mail-mta/courier/courier-0.47.20041113.ebuild23
3 files changed, 23 insertions, 10 deletions
diff --git a/mail-mta/courier/ChangeLog b/mail-mta/courier/ChangeLog
index 4ce3cbbc3791..2ac537f93bd2 100644
--- a/mail-mta/courier/ChangeLog
+++ b/mail-mta/courier/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-mta/courier
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/ChangeLog,v 1.23 2004/11/16 08:47:46 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/ChangeLog,v 1.24 2004/11/16 23:34:09 swtaylor Exp $
+
+ 16 Nov 2004; Scott W Taylor <swtaylor@gentoo.org>
+ courier-0.47.20041113.ebuild:
+ add maildropldap
*courier-0.47.20041113 (16 Nov 2004)
diff --git a/mail-mta/courier/Manifest b/mail-mta/courier/Manifest
index adeb9fd6d2a9..d17db5a6a8ad 100644
--- a/mail-mta/courier/Manifest
+++ b/mail-mta/courier/Manifest
@@ -1,11 +1,11 @@
-MD5 e55244a2764aa620f87c19b392e1e7ce courier-0.47.20041113.ebuild 9509
+MD5 4b3e9e61a0ae8d2a64193a472197372f courier-0.47.20041113.ebuild 9824
MD5 b6f5e2a53855850e07291061a7f416ab courier-0.47.ebuild 10452
MD5 d4687331805cb345c9a2d8a4e9d378c7 courier-0.46.ebuild 9771
MD5 f5d9aedcd49226196f2c35273f45488f courier-0.46.20040825.ebuild 10012
MD5 2c9b2ac349116b05205ba423fc01ac15 courier-0.46.20040816.ebuild 10012
MD5 5463e630d0d43bed171473ae01d30dd4 courier-0.46.20040902.ebuild 10015
MD5 b8368687c56e9fa6d7efff0ddba8f848 courier-0.45.6.ebuild 9772
-MD5 02d786d2e9309caa64b056de9a7dec94 ChangeLog 14014
+MD5 17632fad063289c9578682f608b2146e ChangeLog 14118
MD5 b287829e2f9edbcf1ff7bb349055e77e metadata.xml 392
MD5 52f032e570c6f5f9f69b4e4bdfa562a1 files/password.dist 247
MD5 a546a21f960e4f921e71f614f719a2ce files/bofh 23
diff --git a/mail-mta/courier/courier-0.47.20041113.ebuild b/mail-mta/courier/courier-0.47.20041113.ebuild
index a52fe1b478f2..e1b82aeaf2b5 100644
--- a/mail-mta/courier/courier-0.47.20041113.ebuild
+++ b/mail-mta/courier/courier-0.47.20041113.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.47.20041113.ebuild,v 1.1 2004/11/16 08:47:46 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/courier/courier-0.47.20041113.ebuild,v 1.2 2004/11/16 23:34:09 swtaylor Exp $
inherit eutils
@@ -12,7 +12,7 @@ SLOT="0"
LICENSE="GPL-2"
#KEYWORDS="~x86 ~alpha ~ppc ~sparc ~amd64 ~mips"
KEYWORDS="-*"
-IUSE="postgres ldap mysql pam nls ipv6 spell fax crypt norewrite uclibc"
+IUSE="postgres ldap mysql pam nls ipv6 spell fax crypt norewrite uclibc mailwrapper"
PROVIDE="virtual/mta
virtual/mda
@@ -29,7 +29,8 @@ DEPEND="virtual/libc
ldap? ( >=net-nds/openldap-1.2.11 )
postgres? ( >=dev-db/postgresql-7.1.3 )
spell? ( virtual/aspell-dict )
- !virtual/mta
+ !mailwrapper? ( !virtual/mta )
+ mailwrapper? ( >=net-mail/mailwrapper-0.2 )
!virtual/mda
!virtual/imapd"
@@ -48,7 +49,9 @@ src_unpack() {
src_compile() {
local myconf
- myconf="`use_with spell ispell` `use_with ipv6`"
+ myconf="`use_with spell ispell` `use_with ipv6` `use_enable ldap maildropldap`"
+
+ use ldap && myconf="${myconf} --with-ldapconfig=/etc/courier/maildrop.ldaprc"
if use nls && [ ! -z "$ENABLE_UNICODE" ]; then
myconf="${myconf} --enable-unicode=$ENABLE_UNICODE"
@@ -58,7 +61,7 @@ src_compile() {
myconf="${myconf} debug=true"
-einfo "${myconf}"
+ einfo "Building courier with: ${myconf}"
./configure \
--prefix=/usr \
@@ -204,8 +207,14 @@ src_install() {
insopts -m 400 -o mail -g mail
doins ${FILESDIR}/password.dist
- # fixes bug #25028 courier doesn't symlink sendmail to /usr/sbin
- dosym /usr/bin/sendmail /usr/sbin/sendmail
+ if use mailwrapper ; then
+ mv ${D}/usr/bin/sendmail ${D}/usr/bin/sendmail.courier
+ rm ${D}/usr/bin/rmail
+ insinto /etc/mail
+ doins ${FILESDIR}/mailer.conf
+ else
+ dosym /usr/bin/sendmail /usr/sbin/sendmail
+ fi
echo "MAILDIR=\$HOME/.maildir" >> ${D}/etc/courier/courierd