summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2005-08-19 22:46:57 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2005-08-19 22:46:57 +0000
commite774c5462f81c6813346d4a3fde55d50ae90d76f (patch)
treec62324dafac7813e20c8bb4a05c2cde1bd2ebf27 /mail-mta/nbsmtp/nbsmtp-1.00-r2.ebuild
parentNew release: 2.11.2 (diff)
downloadhistorical-e774c5462f81c6813346d4a3fde55d50ae90d76f.tar.gz
historical-e774c5462f81c6813346d4a3fde55d50ae90d76f.tar.bz2
historical-e774c5462f81c6813346d4a3fde55d50ae90d76f.zip
Bump to use emake instead of make. Also fix #102098 and #103051 by blocking virtual/mta and providing wrapper-nbsmtp. Remove -r1
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'mail-mta/nbsmtp/nbsmtp-1.00-r2.ebuild')
-rw-r--r--mail-mta/nbsmtp/nbsmtp-1.00-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/mail-mta/nbsmtp/nbsmtp-1.00-r2.ebuild b/mail-mta/nbsmtp/nbsmtp-1.00-r2.ebuild
new file mode 100644
index 000000000000..048afc43a50c
--- /dev/null
+++ b/mail-mta/nbsmtp/nbsmtp-1.00-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/nbsmtp/nbsmtp-1.00-r2.ebuild,v 1.1 2005/08/19 22:46:57 ferdy Exp $
+
+DESCRIPTION="Extremely simple MTA to get mail off the system to a relayhost"
+SRC_URI="http://www.gentoo-es.org/~ferdy/${P}.tar.bz2"
+HOMEPAGE="http://nbsmtp.ferdyx.org"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+IUSE="ssl ipv6 debug"
+
+DEPEND="virtual/libc
+ ssl? ( dev-libs/openssl )
+ !virtual/mta"
+
+PROVIDE="virtual/mta"
+
+src_compile() {
+ econf $(use_enable ssl) \
+ $(use_enable debug) \
+ $(use_enable ipv6) || die
+
+ emake || die
+}
+
+src_install() {
+ dodir /usr/{{s,}bin,lib}
+ dobin nbsmtp
+ dobin scripts/nbqueue
+ dobin scripts/wrapper-nbsmtp
+ doman nbsmtprc.5 nbsmtp.8
+ dodoc INSTALL DOCS Doxyfile
+
+ dohard /usr/bin/wrapper-nbsmtp /usr/bin/sendmail
+ dohard /usr/bin/wrapper-nbsmtp /usr/sbin/sendmail
+ dohard /usr/bin/wrapper-nbsmtp /usr/lib/sendmail
+ dohard /usr/bin/wrapper-nbsmtp /usr/bin/mailq
+ dohard /usr/bin/wrapper-nbsmtp /usr/bin/newaliases
+}