summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLim Swee Tat <st_lim@gentoo.org>2004-10-09 14:45:12 +0000
committerLim Swee Tat <st_lim@gentoo.org>2004-10-09 14:45:12 +0000
commit4d3ce995db2162460aee1f8aaee22c453ee9d1ee (patch)
treef88f55f22f3eea064a0248100ec2baf8614c8bf7 /mail-filter
parentAdded sparc stable keyword (diff)
downloadhistorical-4d3ce995db2162460aee1f8aaee22c453ee9d1ee.tar.gz
historical-4d3ce995db2162460aee1f8aaee22c453ee9d1ee.tar.bz2
historical-4d3ce995db2162460aee1f8aaee22c453ee9d1ee.zip
Added the UntrustedMailerArgs
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/dspam/ChangeLog5
-rw-r--r--mail-filter/dspam/Manifest4
-rw-r--r--mail-filter/dspam/dspam-3.2_rc2.ebuild15
3 files changed, 16 insertions, 8 deletions
diff --git a/mail-filter/dspam/ChangeLog b/mail-filter/dspam/ChangeLog
index ec37197c04b7..5346e7db7cc6 100644
--- a/mail-filter/dspam/ChangeLog
+++ b/mail-filter/dspam/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for mail-filter/dspam
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/ChangeLog,v 1.17 2004/10/09 04:40:13 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/ChangeLog,v 1.18 2004/10/09 14:45:12 st_lim Exp $
+
+ 09 Oct 2004; Lim Swee Tat <st_lim@gentoo.org> dspam-3.2_rc2.ebuild:
+ Changed the UntrustedMailerArgs
*dspam-3.2_rc2 (09 Oct 2004)
diff --git a/mail-filter/dspam/Manifest b/mail-filter/dspam/Manifest
index 5bd4e9de88f6..d8afaa3e33c8 100644
--- a/mail-filter/dspam/Manifest
+++ b/mail-filter/dspam/Manifest
@@ -1,10 +1,10 @@
-MD5 bc8ccbc4cf14222a942b0b906fdbbbf0 ChangeLog 3508
+MD5 771d3c380a4c2e907c7767afae59882d ChangeLog 3613
MD5 36789bb9f994a8cf598460b9f1d6c38d dspam-3.0.0.ebuild 6928
MD5 618c4611325b3d26857fa015512ea3dd dspam-3.1.0.ebuild 9316
MD5 7b1aab580ea90c0fba27ee37375d4f45 dspam-3.1.1.ebuild 15331
MD5 faea987ffc4a18b91cbd42a8a12fa875 dspam-3.1.2.ebuild 15331
MD5 5c3bfe2ca9051384c5e14e6ce3ff22f4 dspam-3.2_beta1.ebuild 15334
-MD5 d0c180f5cb5b9569f3cb062286f8a267 dspam-3.2_rc2.ebuild 15816
+MD5 5977b65b468c6784aa1d855606282905 dspam-3.2_rc2.ebuild 16147
MD5 dbfbe5a3bbe3347938107f5f5bd2197e metadata.xml 308
MD5 c12a54112c6fec3530a7b1a368d04ac8 files/README.postfix 309
MD5 e0469b961385fda4305602dc2519d319 files/README.qmail 2317
diff --git a/mail-filter/dspam/dspam-3.2_rc2.ebuild b/mail-filter/dspam/dspam-3.2_rc2.ebuild
index 53d4689766b3..a6837befa428 100644
--- a/mail-filter/dspam/dspam-3.2_rc2.ebuild
+++ b/mail-filter/dspam/dspam-3.2_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.2_rc2.ebuild,v 1.1 2004/10/09 04:40:13 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/dspam/dspam-3.2_rc2.ebuild,v 1.2 2004/10/09 14:45:12 st_lim Exp $
inherit eutils
@@ -181,13 +181,18 @@ src_install () {
echo "enableWhitelist=on") >${T}/default.prefs
echo "groupname:classification:*globaluser" >${T}/group
if use cyrus; then
- echo "/usr/lib/cyrus/deliver %u" > ${T}/untrusted.mailer_args
+ echo "UntrustedDeliveryAgent /usr/lib/cyrus/deliver %u" >> ${D}${HOMEDIR}/dspam.conf
+ sed -e 's:/usr/bin/procmail:/usr/lib/cyrus/deliver %u:g' \
+ -i ${D}${HOMEDIR}/dspam.conf
elif use exim; then
- echo "/usr/sbin/exim -oMr spam-scanned %u" > ${T}/untrusted.mailer_args
+ echo "UntrustedDeliveryAgent /usr/sbin/exim -oMr spam-scanned %u" >> ${D}${HOMEDIR}/dspam.conf
+ sed -e 's:/usr/bin/procmail:/usr/sbin/exim -oMr spam-scanned %u:g' \
+ -i ${D}${HOMEDIR}/dspam.conf
elif use courier; then
echo "/usr/bin/maildrop -d %u" > ${T}/untrusted.mailer_args
- elif use procmail; then
- echo "/usr/bin/procmail -d %u" > ${T}/untrusted.mailer_args
+ echo "UntrustedDeliveryAgent /usr/bin/maildrop -d %u" >> ${D}${HOMEDIR}/dspam.conf
+ sed -e 's:/usr/bin/procmail:/usr/bin/maildrop -d %u:g' \
+ -i ${D}${HOMEDIR}/dspam.conf
fi
# install some initial configuration