summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2008-06-30 07:20:27 +0000
committerChristian Faulhammer <fauli@gentoo.org>2008-06-30 07:20:27 +0000
commit1f31c07f8ac8c5e38cda6fc8bd36268e0b4ae552 (patch)
tree0c98c0c1b00bc14eb43f166e7f816c97625053e8 /mail-client
parentAdded an option, "Use secure file deletion if possible", which (diff)
downloadhistorical-1f31c07f8ac8c5e38cda6fc8bd36268e0b4ae552.tar.gz
historical-1f31c07f8ac8c5e38cda6fc8bd36268e0b4ae552.tar.bz2
historical-1f31c07f8ac8c5e38cda6fc8bd36268e0b4ae552.zip
version bump
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/claws-mail-gtkhtml/ChangeLog8
-rw-r--r--mail-client/claws-mail-gtkhtml/claws-mail-gtkhtml-0.19.ebuild34
-rw-r--r--mail-client/claws-mail-notification/ChangeLog8
-rw-r--r--mail-client/claws-mail-notification/claws-mail-notification-0.17.ebuild33
-rw-r--r--mail-client/claws-mail-rssyl/ChangeLog8
-rw-r--r--mail-client/claws-mail-rssyl/claws-mail-rssyl-0.20.ebuild34
-rw-r--r--mail-client/claws-mail-smime/ChangeLog8
-rw-r--r--mail-client/claws-mail-smime/claws-mail-smime-0.7.6.ebuild27
8 files changed, 156 insertions, 4 deletions
diff --git a/mail-client/claws-mail-gtkhtml/ChangeLog b/mail-client/claws-mail-gtkhtml/ChangeLog
index 63c3080840e2..1b7102a776dc 100644
--- a/mail-client/claws-mail-gtkhtml/ChangeLog
+++ b/mail-client/claws-mail-gtkhtml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/claws-mail-gtkhtml
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-gtkhtml/ChangeLog,v 1.36 2008/06/23 06:56:24 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-gtkhtml/ChangeLog,v 1.37 2008/06/30 07:13:23 opfer Exp $
+
+*claws-mail-gtkhtml-0.19 (30 Jun 2008)
+
+ 30 Jun 2008; Christian Faulhammer <opfer@gentoo.org>
+ +claws-mail-gtkhtml-0.19.ebuild:
+ version bump
23 Jun 2008; Christian Faulhammer <opfer@gentoo.org>
claws-mail-gtkhtml-0.18.ebuild:
diff --git a/mail-client/claws-mail-gtkhtml/claws-mail-gtkhtml-0.19.ebuild b/mail-client/claws-mail-gtkhtml/claws-mail-gtkhtml-0.19.ebuild
new file mode 100644
index 000000000000..e27ac782fd8b
--- /dev/null
+++ b/mail-client/claws-mail-gtkhtml/claws-mail-gtkhtml-0.19.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-gtkhtml/claws-mail-gtkhtml-0.19.ebuild,v 1.1 2008/06/30 07:13:23 opfer Exp $
+
+inherit eutils
+
+MY_P="${PN#claws-mail-}2_viewer-${PV}"
+
+DESCRIPTION="Renders HTML mail using the gtkhtml2 rendering widget."
+HOMEPAGE="http://www.claws-mail.org/"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+RDEPEND=">=mail-client/claws-mail-3.5.0
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf --disable-accessibility
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # kill useless files
+ rm -f "${D}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}
diff --git a/mail-client/claws-mail-notification/ChangeLog b/mail-client/claws-mail-notification/ChangeLog
index c98fcf1bf8be..07fa8570b939 100644
--- a/mail-client/claws-mail-notification/ChangeLog
+++ b/mail-client/claws-mail-notification/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/claws-mail-notification
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-notification/ChangeLog,v 1.21 2008/06/23 07:01:53 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-notification/ChangeLog,v 1.22 2008/06/30 07:15:33 opfer Exp $
+
+*claws-mail-notification-0.17 (30 Jun 2008)
+
+ 30 Jun 2008; Christian Faulhammer <opfer@gentoo.org>
+ +claws-mail-notification-0.17.ebuild:
+ version bump
23 Jun 2008; Christian Faulhammer <opfer@gentoo.org>
-claws-mail-notification-0.12.ebuild,
diff --git a/mail-client/claws-mail-notification/claws-mail-notification-0.17.ebuild b/mail-client/claws-mail-notification/claws-mail-notification-0.17.ebuild
new file mode 100644
index 000000000000..873651b45eb9
--- /dev/null
+++ b/mail-client/claws-mail-notification/claws-mail-notification-0.17.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-notification/claws-mail-notification-0.17.ebuild,v 1.1 2008/06/30 07:15:33 opfer Exp $
+
+MY_P="${PN#claws-mail-}_plugin-${PV}"
+
+DESCRIPTION="Plugin providing various ways to notify user of new and unread mail"
+HOMEPAGE="http://www.claws-mail.org/"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+RDEPEND=">=mail-client/claws-mail-3.5.0
+ >=x11-libs/gtk+-2.10
+ libnotify? ( x11-libs/libnotify )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf $(use_enable libnotify) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # kill useless files
+ rm -f "${D}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}
diff --git a/mail-client/claws-mail-rssyl/ChangeLog b/mail-client/claws-mail-rssyl/ChangeLog
index 724fdd4272bf..7a242b639d2a 100644
--- a/mail-client/claws-mail-rssyl/ChangeLog
+++ b/mail-client/claws-mail-rssyl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/claws-mail-rssyl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-rssyl/ChangeLog,v 1.32 2008/06/23 07:07:34 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-rssyl/ChangeLog,v 1.33 2008/06/30 07:18:33 opfer Exp $
+
+*claws-mail-rssyl-0.20 (30 Jun 2008)
+
+ 30 Jun 2008; Christian Faulhammer <opfer@gentoo.org>
+ +claws-mail-rssyl-0.20.ebuild:
+ version bump
23 Jun 2008; Christian Faulhammer <opfer@gentoo.org>
-claws-mail-rssyl-0.15.ebuild, -claws-mail-rssyl-0.16.ebuild,
diff --git a/mail-client/claws-mail-rssyl/claws-mail-rssyl-0.20.ebuild b/mail-client/claws-mail-rssyl/claws-mail-rssyl-0.20.ebuild
new file mode 100644
index 000000000000..f83ebabe4901
--- /dev/null
+++ b/mail-client/claws-mail-rssyl/claws-mail-rssyl-0.20.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-rssyl/claws-mail-rssyl-0.20.ebuild,v 1.1 2008/06/30 07:18:33 opfer Exp $
+
+MY_P="${P#claws-mail-}"
+
+DESCRIPTION="Read your favorite newsfeeds in Claws Mail. RSS 1.0, 2.0 and Atom feeds are currently supported"
+HOMEPAGE="http://www.claws-mail.org/"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="nls"
+RDEPEND=">=mail-client/claws-mail-3.5.0
+ net-misc/curl
+ dev-libs/libxml2
+ nls? ( >=sys-devel/gettext-0.12.1 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog README
+
+ # kill useless files
+ rm -f "${D}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}
diff --git a/mail-client/claws-mail-smime/ChangeLog b/mail-client/claws-mail-smime/ChangeLog
index 04937c887a21..1393d200aad5 100644
--- a/mail-client/claws-mail-smime/ChangeLog
+++ b/mail-client/claws-mail-smime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/claws-mail-smime
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-smime/ChangeLog,v 1.25 2008/06/23 07:08:58 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-smime/ChangeLog,v 1.26 2008/06/30 07:20:27 opfer Exp $
+
+*claws-mail-smime-0.7.6 (30 Jun 2008)
+
+ 30 Jun 2008; Christian Faulhammer <opfer@gentoo.org>
+ +claws-mail-smime-0.7.6.ebuild:
+ version bump
23 Jun 2008; Christian Faulhammer <opfer@gentoo.org>
-claws-mail-smime-0.7.2.ebuild, -claws-mail-smime-0.7.3.ebuild,
diff --git a/mail-client/claws-mail-smime/claws-mail-smime-0.7.6.ebuild b/mail-client/claws-mail-smime/claws-mail-smime-0.7.6.ebuild
new file mode 100644
index 000000000000..8a90c4f08e2c
--- /dev/null
+++ b/mail-client/claws-mail-smime/claws-mail-smime-0.7.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-smime/claws-mail-smime-0.7.6.ebuild,v 1.1 2008/06/30 07:20:27 opfer Exp $
+
+MY_P="${P#claws-mail-}"
+
+DESCRIPTION="This plugin allows you to handle S/MIME signed and/or encrypted mails"
+HOMEPAGE="http://www.claws-mail.org/"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+RDEPEND=">=mail-client/claws-mail-3.5.0
+ >=app-crypt/gpgme-1.1.1"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog NEWS README
+
+ # kill useless files
+ rm -f "${D}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}