summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTuan Van <langthang@gentoo.org>2006-03-14 23:09:59 +0000
committerTuan Van <langthang@gentoo.org>2006-03-14 23:09:59 +0000
commitcb34aae9af894436d987e8b6094dda2327164ff0 (patch)
tree996c57700f5b167ee8c60979a16b9b14881a7304 /mail-client/mailx-support/mailx-support-20060102-r1.ebuild
parentI added the mirror listed in bug #123986. Closing bug #123986. (diff)
downloadhistorical-cb34aae9af894436d987e8b6094dda2327164ff0.tar.gz
historical-cb34aae9af894436d987e8b6094dda2327164ff0.tar.bz2
historical-cb34aae9af894436d987e8b6094dda2327164ff0.zip
QA bug #126061, reported by Sandro <sanchan@gentoo.org>.
Patch by Diego Pettenò <flameeyes@gentoo.org>. Package-Manager: portage-2.1_pre5-r4
Diffstat (limited to 'mail-client/mailx-support/mailx-support-20060102-r1.ebuild')
-rw-r--r--mail-client/mailx-support/mailx-support-20060102-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/mail-client/mailx-support/mailx-support-20060102-r1.ebuild b/mail-client/mailx-support/mailx-support-20060102-r1.ebuild
new file mode 100644
index 000000000000..0d92cee2a816
--- /dev/null
+++ b/mail-client/mailx-support/mailx-support-20060102-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mailx-support/mailx-support-20060102-r1.ebuild,v 1.1 2006/03/14 23:09:58 langthang Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Provides mail.local and lockspool"
+HOMEPAGE="http://www.openbsd.org/"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}/${P}-respect-ldflags.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" BINDNOW_FLAGS="$(bindnow-flags)" || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+}