summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPavel Kazakov <nullishzero@gentoo.org>2013-12-23 07:44:19 +0000
committerPavel Kazakov <nullishzero@gentoo.org>2013-12-23 07:44:19 +0000
commitf760f2ab978a2f5694e479da5a590631086d24ac (patch)
treee9e3dd36ded5773098374a836d1f0fbb4c82805e /lxde-base/lxdm/files
parentMongoDB is a massive compile: 12GB in my portage build dir, and 2.4G on disk.... (diff)
downloadhistorical-f760f2ab978a2f5694e479da5a590631086d24ac.tar.gz
historical-f760f2ab978a2f5694e479da5a590631086d24ac.tar.bz2
historical-f760f2ab978a2f5694e479da5a590631086d24ac.zip
Make pam a conditional subdirectory; bug #469512
Package-Manager: portage-2.2.7/cvs/Linux x86_64 Manifest-Sign-Key: 0x39E7AB2E
Diffstat (limited to 'lxde-base/lxdm/files')
-rw-r--r--lxde-base/lxdm/files/lxdm-0.4.1-fix-optional-pam.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/lxde-base/lxdm/files/lxdm-0.4.1-fix-optional-pam.patch b/lxde-base/lxdm/files/lxdm-0.4.1-fix-optional-pam.patch
new file mode 100644
index 000000000000..0aecc08593dc
--- /dev/null
+++ b/lxde-base/lxdm/files/lxdm-0.4.1-fix-optional-pam.patch
@@ -0,0 +1,31 @@
+diff --git a/Makefile.am b/Makefile.am
+index bfac56b..40710fc 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -2,10 +2,13 @@ NULL =
+ SUBDIRS= \
+ src \
+ po \
+- pam \
+ data \
+ $(NULL)
+
++if HAVE_PAM
++SUBDIRS += pam
++endif
++
+ rpm: dist @PACKAGE_NAME@.spec
+ rpmbuild -bb \
+ --define "_sourcedir `pwd`" \
+diff --git a/configure.ac b/configure.ac
+index ae5177f..aaa1bad 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -27,6 +27,7 @@ if test "x$USE_PAM" != "xno" ; then
+ AC_MSG_ERROR(["PAM support requested, but pam_open_session not found."])
+ fi])
+ fi
++AM_CONDITIONAL(HAVE_PAM, [test -n "$USE_PAM" -a "x$USE_PAM" != xno ])
+
+ # Checks for header files.
+ AC_PATH_X