summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-06-28 17:16:12 +0000
committerDan Armak <danarmak@gentoo.org>2002-06-28 17:16:12 +0000
commitd239034e2b2323785c8a1a0df41ed2a8c19646ba (patch)
tree0348a0e35695c90ef939d9edbd1294bb2c8ea884 /kde-base
parenttypo fix, SLOT, and LICENSE (diff)
downloadhistorical-d239034e2b2323785c8a1a0df41ed2a8c19646ba.tar.gz
historical-d239034e2b2323785c8a1a0df41ed2a8c19646ba.tar.bz2
historical-d239034e2b2323785c8a1a0df41ed2a8c19646ba.zip
fix #3827 in upcoming 3.0.2 release. add verwilst's patch for his gcc 3.1/antialiasing problem.
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdebase/files/kdebase-3.0.2-fonts.cpp.patch44
-rw-r--r--kde-base/kdebase/files/startkde-3.0.2-gentoo.diff45
-rw-r--r--kde-base/kdebase/kdebase-3.0.2.ebuild5
3 files changed, 70 insertions, 24 deletions
diff --git a/kde-base/kdebase/files/kdebase-3.0.2-fonts.cpp.patch b/kde-base/kdebase/files/kdebase-3.0.2-fonts.cpp.patch
new file mode 100644
index 000000000000..1c87fc46cd1f
--- /dev/null
+++ b/kde-base/kdebase/files/kdebase-3.0.2-fonts.cpp.patch
@@ -0,0 +1,44 @@
+--- kcontrol/fonts/fonts.cpp Fri Jun 28 09:49:12 2002
++++ kcontrol/fonts/fonts.cpp Fri Jun 28 09:52:21 2002
+@@ -6,7 +6,7 @@
+ //
+ // Ported to kcontrol2 by Geert Jansen.
+
+-/* $Id: kdebase-3.0.2-fonts.cpp.patch,v 1.1 2002/06/28 17:16:12 danarmak Exp $ */
++/* $Id: kdebase-3.0.2-fonts.cpp.patch,v 1.1 2002/06/28 17:16:12 danarmak Exp $ */
+
+ #include <qlayout.h>
+ #include <qlabel.h>
+@@ -146,7 +146,7 @@
+
+ void FontUseItem::updateLabel()
+ {
+- QString fontDesc = _font.family() + ' ' + QString::number(_font.pointSize());
++ QString fontDesc = _font.family() + " " + QString::number(_font.pointSize());
+ preview->setText(fontDesc);
+ preview->setFont(_font);
+ }
+@@ -227,15 +227,19 @@
+ QLabel * preview = new QLabel(this);
+ preview->setFrameStyle(QFrame::StyledPanel | QFrame::Sunken);
+ // preview->setMaximumWidth(200);
++ QString name = *it; it++;
++ QString group = *it; it++;
++ QString key = *it; it++;
++ QString file = *it; it++;
+
+ FontUseItem * i =
+ new FontUseItem(
+ this,
+ preview,
+- *it++,
+- *it++,
+- *it++,
+- *it++,
++ name,
++ group,
++ key,
++ file,
+ *defaultFontIt++,
+ *fixedListIt++
+ );
diff --git a/kde-base/kdebase/files/startkde-3.0.2-gentoo.diff b/kde-base/kdebase/files/startkde-3.0.2-gentoo.diff
index 37d82df140d0..f43b5cd3af7c 100644
--- a/kde-base/kdebase/files/startkde-3.0.2-gentoo.diff
+++ b/kde-base/kdebase/files/startkde-3.0.2-gentoo.diff
@@ -1,29 +1,36 @@
---- startkde.orig Fri Jun 28 09:34:00 2002
-+++ startkde Fri Jun 28 09:35:45 2002
-@@ -1,8 +1,20 @@
--#!/bin/sh
-+#!/bin/sh --login
+--- startkde Mon Jun 24 14:54:36 2002
++++ startkde Fri Jun 28 19:25:38 2002
+@@ -1,8 +1,22 @@
+ #!/bin/sh
#
-# DEFAULT KDE STARTUP SCRIPT ( KDE-3.0.2 )
-+# Gentoo KDE Startup Script ( KDE-3.0.2 )
++# GENTOO CUSTOMIZED KDE STARTUP SCRIPT ( KDE-3.0.2 )
#
+# Gentoo part:
-+export PATH="/usr/kde/3/bin:${PATH}"
-+export KDEDIR="/usr/kde/3"
-+export KDEDIRS="/usr/kde/3:${KDEDIRS}"
-+export KDEMAINDIR="/usr/kde/3"
-+rm -rf ~/.kde
-+ln -fs ~/.kde3 ~/.kde
-+[ -e "~/.kde3" ] || mkdir ~/.kde3
++export PATH="_KDEDIR_/bin:${PATH}"
++export KDEDIR="_KDEDIR_"
++export KDEDIRS="_KDEDIR_:${KDEDIRS}"
++export KDEMAINDIR="_KDEDIR_"
+
++cd ~
++[ -d .kde ] && mv .kde .kde.backup
++[ -e .kde3 ] || mkdir .kde3
++ln -sf .kde3 .kde
++export KDEHOME="${HOME}/.kde3"
+
-+# Original KDE part:
++# Gentoo part ends
+
# Boot sequence:
#
# kdeinit is used to fork off processes which improves memory usage
-@@ -30,14 +42,14 @@
+@@ -25,12 +39,12 @@
+ # especially necessary on slow machines, where starting KDE takes one or two
+ # minutes until anything appears on the screen.
+ #
+-# Set the background to plain grey.
++# Set the background to cyan (Gentoo version change).
+ # The standard X background is nasty, causing moire effects and exploding
# people's heads. We use colours from the standard KDE palette for those with
# palettised displays.
@@ -32,11 +39,3 @@
xsetroot -cursor_name left_ptr $bkg
# The user's personal KDE directory is usually ~/.kde, but this setting
- # may be overridden by setting KDEHOME.
-
- kdehome=$HOME/.kde
--test -n "$KDEHOME" && kdehome=`echo "$KDEHOME"|sed "s,^\~/,$HOME/,"`
-+test -n "$KDEHOME" && eval kdehome=$KDEHOME
-
- # Activate the kde font directories.
- #
diff --git a/kde-base/kdebase/kdebase-3.0.2.ebuild b/kde-base/kdebase/kdebase-3.0.2.ebuild
index ba468074ba15..726da61c0a15 100644
--- a/kde-base/kdebase/kdebase-3.0.2.ebuild
+++ b/kde-base/kdebase/kdebase-3.0.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Authors Dan Armak <danarmak@gentoo.org>, Bart Verwilst <verwilst@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.0.2.ebuild,v 1.1 2002/06/27 19:33:43 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.0.2.ebuild,v 1.2 2002/06/28 17:16:12 danarmak Exp $
inherit kde-dist
@@ -33,6 +33,9 @@ use opengl && myconf="$myconf --with-gl" || myconf="$myconf --without-gl"
use ssl && myconf="$myconf --with-ssl" || myconf="$myconf --without-ssl"
use pam && myconf="$myconf --with-pam=yes" || myconf="$myconf --with-pam=no --with-shadow"
+# fix for verwilst's gcc 3.1 & antialiasing problem
+PATCHES="$FILESDIR/${P}-fonts.cpp.patch"
+
src_install() {
kde_src_install