summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-04-03 23:43:56 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-04-03 23:43:56 +0000
commit6c0845bdf07869eb131f8ef436303c1f31196d0b (patch)
tree5c46566a5031c12d90459b1fff061951009dc77e /kde-base
parentAdd patches for bug #86446 (crash on logout) and for bug #87485 (handling of ... (diff)
downloadhistorical-6c0845bdf07869eb131f8ef436303c1f31196d0b.tar.gz
historical-6c0845bdf07869eb131f8ef436303c1f31196d0b.tar.bz2
historical-6c0845bdf07869eb131f8ef436303c1f31196d0b.zip
Fix patch.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdenetwork/Manifest2
-rw-r--r--kde-base/kdenetwork/files/kdenetwork-3.4.0-kopete-spaces.patch281
-rw-r--r--kde-base/kopete/Manifest8
3 files changed, 12 insertions, 279 deletions
diff --git a/kde-base/kdenetwork/Manifest b/kde-base/kdenetwork/Manifest
index 566bd010f4a0..5eb8acd1e7ec 100644
--- a/kde-base/kdenetwork/Manifest
+++ b/kde-base/kdenetwork/Manifest
@@ -15,7 +15,7 @@ MD5 c72f00859a8536c527d040173f92d3f4 files/kdenetwork-3.4.0-kopete-logout.patch
MD5 8dae5eac25d478ebf23279132c4a0ead files/digest-kdenetwork-3.3.2 70
MD5 3939e85ee43aba114cc3ece4194145b6 files/reslisa.conf 340
MD5 72eca9b8637e868d730399e0becc045d files/digest-kdenetwork-3.2.3 70
-MD5 d272c023453f42fe190bfed26a1378e4 files/kdenetwork-3.4.0-kopete-spaces.patch 17289
+MD5 f8624841efe576b99f71c604af307bbf files/kdenetwork-3.4.0-kopete-spaces.patch 8084
MD5 d97100af0cb95f733660b7a61492d71f files/lisa.conf 452
MD5 622d3497792334fa87e483e249da693d files/digest-kdenetwork-3.4.0 70
MD5 a0086a72d069c5606f1e2ea81b98fea8 files/digest-kdenetwork-3.3.1-r1 70
diff --git a/kde-base/kdenetwork/files/kdenetwork-3.4.0-kopete-spaces.patch b/kde-base/kdenetwork/files/kdenetwork-3.4.0-kopete-spaces.patch
index 6358c0947fd8..26c8382f3684 100644
--- a/kde-base/kdenetwork/files/kdenetwork-3.4.0-kopete-spaces.patch
+++ b/kde-base/kdenetwork/files/kdenetwork-3.4.0-kopete-spaces.patch
@@ -1,6 +1,6 @@
diff -Nur kdenetwork-3.4.0.orig/kopete/protocols/oscar/aim/aimcontact.cpp kdenetwork-3.4.0/kopete/protocols/oscar/aim/aimcontact.cpp
--- kdenetwork-3.4.0.orig/kopete/protocols/oscar/aim/aimcontact.cpp 2005-02-23 11:30:54.000000000 +0100
-+++ kdenetwork-3.4.0/kopete/protocols/oscar/aim/aimcontact.cpp 2005-04-04 00:13:50.000000000 +0200
++++ kdenetwork-3.4.0/kopete/protocols/oscar/aim/aimcontact.cpp 2005-04-04 01:41:26.000000000 +0200
@@ -145,7 +145,7 @@
void AIMContact::userInfoUpdated( const QString& contact, const UserDetails& details )
@@ -37,280 +37,9 @@ diff -Nur kdenetwork-3.4.0.orig/kopete/protocols/oscar/aim/aimcontact.cpp kdenet
return;
setProperty( mProtocol->clientProfile, profile );
-diff -Nur kdenetwork-3.4.0.orig/kopete/protocols/oscar/aim/aimcontact.cpp.orig kdenetwork-3.4.0/kopete/protocols/oscar/aim/aimcontact.cpp.orig
---- kdenetwork-3.4.0.orig/kopete/protocols/oscar/aim/aimcontact.cpp.orig 1970-01-01 01:00:00.000000000 +0100
-+++ kdenetwork-3.4.0/kopete/protocols/oscar/aim/aimcontact.cpp.orig 2005-02-23 11:30:54.000000000 +0100
-@@ -0,0 +1,267 @@
-+/*
-+ aimcontact.cpp - Oscar Protocol Plugin
-+
-+ Copyright (c) 2003 by Will Stephenson
-+ Kopete (c) 2002-2004 by the Kopete developers <kopete-devel@kde.org>
-+
-+ *************************************************************************
-+ * *
-+ * This program is free software; you can redistribute it and/or modify *
-+ * it under the terms of the GNU General Public License as published by *
-+ * the Free Software Foundation; either version 2 of the License, or *
-+ * (at your option) any later version. *
-+ * *
-+ *************************************************************************
-+*/
-+
-+#include <time.h>
-+
-+#include <qapplication.h>
-+#include <qregexp.h>
-+
-+#include <kactionclasses.h>
-+#include <klocale.h>
-+#include <kdebug.h>
-+#include <kmessagebox.h>
-+
-+#include "kopeteaway.h"
-+#include "kopetemessagemanager.h"
-+#include "kopeteuiglobal.h"
-+#include "kopetemetacontact.h"
-+
-+//liboscar
-+#include "client.h"
-+#include "oscartypes.h"
-+#include "oscarutils.h"
-+
-+#include "aimprotocol.h"
-+#include "aimuserinfo.h"
-+#include "aimcontact.h"
-+#include "aimaccount.h"
-+
-+AIMContact::AIMContact( Kopete::Account* account, const QString& name, Kopete::MetaContact* parent,
-+ const QString& icon, const Oscar::SSI& ssiItem )
-+: OscarContact(account, name, parent, icon, ssiItem )
-+{
-+ mProtocol=static_cast<AIMProtocol *>(protocol());
-+ setOnlineStatus( mProtocol->statusOffline );
-+
-+ m_infoDialog = 0L;
-+ m_warnUserAction = 0L;
-+ mUserProfile="";
-+ m_haveAwayMessage = false;
-+
-+ QObject::connect( mAccount->engine(), SIGNAL( receivedUserInfo( const QString&, const UserDetails& ) ),
-+ this, SLOT( userInfoUpdated( const QString&, const UserDetails& ) ) );
-+ //QObject::connect( mAccount->engine(), SIGNAL( userIsOnline( const QString& ) ), this, SLOT( userOnline( const QString& ) ) );
-+ QObject::connect( mAccount->engine(), SIGNAL( userIsOffline( const QString& ) ), this, SLOT( userOffline( const QString& ) ) );
-+ QObject::connect( mAccount->engine(), SIGNAL( receivedAwayMessage( const QString&, const QString& ) ),
-+ this, SLOT( updateAwayMessage( const QString&, const QString& ) ) );
-+ QObject::connect( mAccount->engine(), SIGNAL( receivedProfile( const QString&, const QString& ) ),
-+ this, SLOT( updateProfile( const QString&, const QString& ) ) );
-+ QObject::connect( mAccount->engine(), SIGNAL( userWarned( const QString&, Q_UINT16, Q_UINT16 ) ),
-+ this, SLOT( gotWarning( const QString&, Q_UINT16, Q_UINT16 ) ) );
-+}
-+
-+AIMContact::~AIMContact()
-+{
-+}
-+
-+bool AIMContact::isReachable()
-+{
-+ return true;
-+}
-+
-+QPtrList<KAction> *AIMContact::customContextMenuActions()
-+{
-+
-+ QPtrList<KAction> *actionCollection = new QPtrList<KAction>();
-+ if ( !m_warnUserAction )
-+ {
-+ m_warnUserAction = new KAction( i18n( "&Warn User" ), 0, this, SLOT( warnUser() ), this, "warnAction" );
-+ }
-+
-+ m_warnUserAction->setEnabled( account()->isConnected() );
-+
-+ actionCollection->append( m_warnUserAction );
-+ return actionCollection;
-+}
-+
-+const QString AIMContact::awayMessage()
-+{
-+ return property(mProtocol->awayMessage).value().toString();
-+}
-+
-+void AIMContact::setAwayMessage(const QString &message)
-+{
-+ kdDebug(14152) << k_funcinfo <<
-+ "Called for '" << contactId() << "', away msg='" << message << "'" << endl;
-+ QString filteredMessage = message;
-+ filteredMessage.replace(
-+ QRegExp(QString::fromLatin1("<[hH][tT][mM][lL].*>(.*)</[hH][tT][mM][lL]>")),
-+ QString::fromLatin1("\\1"));
-+ filteredMessage.replace(
-+ QRegExp(QString::fromLatin1("<[bB][oO][dD][yY].*>(.*)</[bB][oO][dD][yY]>")),
-+ QString::fromLatin1("\\1") );
-+ filteredMessage.replace(
-+ QRegExp(QString::fromLatin1("<[fF][oO][nN][tT].*>(.*)</[fF][oO][nN][tT]>")),
-+ QString::fromLatin1("\\1") );
-+ setProperty(mProtocol->awayMessage, filteredMessage);
-+}
-+
-+int AIMContact::warningLevel() const
-+{
-+ return m_warningLevel;
-+}
-+
-+void AIMContact::updateSSIItem()
-+{
-+ if ( m_ssiItem.type() != 0xFFFF && m_ssiItem.waitingAuth() == false &&
-+ onlineStatus() == Kopete::OnlineStatus::Unknown )
-+ {
-+ //make sure they're offline
-+ setOnlineStatus( static_cast<AIMProtocol*>( protocol() )->statusOffline );
-+ }
-+}
-+
-+void AIMContact::slotUserInfo()
-+{
-+ if ( !m_infoDialog)
-+ {
-+ m_infoDialog = new AIMUserInfoDialog( this, static_cast<AIMAccount*>( account() ), false, Kopete::UI::Global::mainWidget(), 0 );
-+ if( !m_infoDialog )
-+ return;
-+ connect( m_infoDialog, SIGNAL( finished() ), this, SLOT( closeUserInfoDialog() ) );
-+ m_infoDialog->show();
-+ if ( mAccount->isConnected() )
-+ {
-+ mAccount->engine()->requestAIMProfile( contactId() );
-+ mAccount->engine()->requestAIMAwayMessage( contactId() );
-+ }
-+ }
-+ else
-+ m_infoDialog->raise();
-+}
-+
-+void AIMContact::userInfoUpdated( const QString& contact, const UserDetails& details )
-+{
-+ if ( contact.lower() != contactId().lower() )
-+ return;
-+
-+ kdDebug(OSCAR_RAW_DEBUG) << k_funcinfo << contact << endl;
-+
-+ //if they don't have an SSI alias, make sure we use the capitalization from the
-+ //server so their contact id looks all pretty.
-+ QString nickname = property( Kopete::Global::Properties::self()->nickName() ).value().toString();
-+ if ( Oscar::normalize( nickname ) == Oscar::normalize( details.userId() ) )
-+ setProperty( Kopete::Global::Properties::self()->nickName(), details.userId() );
-+
-+ if ( ( details.userClass() & 32 ) == 0 )
-+ {
-+ setOnlineStatus( mProtocol->statusOnline ); //we're online
-+ removeProperty( mProtocol->awayMessage );
-+ m_haveAwayMessage = false;
-+ }
-+ else
-+ {
-+ setOnlineStatus( mProtocol->statusAway ); //we're away
-+ if ( !m_haveAwayMessage ) //prevent cyclic away message requests
-+ {
-+ mAccount->engine()->requestAIMAwayMessage( contactId() );
-+ m_haveAwayMessage = true;
-+ }
-+ }
-+
-+ OscarContact::userInfoUpdated( contact, details );
-+}
-+
-+
-+
-+void AIMContact::userOnline( const QString& userId )
-+{
-+ if ( userId.lower() == contactId().lower() )
-+ {
-+ kdDebug(OSCAR_RAW_DEBUG) << k_funcinfo << "Getting more contact info" << endl;
-+ setOnlineStatus( mProtocol->statusOnline );
-+ }
-+}
-+
-+void AIMContact::userOffline( const QString& userId )
-+{
-+ if ( Oscar::normalize( userId ) == Oscar::normalize( contactId() ) )
-+ {
-+ setOnlineStatus( mProtocol->statusOffline );
-+ removeProperty( mProtocol->awayMessage );
-+ }
-+}
-+
-+void AIMContact::updateAwayMessage( const QString& contact, const QString& message )
-+{
-+ if ( contact.lower() != contactId().lower() )
-+ return;
-+ else
-+ {
-+ if ( message.isEmpty() )
-+ {
-+ removeProperty( mProtocol->awayMessage );
-+ setOnlineStatus( mProtocol->statusOnline );
-+ m_haveAwayMessage = false;
-+ }
-+ else
-+ {
-+ m_haveAwayMessage = true;
-+ setAwayMessage( message );
-+ setOnlineStatus( mProtocol->statusAway );
-+ }
-+ }
-+
-+ emit updatedProfile();
-+}
-+
-+void AIMContact::updateProfile( const QString& contact, const QString& profile )
-+{
-+ if ( contact.lower() != contactId().lower() )
-+ return;
-+
-+ setProperty( mProtocol->clientProfile, profile );
-+ emit updatedProfile();
-+}
-+
-+void AIMContact::gotWarning( const QString& contact, Q_UINT16 increase, Q_UINT16 newLevel )
-+{
-+ //somebody just got bitchslapped! :O
-+ Q_UNUSED( increase );
-+ if ( Oscar::normalize( contact ) == Oscar::normalize( contactId() ) )
-+ m_warningLevel = newLevel;
-+
-+ //TODO add a KNotify event after merge to HEAD
-+}
-+
-+void AIMContact::closeUserInfoDialog()
-+{
-+ m_infoDialog->delayedDestruct();
-+ m_infoDialog = 0L;
-+}
-+
-+void AIMContact::warnUser()
-+{
-+ QString nick = property( Kopete::Global::Properties::self()->nickName() ).value().toString();
-+ QString message = i18n( "<qt>Would you like to warn %1 anonymously or with your name?<br>" \
-+ "(Warning a user on AIM will result in a \"Warning Level\"" \
-+ " increasing for the user you warn. Once this level has reached a" \
-+ " certain point, they will not be able to sign on. Please do not abuse" \
-+ " this function, it is meant for legitimate practices.)</qt>" ).arg( nick );
-+
-+
-+ int result = KMessageBox::questionYesNoCancel( Kopete::UI::Global::mainWidget(), message,
-+ i18n( "Warn User %1?" ).arg( nick ),
-+ i18n( "Warn Anonymously" ), i18n( "Warn" ) );
-+
-+ if ( result == KMessageBox::Yes )
-+ mAccount->engine()->sendWarning( contactId(), true);
-+ else if ( result == KMessageBox::No )
-+ mAccount->engine()->sendWarning( contactId(), false);
-+}
-+
-+#include "aimcontact.moc"
-+//kate: tab-width 4; indent-mode csands;
diff -Nur kdenetwork-3.4.0.orig/kopete/protocols/oscar/icq/icqcontact.cpp kdenetwork-3.4.0/kopete/protocols/oscar/icq/icqcontact.cpp
--- kdenetwork-3.4.0.orig/kopete/protocols/oscar/icq/icqcontact.cpp 2005-02-03 23:52:07.000000000 +0100
-+++ kdenetwork-3.4.0/kopete/protocols/oscar/icq/icqcontact.cpp 2005-04-04 00:13:50.000000000 +0200
++++ kdenetwork-3.4.0/kopete/protocols/oscar/icq/icqcontact.cpp 2005-04-04 01:41:26.000000000 +0200
@@ -106,7 +106,7 @@
void ICQContact::userOnline( const QString& userId )
@@ -376,7 +105,7 @@ diff -Nur kdenetwork-3.4.0.orig/kopete/protocols/oscar/icq/icqcontact.cpp kdenet
ICQShortInfo shortInfo = mAccount->engine()->getShortInfo( contact );
diff -Nur kdenetwork-3.4.0.orig/kopete/protocols/oscar/liboscar/ssiauthtask.cpp kdenetwork-3.4.0/kopete/protocols/oscar/liboscar/ssiauthtask.cpp
--- kdenetwork-3.4.0.orig/kopete/protocols/oscar/liboscar/ssiauthtask.cpp 2005-01-30 16:09:38.000000000 +0100
-+++ kdenetwork-3.4.0/kopete/protocols/oscar/liboscar/ssiauthtask.cpp 2005-04-04 00:13:50.000000000 +0200
++++ kdenetwork-3.4.0/kopete/protocols/oscar/liboscar/ssiauthtask.cpp 2005-04-04 01:41:26.000000000 +0200
@@ -21,6 +21,7 @@
#include "transfer.h"
#include "buffer.h"
@@ -423,7 +152,7 @@ diff -Nur kdenetwork-3.4.0.orig/kopete/protocols/oscar/liboscar/ssiauthtask.cpp
emit contactAddedYou( uin );
diff -Nur kdenetwork-3.4.0.orig/kopete/protocols/oscar/liboscar/ssilisttask.cpp kdenetwork-3.4.0/kopete/protocols/oscar/liboscar/ssilisttask.cpp
--- kdenetwork-3.4.0.orig/kopete/protocols/oscar/liboscar/ssilisttask.cpp 2005-01-25 16:10:19.000000000 +0100
-+++ kdenetwork-3.4.0/kopete/protocols/oscar/liboscar/ssilisttask.cpp 2005-04-04 00:13:50.000000000 +0200
++++ kdenetwork-3.4.0/kopete/protocols/oscar/liboscar/ssilisttask.cpp 2005-04-04 01:41:26.000000000 +0200
@@ -110,6 +110,9 @@
tlvList.append( t );
}
@@ -436,7 +165,7 @@ diff -Nur kdenetwork-3.4.0.orig/kopete/protocols/oscar/liboscar/ssilisttask.cpp
diff -Nur kdenetwork-3.4.0.orig/kopete/protocols/oscar/liboscar/ssimodifytask.cpp kdenetwork-3.4.0/kopete/protocols/oscar/liboscar/ssimodifytask.cpp
--- kdenetwork-3.4.0.orig/kopete/protocols/oscar/liboscar/ssimodifytask.cpp 2005-02-01 20:41:08.000000000 +0100
-+++ kdenetwork-3.4.0/kopete/protocols/oscar/liboscar/ssimodifytask.cpp 2005-04-04 00:13:50.000000000 +0200
++++ kdenetwork-3.4.0/kopete/protocols/oscar/liboscar/ssimodifytask.cpp 2005-04-04 01:41:26.000000000 +0200
@@ -41,7 +41,7 @@
{
}
diff --git a/kde-base/kopete/Manifest b/kde-base/kopete/Manifest
index 88a0819083f2..40742b93093b 100644
--- a/kde-base/kopete/Manifest
+++ b/kde-base/kopete/Manifest
@@ -1,6 +1,10 @@
-MD5 d67c8207f08c5bee877f44ab13ef2981 ChangeLog 1304
MD5 14889ab75f97d76e58b0c1154e7683a9 metadata.xml 161
-MD5 13f2e5a34a0ce548345d2b47c9801747 kopete-3.4.0_rc1.ebuild 422
+MD5 32a360888be08a69d8210662183145dd kopete-3.4.0-r1.ebuild 648
MD5 a1fcf20c08c25ac6bfa0230ecdc38f4a kopete-3.4.0.ebuild 430
+MD5 2ae54f3343c63758adb75537ccd24149 ChangeLog 1608
+MD5 13f2e5a34a0ce548345d2b47c9801747 kopete-3.4.0_rc1.ebuild 422
+MD5 c72f00859a8536c527d040173f92d3f4 files/kdenetwork-3.4.0-kopete-logout.patch 20923
+MD5 f8624841efe576b99f71c604af307bbf files/kdenetwork-3.4.0-kopete-spaces.patch 8084
MD5 ee82ae945549a695ca5353dd33e3ce47 files/digest-kopete-3.4.0_rc1 389
+MD5 622d3497792334fa87e483e249da693d files/digest-kopete-3.4.0-r1 70
MD5 622d3497792334fa87e483e249da693d files/digest-kopete-3.4.0 70