summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 13:23:06 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 13:23:06 +0000
commitfb6446ec2ae71d8604a2605b5e0a7741800234b9 (patch)
treef541678afd1386deac67794ab2dccf4e07d2e82c /kde-base/kmail/kmail-3.5.5.ebuild
parentVersion bump to 009, imported from breakmygentoo.net (Thanks Peter Hyman!). ... (diff)
downloadhistorical-fb6446ec2ae71d8604a2605b5e0a7741800234b9.tar.gz
historical-fb6446ec2ae71d8604a2605b5e0a7741800234b9.tar.bz2
historical-fb6446ec2ae71d8604a2605b5e0a7741800234b9.zip
Bump to 3.5.5 (pre-release).
Package-Manager: portage-2.1.2_pre2-r1
Diffstat (limited to 'kde-base/kmail/kmail-3.5.5.ebuild')
-rw-r--r--kde-base/kmail/kmail-3.5.5.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/kde-base/kmail/kmail-3.5.5.ebuild b/kde-base/kmail/kmail-3.5.5.ebuild
new file mode 100644
index 000000000000..95ace76b6d99
--- /dev/null
+++ b/kde-base/kmail/kmail-3.5.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-3.5.5.ebuild,v 1.1 2006/10/03 11:06:58 flameeyes Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_DIR="${SRC_DIR}
+ mirror://gentoo/kdepim-3.5-patchset-02.tar.bz2"
+
+DESCRIPTION="KDE mail client"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt"
+DEPEND="$(deprange 3.5.4 $MAXKDEVER kde-base/libkdenetwork)
+ $(deprange $PV $MAXKDEVER kde-base/libkdepim)
+ $(deprange $PV $MAXKDEVER kde-base/libkpimidentities)
+ $(deprange 3.5.4 $MAXKDEVER kde-base/mimelib)
+ $(deprange 3.5.0 $MAXKDEVER kde-base/libksieve)
+ $(deprange $PV $MAXKDEVER kde-base/certmanager)
+ $(deprange $PV $MAXKDEVER kde-base/libkcal)
+ $(deprange $PV $MAXKDEVER kde-base/kontact)
+ $(deprange 3.5.4 $MAXKDEVER kde-base/libkpgp)
+ $(deprange 3.5.3 $MAXKDEVER kde-base/libkmime)"
+RDEPEND="${DEPEND}
+ crypt? ( app-crypt/pinentry )
+ $(deprange $PV $MAXKDEVER kde-base/kdepim-kioslaves)
+ $(deprange $PV $MAXKDEVER kde-base/kmailcvt)
+ $(deprange-dual $PV $MAXKDEVER kde-base/kdebase-kioslaves)
+ $(deprange-dual $PV $MAXKDEVER kde-base/kcontrol)" # for the "looknfeel" icon, and probably others.
+
+KMCOPYLIB="
+ libkdepim libkdepim/
+ libkpimidentities libkpimidentities/
+ libmimelib mimelib/
+ libksieve libksieve/
+ libkleopatra certmanager/lib/
+ libkcal libkcal
+ libkpinterfaces kontact/interfaces/
+ libkmime libkmime
+ libkpgp libkpgp"
+KMEXTRACTONLY="
+ libkdenetwork/
+ libkdepim/
+ libkpimidentities/
+ libksieve/
+ libkcal/
+ mimelib/
+ certmanager/
+ korganizer/korganizeriface.h
+ kontact/interfaces/
+ libkmime/
+ libkpgp
+ dcopidlng"
+KMCOMPILEONLY="libemailfunctions"
+# the kmail plugins are installed with kmail
+KMEXTRA="plugins/kmail/
+ kontact/plugins/kmail/" # We add here the kontact's plugin instead of compiling it with kontact because it needs a lot of this programs deps.
+
+src_unpack() {
+ kde-meta_src_unpack
+
+ sed -i -e 's:lib_LTLIBRARIES:noinst_LTLIBRARIES:' \
+ "${S}/indexlib/Makefile.am"
+}