summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-10-12 13:32:54 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-10-12 13:32:54 +0000
commitfe1059f8c562d3bf4a890036ca21bc47431453a9 (patch)
tree94909a9c006294c8c3c2b8980bde61d28c6e5dee /kde-base/kdeutils
parentClock skew fix for AMD64 X2, and update to Linux 2.6.13.4 (diff)
downloadhistorical-fe1059f8c562d3bf4a890036ca21bc47431453a9.tar.gz
historical-fe1059f8c562d3bf4a890036ca21bc47431453a9.tar.bz2
historical-fe1059f8c562d3bf4a890036ca21bc47431453a9.zip
New version.
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'kde-base/kdeutils')
-rw-r--r--kde-base/kdeutils/ChangeLog7
-rw-r--r--kde-base/kdeutils/files/digest-kdeutils-3.4.31
-rw-r--r--kde-base/kdeutils/kdeutils-3.4.3.ebuild35
3 files changed, 42 insertions, 1 deletions
diff --git a/kde-base/kdeutils/ChangeLog b/kde-base/kdeutils/ChangeLog
index cff3b5e62d1d..0b7155a41617 100644
--- a/kde-base/kdeutils/ChangeLog
+++ b/kde-base/kdeutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdeutils
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeutils/ChangeLog,v 1.129 2005/10/06 23:27:51 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeutils/ChangeLog,v 1.130 2005/10/12 13:28:37 greg_g Exp $
+
+*kdeutils-3.4.3 (12 Oct 2005)
+
+ 12 Oct 2005; Gregorio Guidi <greg_g@gentoo.org> +kdeutils-3.4.3.ebuild:
+ New version.
06 Oct 2005; Hardave Riar <hardave@gentoo.org> kdeutils-3.4.2.ebuild:
Keyworded ~mips.
diff --git a/kde-base/kdeutils/files/digest-kdeutils-3.4.3 b/kde-base/kdeutils/files/digest-kdeutils-3.4.3
new file mode 100644
index 000000000000..0b8cb3d8d2fe
--- /dev/null
+++ b/kde-base/kdeutils/files/digest-kdeutils-3.4.3
@@ -0,0 +1 @@
+MD5 d467284b523bb1268da776cd016ede4d kdeutils-3.4.3.tar.bz2 2257060
diff --git a/kde-base/kdeutils/kdeutils-3.4.3.ebuild b/kde-base/kdeutils/kdeutils-3.4.3.ebuild
new file mode 100644
index 000000000000..7471463d674c
--- /dev/null
+++ b/kde-base/kdeutils/kdeutils-3.4.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeutils/kdeutils-3.4.3.ebuild,v 1.1 2005/10/12 13:28:37 greg_g Exp $
+
+inherit kde-dist eutils
+
+DESCRIPTION="KDE utilities"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="crypt snmp pbbuttonsd"
+
+DEPEND="~kde-base/kdebase-${PV}
+ snmp? ( net-analyzer/net-snmp )
+ pbbuttonsd? ( app-laptop/pbbuttonsd )"
+
+RDEPEND="${DEPEND}
+ crypt? ( app-crypt/gnupg )"
+
+src_unpack() {
+ kde_src_unpack
+
+ # Configure patch. Applied for 3.5.
+ epatch "${FILESDIR}/kdeutils-3.4-configure.patch"
+
+ # For the configure patch.
+ make -f admin/Makefile.common || die
+}
+
+src_compile() {
+ local myconf="$(use_with snmp) $(use_with pbbuttonsd powerbook)"
+
+ use crypt || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kgpg"
+
+ kde_src_compile
+}