summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-08-01 22:17:38 +0000
committerJohannes Huber <johu@gentoo.org>2012-08-01 22:17:38 +0000
commit881e446ad159543c84e6f5710f10814c66f875f3 (patch)
treefb5718e17dbc5a4f0b570ece0495be9a82fb2ced /kde-base/kdepim-runtime
parentversion bump for bug 424525, ebuild provided by Ortwin Glück (diff)
downloadhistorical-881e446ad159543c84e6f5710f10814c66f875f3.tar.gz
historical-881e446ad159543c84e6f5710f10814c66f875f3.tar.bz2
historical-881e446ad159543c84e6f5710f10814c66f875f3.zip
Version bump KDE SC 4.9.0
Package-Manager: portage-2.2.0_alpha120/cvs/Linux x86_64
Diffstat (limited to 'kde-base/kdepim-runtime')
-rw-r--r--kde-base/kdepim-runtime/ChangeLog8
-rw-r--r--kde-base/kdepim-runtime/kdepim-runtime-4.9.0.ebuild52
-rw-r--r--kde-base/kdepim-runtime/metadata.xml3
3 files changed, 62 insertions, 1 deletions
diff --git a/kde-base/kdepim-runtime/ChangeLog b/kde-base/kdepim-runtime/ChangeLog
index 33d409a9dddb..f9a03c5c6b31 100644
--- a/kde-base/kdepim-runtime/ChangeLog
+++ b/kde-base/kdepim-runtime/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepim-runtime
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.82 2012/06/21 21:54:44 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/ChangeLog,v 1.83 2012/08/01 22:17:09 johu Exp $
+
+*kdepim-runtime-4.9.0 (01 Aug 2012)
+
+ 01 Aug 2012; Johannes Huber <johu@gentoo.org> +kdepim-runtime-4.9.0.ebuild,
+ metadata.xml:
+ Version bump KDE SC 4.9.0
*kdepim-runtime-4.8.4 (21 Jun 2012)
diff --git a/kde-base/kdepim-runtime/kdepim-runtime-4.9.0.ebuild b/kde-base/kdepim-runtime/kdepim-runtime-4.9.0.ebuild
new file mode 100644
index 000000000000..3ad428fd86c8
--- /dev/null
+++ b/kde-base/kdepim-runtime/kdepim-runtime-4.9.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-runtime/kdepim-runtime-4.9.0.ebuild,v 1.1 2012/08/01 22:17:09 johu Exp $
+
+EAPI=4
+
+KMNAME="kdepim-runtime"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="KDE PIM runtime plugin collection"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug google kolab"
+
+RESTRICT="test"
+# Would need test programs _testrunner and akonaditest from kdepimlibs, see bug 313233
+
+DEPEND="
+ app-misc/strigi
+ >=app-office/akonadi-server-1.8.0
+ dev-libs/boost
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=dev-libs/shared-desktop-ontologies-0.10.0
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ x11-misc/shared-mime-info
+ google? ( >=net-libs/libkgapi-0.4.0[-oldpim] )
+ kolab? ( net-libs/libkolab )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kdepim-icons)
+ !kde-misc/akonadi-google
+"
+
+# nepomuk_email_feeder moved here in 4.8
+add_blocker kdepim-common-libs 4.7.50
+
+src_prepare() {
+ sed -e "s:find_package(LibKGAPI QUIET NO_MODULE):macro_optional_find_package(LibKGAPI):g" \
+ -i "${S}/CMakeLists.txt" || die "fixing automagic dependencies failed"
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with google LibKGAPI)
+ $(cmake-utils_use_with kolab Libkolab)
+ )
+
+ kde4-base_src_configure
+}
diff --git a/kde-base/kdepim-runtime/metadata.xml b/kde-base/kdepim-runtime/metadata.xml
index 8d1e86a9cefb..008f0a9c9525 100644
--- a/kde-base/kdepim-runtime/metadata.xml
+++ b/kde-base/kdepim-runtime/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>kde</herd>
+<use>
+ <flag name="google">Google service integration via <pkg>net-libs/libkgapi</pkg></flag>
+</use>
</pkgmetadata>