summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-04-08 12:27:54 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-04-08 12:27:54 +0000
commit23166c16b90342ae41f452b8d729ae8c5f97c891 (patch)
treefed8f302c25ec25ddf51d968a00f8c0f0df6bf4f /kde-base/kdeadmin/kdeadmin-3.4.0-r1.ebuild
parentminor formatting fix (Bug #88316) (diff)
downloadhistorical-23166c16b90342ae41f452b8d729ae8c5f97c891.tar.gz
historical-23166c16b90342ae41f452b8d729ae8c5f97c891.tar.bz2
historical-23166c16b90342ae41f452b8d729ae8c5f97c891.zip
Add patch to fix /etc/passwd corruption in kuser (#87405).
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'kde-base/kdeadmin/kdeadmin-3.4.0-r1.ebuild')
-rw-r--r--kde-base/kdeadmin/kdeadmin-3.4.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-base/kdeadmin/kdeadmin-3.4.0-r1.ebuild b/kde-base/kdeadmin/kdeadmin-3.4.0-r1.ebuild
new file mode 100644
index 000000000000..31c6d95844d5
--- /dev/null
+++ b/kde-base/kdeadmin/kdeadmin-3.4.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeadmin/kdeadmin-3.4.0-r1.ebuild,v 1.1 2005/04/08 12:27:54 greg_g Exp $
+
+inherit kde-dist eutils
+
+DESCRIPTION="KDE administration tools (user manager, etc.)"
+
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc"
+IUSE=""
+
+DEPEND="~kde-base/kdebase-${PV}"
+
+src_unpack() {
+ kde_src_unpack
+
+ # Fix /etc/passwd corruption in kuser (kde bug 100443). Applied for 3.4.1.
+ epatch "${FILESDIR}/${P}-kuser.patch"
+}
+
+src_compile() {
+ # we only want to compile the lilo config module on x86, but there we want to make sure it's
+ # always compiled to ensure consistent behaviour of the package across both lilo and grub systems,
+ # because configure when left to its own devices will build lilo-config or not basd on whether
+ # lilo is present in the path.
+ # so, we make configure build it by removing the configure.in.in file that checks for
+ # lilo's presense
+ if use x86; then
+ echo > ${S}/lilo-config/configure.in.in
+ make -f admin/Makefile.common
+ fi
+
+ export DO_NOT_COMPILE="${DO_NOT_COMPILE} ksysv"
+
+ kde_src_compile
+}
+
+# TODO: add nis support