summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-09-01 16:32:24 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-09-01 16:32:24 +0000
commit0941f8f8b9ab158f571c295f3e1a4db8e2117481 (patch)
tree395111f62c037d6bc60c879297b61c7bbb00ccc4 /kde-base/kde-l10n
parentstable sparc, bug 282379 (diff)
downloadhistorical-0941f8f8b9ab158f571c295f3e1a4db8e2117481.tar.gz
historical-0941f8f8b9ab158f571c295f3e1a4db8e2117481.tar.bz2
historical-0941f8f8b9ab158f571c295f3e1a4db8e2117481.zip
Version bump KDE 4.3.1
Package-Manager: portage-2.2_rc38/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kde-l10n')
-rw-r--r--kde-base/kde-l10n/ChangeLog8
-rw-r--r--kde-base/kde-l10n/kde-l10n-4.3.1.ebuild72
2 files changed, 79 insertions, 1 deletions
diff --git a/kde-base/kde-l10n/ChangeLog b/kde-base/kde-l10n/ChangeLog
index b4d3f9cff680..603aa1711e50 100644
--- a/kde-base/kde-l10n/ChangeLog
+++ b/kde-base/kde-l10n/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kde-l10n
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.34 2009/08/04 00:16:29 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.35 2009/09/01 15:10:23 tampakrap Exp $
+
+*kde-l10n-4.3.1 (01 Sep 2009)
+
+ 01 Sep 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ +kde-l10n-4.3.1.ebuild:
+ Version bump
*kde-l10n-4.3.0 (04 Aug 2009)
diff --git a/kde-base/kde-l10n/kde-l10n-4.3.1.ebuild b/kde-base/kde-l10n/kde-l10n-4.3.1.ebuild
new file mode 100644
index 000000000000..c4951afa9ef9
--- /dev/null
+++ b/kde-base/kde-l10n/kde-l10n-4.3.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.3.1.ebuild,v 1.1 2009/09/01 15:10:23 tampakrap Exp $
+
+EAPI="2"
+
+inherit kde4-base
+
+DESCRIPTION="KDE internationalization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="sys-devel/gettext"
+RDEPEND=""
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="+handbook"
+
+MY_LANGS="ar bg bn_IN ca cs csb da de el en_GB es et eu fi fr ga gl gu he hi
+ hne hu is it ja kk km kn ko ku lt lv mai mk ml mr nb nds nl nn pa pl pt
+ pt_BR ro ru sk sl sr sv tg th tr uk wa zh_CN zh_TW"
+
+URI_BASE="${SRC_URI/-${PV}.tar.bz2/}"
+SRC_URI=""
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local LNG DIR
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for LNG in ${LINGUAS}; do
+ DIR="${PN}-${LNG}-${PV}"
+ if [[ -d "${DIR}" ]] ; then
+ echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_build handbook docs)"
+ [[ -n ${A} ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -n ${A} ]] && kde4-base_src_compile
+}
+
+src_install() {
+ [[ -n ${A} ]] && kde4-base_src_install
+}