summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-09-05 22:55:16 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-09-05 22:55:16 +0000
commitcc76d1f56c59e97f1a2576468ba4993c4d5b612c (patch)
treed08e2b2c1ab8d1221393a6155133ce97c56538c1 /kde-base/dolphin
parentVersion bump KDE SC 4.5.1 (diff)
downloadhistorical-cc76d1f56c59e97f1a2576468ba4993c4d5b612c.tar.gz
historical-cc76d1f56c59e97f1a2576468ba4993c4d5b612c.tar.bz2
historical-cc76d1f56c59e97f1a2576468ba4993c4d5b612c.zip
Version bump KDE SC 4.5.1
Package-Manager: portage-2.2_rc75/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog8
-rw-r--r--kde-base/dolphin/dolphin-4.5.1.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 69295a667416..4ffd3d6d0ed2 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.83 2010/08/09 17:34:55 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.84 2010/09/05 22:49:06 tampakrap Exp $
+
+*dolphin-4.5.1 (05 Sep 2010)
+
+ 05 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +dolphin-4.5.1.ebuild:
+ Version bump
09 Aug 2010; Tomáš Chvátal <scarabeus@gentoo.org> dolphin-4.4.5.ebuild:
Drop alpha ia64 and sparc per the AT Lead permission.
diff --git a/kde-base/dolphin/dolphin-4.5.1.ebuild b/kde-base/dolphin/dolphin-4.5.1.ebuild
new file mode 100644
index 000000000000..573e8340f6d7
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.5.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.5.1.ebuild,v 1.1 2010/09/05 22:49:06 tampakrap Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK=1
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS=""
+IUSE="debug semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? ( >=dev-libs/shared-desktop-ontologies-0.2 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? (
+ || (
+ $(add_kdebase_dep ffmpegthumbs)
+ $(add_kdebase_dep mplayerthumbs)
+ )
+ )
+"
+
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-meta_src_configure
+}