summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-06-30 15:37:09 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-06-30 15:37:09 +0000
commitaa66be86a5a6d313a757a8082822195e32ec6d44 (patch)
tree216e32b289318ecc6cc5c758e202354a9ced5982 /kde-base/dolphin
parentUse --with-optim to respect CFLAGS (bug #261214). (diff)
downloadhistorical-aa66be86a5a6d313a757a8082822195e32ec6d44.tar.gz
historical-aa66be86a5a6d313a757a8082822195e32ec6d44.tar.bz2
historical-aa66be86a5a6d313a757a8082822195e32ec6d44.zip
[kde-base] Bump KDE SC 4.4.5 =)
Package-Manager: portage-2.2_rc67_p182/cvs/Linux x86_64
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.4.5.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 844f789efd13..edf5c0a77810 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.77 2010/06/27 09:26:13 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.78 2010/06/30 15:36:56 alexxy Exp $
+
+*dolphin-4.4.5 (30 Jun 2010)
+
+ 30 Jun 2010; Alexey Shvetsov <alexxy@gentoo.org> +dolphin-4.4.5.ebuild:
+ Version bump
27 Jun 2010; Christian Faulhammer <fauli@gentoo.org> dolphin-4.4.4.ebuild:
x86 stable, bug 322791
diff --git a/kde-base/dolphin/dolphin-4.4.5.ebuild b/kde-base/dolphin/dolphin-4.4.5.ebuild
new file mode 100644
index 000000000000..28c65541d02f
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.4.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.4.5.ebuild,v 1.1 2010/06/30 15:36:56 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook semantic-desktop subversion thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? ( >=dev-libs/shared-desktop-ontologies-0.2 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+ subversion? (
+ dev-vcs/subversion
+ $(add_kdebase_dep kompare)
+ )
+"
+PDEPEND="
+ thumbnail? ( $(add_kdebase_dep mplayerthumbs) )
+"
+
+KMLOADLIBS="libkonq"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ if ! use subversion; then
+ sed -e '/install(.*fileviewsvnplugin.*)/s/^/#DONOTINSTALL /g' \
+ -i dolphin/src/CMakeLists.txt || die 'failed to disable subversion plugin'
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-meta_src_configure
+}