summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-03-04 18:00:22 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-03-04 18:00:22 +0000
commit6f430e346de22377dc53caf57d7a8b62b57eb7ed (patch)
tree7bf86d97cf974dfed6c010d3ff5aebc192229757 /kde-base/dolphin
parentRemoved unneccessary python_copy_sources (diff)
downloadhistorical-6f430e346de22377dc53caf57d7a8b62b57eb7ed.tar.gz
historical-6f430e346de22377dc53caf57d7a8b62b57eb7ed.tar.bz2
historical-6f430e346de22377dc53caf57d7a8b62b57eb7ed.zip
[kde-base] Add KDE SC 4.6.1
Package-Manager: portage-2.2.0_alpha26/cvs/Linux x86_64
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.6.1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 4f148d9d741e..acedfcb19013 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.90 2011/01/26 20:29:23 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.91 2011/03/04 18:00:16 alexxy Exp $
+
+*dolphin-4.6.1 (04 Mar 2011)
+
+ 04 Mar 2011; Alexey Shvetsov <alexxy@gentoo.org> +dolphin-4.6.1.ebuild:
+ Version bump KDE SC 4.6.1
*dolphin-4.6.0 (26 Jan 2011)
diff --git a/kde-base/dolphin/dolphin-4.6.1.ebuild b/kde-base/dolphin/dolphin-4.6.1.ebuild
new file mode 100644
index 000000000000..df67e5ef75c3
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.6.1.ebuild,v 1.1 2011/03/04 18:00:16 alexxy Exp $
+
+EAPI=3
+
+KDE_HANDBOOK="optional"
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? ( >=dev-libs/shared-desktop-ontologies-0.2 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? (
+ || (
+ $(add_kdebase_dep ffmpegthumbs)
+ $(add_kdebase_dep mplayerthumbs)
+ )
+ )
+"
+
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-meta_src_configure
+}