summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
commit3c0323f9d2990f6ccb8a70eb2ca0172e57f561fe (patch)
tree354eb455031cc91369bff38098f7636aa38ecdad /kde-base/dolphin
parent[profiles] Mask marble with gps on ppc64 (diff)
downloadhistorical-3c0323f9d2990f6ccb8a70eb2ca0172e57f561fe.tar.gz
historical-3c0323f9d2990f6ccb8a70eb2ca0172e57f561fe.tar.bz2
historical-3c0323f9d2990f6ccb8a70eb2ca0172e57f561fe.zip
[kde-base] Add KDE SC 4.6.0
Package-Manager: portage-2.2.0_alpha19_p2/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.6.0.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 7068963d7692..4f148d9d741e 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.89 2011/01/10 11:53:19 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.90 2011/01/26 20:29:23 alexxy Exp $
+
+*dolphin-4.6.0 (26 Jan 2011)
+
+ 26 Jan 2011; Alexey Shvetsov <alexxy@gentoo.org> +dolphin-4.6.0.ebuild:
+ Version bump KDE SC 4.6.0
*dolphin-4.5.5 (10 Jan 2011)
diff --git a/kde-base/dolphin/dolphin-4.6.0.ebuild b/kde-base/dolphin/dolphin-4.6.0.ebuild
new file mode 100644
index 000000000000..4ce2df30e753
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.6.0.ebuild,v 1.1 2011/01/26 20:29:23 alexxy Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? ( >=dev-libs/shared-desktop-ontologies-0.2 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? (
+ || (
+ $(add_kdebase_dep ffmpegthumbs)
+ $(add_kdebase_dep mplayerthumbs)
+ )
+ )
+"
+
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-meta_src_configure
+}