summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-12-02 21:18:24 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-12-02 21:18:24 +0000
commit307c276a3b4c55dca98f0a87512c3cbb4ace9264 (patch)
treebe7fdf498714778819009f86b7aa2b771e52ebd1 /kde-base/dolphin
parentMask KDE SC 4.5 due to missing deps on ppc ppc64 and x86-fbsd. bug #336158 (diff)
downloadhistorical-307c276a3b4c55dca98f0a87512c3cbb4ace9264.tar.gz
historical-307c276a3b4c55dca98f0a87512c3cbb4ace9264.tar.bz2
historical-307c276a3b4c55dca98f0a87512c3cbb4ace9264.zip
[kde-base] Add KDE SC 4.5.4
Package-Manager: portage-2.2.0_alpha6_p10/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.5.4.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 0d15efc06682..742f6f1b431e 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.87 2010/11/03 16:30:29 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.88 2010/12/02 21:18:24 alexxy Exp $
+
+*dolphin-4.5.4 (02 Dec 2010)
+
+ 02 Dec 2010; Alexey Shvetsov <alexxy@gentoo.org> +dolphin-4.5.4.ebuild:
+ Version bump KDE SC 4.5.4
*dolphin-4.5.3 (03 Nov 2010)
diff --git a/kde-base/dolphin/dolphin-4.5.4.ebuild b/kde-base/dolphin/dolphin-4.5.4.ebuild
new file mode 100644
index 000000000000..63dd2d8e0bce
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.5.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.5.4.ebuild,v 1.1 2010/12/02 21:18:24 alexxy Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? ( >=dev-libs/shared-desktop-ontologies-0.2 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? (
+ || (
+ $(add_kdebase_dep ffmpegthumbs)
+ $(add_kdebase_dep mplayerthumbs)
+ )
+ )
+"
+
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-meta_src_configure
+}