summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-11-13 12:10:59 +0000
committerPacho Ramos <pacho@gentoo.org>2014-11-13 12:10:59 +0000
commitcd2249a15d97fa3cdaa0e350b852c4ac08b7fccf (patch)
tree979fa2a2a8b37fc086d38e8b9620fc2803fffa96 /gnome-extra/sensors-applet/files
parentDrop package due bug #508854 (diff)
downloadhistorical-cd2249a15d97fa3cdaa0e350b852c4ac08b7fccf.tar.gz
historical-cd2249a15d97fa3cdaa0e350b852c4ac08b7fccf.tar.bz2
historical-cd2249a15d97fa3cdaa0e350b852c4ac08b7fccf.zip
Drop package due bug #508854
Diffstat (limited to 'gnome-extra/sensors-applet/files')
-rw-r--r--gnome-extra/sensors-applet/files/sensors-applet-2.2.7-libnotify-0.7.patch57
-rw-r--r--gnome-extra/sensors-applet/files/sensors-applet-2.2.7-underlinking.patch37
2 files changed, 0 insertions, 94 deletions
diff --git a/gnome-extra/sensors-applet/files/sensors-applet-2.2.7-libnotify-0.7.patch b/gnome-extra/sensors-applet/files/sensors-applet-2.2.7-libnotify-0.7.patch
deleted file mode 100644
index ea2f7803a8fa..000000000000
--- a/gnome-extra/sensors-applet/files/sensors-applet-2.2.7-libnotify-0.7.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-diff --git a/sensors-applet/active-sensor-libnotify.c b/sensors-applet/active-sensor-libnotify.c
-index e69b005..f7a7eb8 100644
---- a/sensors-applet/active-sensor-libnotify.c
-+++ b/sensors-applet/active-sensor-libnotify.c
-@@ -84,10 +84,23 @@ void active_sensor_libnotify_notify(ActiveSensor *active_sensor,
-
- /* now create a new one */
- g_debug("Creating new notification");
-+ #ifdef NOTIFY_CHECK_VERSION
-+ #if NOTIFY_CHECK_VERSION (0, 7, 1)
-+ active_sensor->notification[notif_type] = notify_notification_new(summary,
-+ message,
-+ icon_filename);
-+ #else
-+ active_sensor->notification[notif_type] = notify_notification_new(summary,
-+ message,
-+ icon_filename,
-+ attach);
-+ #endif
-+ #else
- active_sensor->notification[notif_type] = notify_notification_new(summary,
- message,
- icon_filename,
- attach);
-+ #endif
- g_signal_connect(active_sensor->notification[notif_type], "closed",
- G_CALLBACK(notif_closed_cb),
- active_sensor);
-diff --git a/sensors-applet/sensors-applet.c b/sensors-applet/sensors-applet.c
-index 9486173..81675b8 100644
---- a/sensors-applet/sensors-applet.c
-+++ b/sensors-applet/sensors-applet.c
-@@ -303,11 +303,23 @@ void sensors_applet_notify(SensorsApplet *sensors_applet,
- message = g_strdup_printf(_("An error occurred while trying to save the current sensor configuration. "));
- break;
- }
--
-+ #ifdef NOTIFY_CHECK_VERSION
-+ #if NOTIFY_CHECK_VERSION (0, 7, 1)
-+ sensors_applet->notification = notify_notification_new(summary,
-+ message,
-+ GTK_STOCK_DIALOG_WARNING);
-+ #else
-+ sensors_applet->notification = notify_notification_new(summary,
-+ message,
-+ GTK_STOCK_DIALOG_WARNING,
-+ GTK_WIDGET(sensors_applet->applet));
-+ #endif
-+ #else
- sensors_applet->notification = notify_notification_new(summary,
- message,
- GTK_STOCK_DIALOG_WARNING,
- GTK_WIDGET(sensors_applet->applet));
-+ #endif
- g_free(summary);
- g_free(message);
-
diff --git a/gnome-extra/sensors-applet/files/sensors-applet-2.2.7-underlinking.patch b/gnome-extra/sensors-applet/files/sensors-applet-2.2.7-underlinking.patch
deleted file mode 100644
index 8df1953b7b40..000000000000
--- a/gnome-extra/sensors-applet/files/sensors-applet-2.2.7-underlinking.patch
+++ /dev/null
@@ -1,37 +0,0 @@
- sensors-applet/Makefile.am | 4 ++--
- sensors-applet/Makefile.in | 2 +-
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/sensors-applet/Makefile.am b/sensors-applet/Makefile.am
-index a87feb0..097122e 100644
---- a/sensors-applet/Makefile.am
-+++ b/sensors-applet/Makefile.am
-@@ -11,7 +11,7 @@ INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale/"\" \
- $(GLIB_CFLAGS) $(GTK_CFLAGS) $(GNOME_CFLAGS) $(CAIRO_CFLAGS) $(LIBNOTIFY_CFLAGS)
-
-
--LIBS = $(GLIB_LIBS) $(GTK_LIBS) $(GNOME_LIBS) $(CAIRO_LIBS) $(LIBNOTIFY_LIBS)
-+LIBS = $(GLIB_LIBS) $(GTK_LIBS) $(GNOME_LIBS) $(CAIRO_LIBS) $(LIBNOTIFY_LIBS) -ldl
-
- if LIBNOTIFY
- libnotify_SRC = active-sensor-libnotify.c \
-@@ -47,4 +47,4 @@ headerdir = $(prefix)/include/sensors-applet
- header_DATA = $(INST_H_FILES)
-
- # since it is separate
--EXTRA_DIST = sensors-applet-plugin.h
-\ No newline at end of file
-+EXTRA_DIST = sensors-applet-plugin.h
-diff --git a/sensors-applet/Makefile.in b/sensors-applet/Makefile.in
-index dd6765f..3b0b8ac 100644
---- a/sensors-applet/Makefile.in
-+++ b/sensors-applet/Makefile.in
-@@ -167,7 +167,7 @@ LIBATASMART_LIBS = @LIBATASMART_LIBS@
- LIBNOTIFY_CFLAGS = @LIBNOTIFY_CFLAGS@
- LIBNOTIFY_LIBS = @LIBNOTIFY_LIBS@
- LIBOBJS = @LIBOBJS@
--LIBS = $(GLIB_LIBS) $(GTK_LIBS) $(GNOME_LIBS) $(CAIRO_LIBS) $(LIBNOTIFY_LIBS)
-+LIBS = $(GLIB_LIBS) $(GTK_LIBS) $(GNOME_LIBS) $(CAIRO_LIBS) $(LIBNOTIFY_LIBS) -ldl
- LIBSENSORS_CFLAGS = @LIBSENSORS_CFLAGS@
- LIBSENSORS_LIBS = @LIBSENSORS_LIBS@
- LIBTOOL = @LIBTOOL@