summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-05-13 18:26:27 +0000
committerMarinus Schraal <foser@gentoo.org>2003-05-13 18:26:27 +0000
commitccf0680b78c9f9f07375d16015c7c68eb94e0149 (patch)
tree6d2fe3d6a40417b9c1fed6511651b7d3d867aa0a /gnome-extra/libgtkhtml/libgtkhtml-2.2.4.ebuild
parentnew version (diff)
downloadhistorical-ccf0680b78c9f9f07375d16015c7c68eb94e0149.tar.gz
historical-ccf0680b78c9f9f07375d16015c7c68eb94e0149.tar.bz2
historical-ccf0680b78c9f9f07375d16015c7c68eb94e0149.zip
New version 'n cleanup
Diffstat (limited to 'gnome-extra/libgtkhtml/libgtkhtml-2.2.4.ebuild')
-rw-r--r--gnome-extra/libgtkhtml/libgtkhtml-2.2.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnome-extra/libgtkhtml/libgtkhtml-2.2.4.ebuild b/gnome-extra/libgtkhtml/libgtkhtml-2.2.4.ebuild
new file mode 100644
index 000000000000..69f3187f1d73
--- /dev/null
+++ b/gnome-extra/libgtkhtml/libgtkhtml-2.2.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgtkhtml/libgtkhtml-2.2.4.ebuild,v 1.1 2003/05/13 18:26:27 foser Exp $
+
+inherit eutils gnome2
+
+S=${WORKDIR}/${P}
+DESCRIPTION="a Gtk+ based HTML rendering library"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="1"
+LICENSE="LGPL-2.1 GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+# FIXME : seems only testapps need gnomevfs
+RDEPEND=">=x11-libs/gtk+-2
+ >=dev-libs/libxml2-2.4.16
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/gail-1"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README TODO docs/IDEAS"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ if use alpha; then
+ epatch ${FILESDIR}/${PN}-2.2.0-alpha.patch || die
+ fi
+}