summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-02-18 20:06:20 +0000
committerSimon Stelling <blubb@gentoo.org>2006-02-18 20:06:20 +0000
commit883478e1254af6cf3ea5a29b9baabfe86f8b3a5a (patch)
treee39f18d49c0a7f5ed3bb413b64423e2bf4b64275 /gnome-extra/gnome-art/gnome-art-0.2-r2.ebuild
parentMake gxine 0.4.5 work on modular X. (diff)
downloadhistorical-883478e1254af6cf3ea5a29b9baabfe86f8b3a5a.tar.gz
historical-883478e1254af6cf3ea5a29b9baabfe86f8b3a5a.tar.bz2
historical-883478e1254af6cf3ea5a29b9baabfe86f8b3a5a.zip
fix bug 122514
Package-Manager: portage-2.1_pre4-r1
Diffstat (limited to 'gnome-extra/gnome-art/gnome-art-0.2-r2.ebuild')
-rw-r--r--gnome-extra/gnome-art/gnome-art-0.2-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnome-extra/gnome-art/gnome-art-0.2-r2.ebuild b/gnome-extra/gnome-art/gnome-art-0.2-r2.ebuild
new file mode 100644
index 000000000000..fb7906070862
--- /dev/null
+++ b/gnome-extra/gnome-art/gnome-art-0.2-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-art/gnome-art-0.2-r2.ebuild,v 1.1 2006/02/18 20:06:20 blubb Exp $
+
+inherit ruby
+
+DESCRIPTION="A collection of tools for managing art from the art.gnome.org website."
+HOMEPAGE="http://www.miketech.net/gnome-art/"
+SRC_URI="http://www.miketech.net/gnome-art/download/${P}.tar.gz"
+
+USE_RUBY="ruby18"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+RDEPEND="virtual/ruby
+ >=dev-ruby/ruby-gnome2-0.14.1
+ >=dev-ruby/ruby-atk-0.14.1
+ >=dev-ruby/ruby-pango-0.14.1
+ >=dev-ruby/ruby-gdkpixbuf2-0.12.0
+ >=dev-ruby/ruby-libart2-0.14.1
+ >=dev-ruby/ruby-libglade2-0.12.0
+ >=dev-ruby/ruby-gconf2-0.12.0"
+DEPEND="virtual/ruby"
+
+src_install(){
+ cd gnome-splashscreen-manager
+ ruby_einstall || die "installing gnome-splashscreen-manager failed"
+ cd ../gnome-art
+ ruby_einstall || die "installing gnome-art failed"
+
+ dodoc README AUTHORS Changelog
+
+ mkdir ${D}/usr/share/pixmaps
+ cp ${D}/usr/share/${PN}/glade/pixmaps/gnome-graphics.png \
+ ${D}/usr/share/pixmaps
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/gnome-art.desktop
+ doins ${FILESDIR}/gnome-splashscreen-manager.desktop
+}