summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-02-24 19:39:00 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-02-24 19:39:00 +0000
commitb77617b54437a2552b10063efd7965d9d1564a70 (patch)
treeec785d0c7f44f652c4486b4b6c2238761068d2cf /gnome-base
parentremoving - old patches for revisions that don't exist anymore (diff)
downloadhistorical-b77617b54437a2552b10063efd7965d9d1564a70.tar.gz
historical-b77617b54437a2552b10063efd7965d9d1564a70.tar.bz2
historical-b77617b54437a2552b10063efd7965d9d1564a70.zip
missing ebuild
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gconf/gconf-1.0.8-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnome-base/gconf/gconf-1.0.8-r1.ebuild b/gnome-base/gconf/gconf-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..dfbc49d0e6ae
--- /dev/null
+++ b/gnome-base/gconf/gconf-1.0.8-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-1.0.8-r1.ebuild,v 1.1 2002/02/24 19:39:00 drobbins Exp $
+
+S=${WORKDIR}/Gconf-${PV}
+DESCRIPTION="Gconf"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/GConf/GConf-${PV}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+RDEPEND=">=sys-libs/db-3.2.3h >=gnome-base/oaf-0.6.6-r1"
+DEPEND="${RDEPEND} nls? ( sys-devel/gettext ) >=dev-util/guile-1.4"
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ mkdir intl
+ touch intl/libgettext.h
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ make || die # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+ # gconf 1.0.8 seems to gets the perms wrong on this dir.
+ chmod 0755 ${D}/etc/gconf/gconf.xml.mandatory
+ # this fix closes bug #803
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+}
+
+pkg_postinst() {
+ # this is to fix installations where the following dir
+ # has already been merged with incorrect permissions.
+ # We can remove this fix after gconf 1.0.8 is an ancient
+ # version.
+ chmod 0755 ${ROOT}/etc/gconf/gconf.xml.mandatory
+}