summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-11-22 15:32:53 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-11-22 15:32:53 +0000
commitacf0523489e1c4b45c060adc373ab141513d9e75 (patch)
tree357b89e0157863e44a53befd0bab2338b10e0628 /games-strategy
parentStable on sparc (diff)
downloadhistorical-acf0523489e1c4b45c060adc373ab141513d9e75.tar.gz
historical-acf0523489e1c4b45c060adc373ab141513d9e75.tar.bz2
historical-acf0523489e1c4b45c060adc373ab141513d9e75.zip
Initial import. Ebuild by Paul Bredbury <brebs@sent.com> and modified by me. Closing bug #111884.
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/coldwar-demo/ChangeLog11
-rw-r--r--games-strategy/coldwar-demo/Manifest4
-rw-r--r--games-strategy/coldwar-demo/coldwar-demo-1.ebuild67
-rw-r--r--games-strategy/coldwar-demo/files/digest-coldwar-demo-11
-rw-r--r--games-strategy/coldwar-demo/metadata.xml5
5 files changed, 88 insertions, 0 deletions
diff --git a/games-strategy/coldwar-demo/ChangeLog b/games-strategy/coldwar-demo/ChangeLog
new file mode 100644
index 000000000000..963b2e16b5fa
--- /dev/null
+++ b/games-strategy/coldwar-demo/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-strategy/coldwar-demo
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/coldwar-demo/ChangeLog,v 1.1 2005/11/22 15:32:53 wolf31o2 Exp $
+
+*coldwar-demo-1 (22 Nov 2005)
+
+ 22 Nov 2005; Chris Gianelloni <wolf31o2@gentoo.org> +metadata.xml,
+ +coldwar-demo-1.ebuild:
+ Initial import. Ebuild by Paul Bredbury <brebs@sent.com> and modified by me.
+ Closing bug #111884.
+
diff --git a/games-strategy/coldwar-demo/Manifest b/games-strategy/coldwar-demo/Manifest
new file mode 100644
index 000000000000..24f3f659aba2
--- /dev/null
+++ b/games-strategy/coldwar-demo/Manifest
@@ -0,0 +1,4 @@
+MD5 40ecc0792795251d542091a1647c573b ChangeLog 458
+MD5 091ae188f812657476257bd46f5f9f5b coldwar-demo-1.ebuild 1570
+MD5 9d7e1993611f759ec4e88d9a3649c80d files/digest-coldwar-demo-1 64
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
diff --git a/games-strategy/coldwar-demo/coldwar-demo-1.ebuild b/games-strategy/coldwar-demo/coldwar-demo-1.ebuild
new file mode 100644
index 000000000000..c450622cf8b4
--- /dev/null
+++ b/games-strategy/coldwar-demo/coldwar-demo-1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/coldwar-demo/coldwar-demo-1.ebuild,v 1.1 2005/11/22 15:32:53 wolf31o2 Exp $
+
+inherit eutils games
+
+DESCRIPTION="Third-person sneaker like Splinter Cell"
+HOMEPAGE="http://www.coldwar-game.com/"
+
+SRC_URI="coldwar_demo.run"
+DOWNLOAD_URL="http://www.mindwarestudios.com/download/coldwar_demo.torrent"
+
+# Not sure where the license is!
+LICENSE="as-is"
+
+SLOT="0"
+
+# Has an "x86_64" dir, so maybe works on other arches (untested).
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="strip fetch"
+
+DEPEND="app-arch/tar
+ app-arch/gzip"
+
+RDEPEND="virtual/x11
+ virtual/opengl
+ amd64? ( app-emulation/emul-linux-x86-soundlibs
+ app-emulation/emul-linux-x86-sdl
+ app-emulation/emul-linux-x86-medialibs
+ app-emulation/emul-linux-x86-baselibs
+ app-emulation/emul-linux-x86-xlibs )"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please download ${A} into ${DISTDIR}"
+ einfo "using ${DOWNLOAD_URL}"
+}
+
+S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ mv bin/Linux/x86/glibc-2.1/bin/* bin/
+
+ games_make_wrapper ${PN} ./bin/launcher "${dir}" "${dir}"
+ newicon coldwar.xpm ${PN}.xpm || die "copying icon"
+ make_desktop_entry "${PN}" "Cold War Demo" "${PN}".xpm
+
+ rm -rf coldwar_demo.run setup.* bin/Linux lib/libopenal*
+ mkdir -p ${Ddir}
+ cp -r * ${Ddir}/ || die "recursive copy failed"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ einfo "To play the game, run: ${PN}"
+}
diff --git a/games-strategy/coldwar-demo/files/digest-coldwar-demo-1 b/games-strategy/coldwar-demo/files/digest-coldwar-demo-1
new file mode 100644
index 000000000000..91d353b6e608
--- /dev/null
+++ b/games-strategy/coldwar-demo/files/digest-coldwar-demo-1
@@ -0,0 +1 @@
+MD5 dbe404f99f565f6cf55f802b7d5a9dcf coldwar_demo.run 341905710
diff --git a/games-strategy/coldwar-demo/metadata.xml b/games-strategy/coldwar-demo/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-strategy/coldwar-demo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>