summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-13 00:10:57 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-13 00:10:57 +0000
commit44705f2406584b9b2e2acb0f9841b4722f702f40 (patch)
tree8acfb38880ae7906b9533820be1fcf7e39405c7d /games-strategy
parentAdd ~alpha keyword. (diff)
downloadhistorical-44705f2406584b9b2e2acb0f9841b4722f702f40.tar.gz
historical-44705f2406584b9b2e2acb0f9841b4722f702f40.tar.bz2
historical-44705f2406584b9b2e2acb0f9841b4722f702f40.zip
Add a hack workaround since function seems to be rewritten in upstream CVS and it currently doesnt parse NVIDIA version properly #95696.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/glest/ChangeLog7
-rw-r--r--games-strategy/glest/Manifest5
-rw-r--r--games-strategy/glest/files/glest-1.0.10_p7-fake-checkGlCaps.patch8
-rw-r--r--games-strategy/glest/glest-1.0.10_p7.ebuild5
4 files changed, 20 insertions, 5 deletions
diff --git a/games-strategy/glest/ChangeLog b/games-strategy/glest/ChangeLog
index 5f6a538ad1ae..7e860d14f84d 100644
--- a/games-strategy/glest/ChangeLog
+++ b/games-strategy/glest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/glest
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/ChangeLog,v 1.2 2005/04/12 09:39:13 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/ChangeLog,v 1.3 2005/06/13 00:10:56 vapier Exp $
+
+ 13 Jun 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/glest-1.0.10_p7-fake-checkGlCaps.patch, glest-1.0.10_p7.ebuild:
+ Add a hack workaround since function seems to be rewritten in upstream CVS
+ and it currently doesnt parse NVIDIA version properly #95696.
12 Apr 2005; David Holm <dholm@gentoo.org> glest-1.0.10_p7.ebuild:
Added to ~ppc.
diff --git a/games-strategy/glest/Manifest b/games-strategy/glest/Manifest
index ad7396a2cd07..ac16864d55ef 100644
--- a/games-strategy/glest/Manifest
+++ b/games-strategy/glest/Manifest
@@ -1,5 +1,6 @@
-MD5 62c00e9d1d81606fcc8923e7bfd7f420 glest-1.0.10_p7.ebuild 2320
-MD5 577f270924bb7b17f54adc35b39b507b ChangeLog 452
+MD5 5bb989c52f433b02624524136636d89f glest-1.0.10_p7.ebuild 2346
+MD5 d989c2706f05befcf47e3286aaa06ecf ChangeLog 718
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 704449ca017fe5f35a53024e3daa2a4c files/digest-glest-1.0.10_p7 306
MD5 cbc9ee2193e3623d8e7fc3a999e7d465 files/glest 498
+MD5 a36bd77a690a0460b5a2f1abccd7e859 files/glest-1.0.10_p7-fake-checkGlCaps.patch 250
diff --git a/games-strategy/glest/files/glest-1.0.10_p7-fake-checkGlCaps.patch b/games-strategy/glest/files/glest-1.0.10_p7-fake-checkGlCaps.patch
new file mode 100644
index 000000000000..9efe40afeaf1
--- /dev/null
+++ b/games-strategy/glest/files/glest-1.0.10_p7-fake-checkGlCaps.patch
@@ -0,0 +1,8 @@
+--- sources/renderer.cpp.orig 2005-06-12 20:06:38.000000000 -0400
++++ sources/renderer.cpp 2005-06-12 20:06:53.000000000 -0400
+@@ -2243,4 +2243,5 @@
+
+ void Renderer::checkGlCaps() {
++return;
+ //opengl 1.3
+ if(!isGlVersionSupported(1, 3, 0)) {
diff --git a/games-strategy/glest/glest-1.0.10_p7.ebuild b/games-strategy/glest/glest-1.0.10_p7.ebuild
index 15553a7db333..601008188df5 100644
--- a/games-strategy/glest/glest-1.0.10_p7.ebuild
+++ b/games-strategy/glest/glest-1.0.10_p7.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/glest-1.0.10_p7.ebuild,v 1.3 2005/04/20 02:48:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glest/glest-1.0.10_p7.ebuild,v 1.4 2005/06/13 00:10:56 vapier Exp $
inherit eutils games
DATAVERSION="${PV/_p?/}"
SOURCEVERSION="${PV/_p/-r}"
DESCRIPTION="Cross-platform 3D realtime strategy game"
-HOMEPAGE="http://www.stud.uni-karlsruhe.de/~uxsm/glest/"
+HOMEPAGE="http://www.glest.org/"
SRC_URI="http://www.stud.uni-karlsruhe.de/~uxsm/glest-${SOURCEVERSION}-source.tar.bz2
http://www.stud.uni-karlsruhe.de/~unatc/glest/glest-${DATAVERSION}-data.tar.bz2
linguas_de? ( http://www.stud.uni-karlsruhe.de/~uxsm/german.lng )
@@ -35,6 +35,7 @@ S=${WORKDIR}/${PN}-${DATAVERSION}
src_unpack() {
unpack glest-${SOURCEVERSION}-source.tar.bz2 glest-${DATAVERSION}-data.tar.bz2
cd "${S}"
+ epatch "${FILESDIR}"/${P}-fake-checkGlCaps.patch
# sometimes they package configure, sometimes they dont
if [[ ! -e configure ]] ; then
./autogen.sh || die "autogen failed"