summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-08-19 23:21:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-08-19 23:21:47 +0000
commitb84fbce1a6434212c60fee02087363271b117d52 (patch)
treee8ac0673fa2dca299301a2248c55f79bae9897b2 /games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
parentAdded to ~ppc (diff)
downloadhistorical-b84fbce1a6434212c60fee02087363271b117d52.tar.gz
historical-b84fbce1a6434212c60fee02087363271b117d52.tar.bz2
historical-b84fbce1a6434212c60fee02087363271b117d52.zip
Fix datadir issue (bug #60933)
Diffstat (limited to 'games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild')
-rw-r--r--games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
index 7b879de643bd..86f732d9977c 100644
--- a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
+++ b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild,v 1.4 2004/07/01 11:23:39 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild,v 1.5 2004/08/19 23:21:47 mr_bones_ Exp $
inherit games
@@ -29,27 +29,27 @@ S="${WORKDIR}/csmash-${PV}"
src_unpack() {
unpack csmash-${PV}.tar.gz
- cd ${S}
+ cd "${S}"
if use oggvorbis ; then
- cp ${DISTDIR}/${MY_OGG} ${S}/ || die "cp failed"
+ cp "${DISTDIR}/${MY_OGG}" "${S}/" || die "cp failed"
sed -i \
-e "s:${MY_OGG}:${GAMES_DATADIR}/csmash/${MY_OGG}:" ttinc.h \
- || die "setting ogg loc"
+ || die "setting ogg loc"
fi
}
src_compile() {
egamesconf \
- `use_enable nls` \
+ $(use_enable nls) \
--datadir="${GAMES_DATADIR_BASE}" \
|| die
- emake || die "emake failed"
+ emake \
+ localedir="/usr/share" \
+ || die "emake failed"
}
src_install() {
- egamesinstall \
- datadir="${D}/${GAMES_DATADIR_BASE}" \
- || die
+ make DESTDIR="${D}" install || die "make install failed"
if use oggvorbis ; then
insinto "${GAMES_DATADIR}/csmash"
doins "${MY_OGG}"