summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-12-20 23:53:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-12-20 23:53:29 +0000
commit3ab79177689114bb0cc589fdb75c4f7c38eb7605 (patch)
treea4c35058cfd3fb82274338deeea9241fa0db0f08 /games-rpg
parentsrc_compile() -> src_unpack(), bug #75054 (diff)
downloadhistorical-3ab79177689114bb0cc589fdb75c4f7c38eb7605.tar.gz
historical-3ab79177689114bb0cc589fdb75c4f7c38eb7605.tar.bz2
historical-3ab79177689114bb0cc589fdb75c4f7c38eb7605.zip
fix curl include - bug #75104
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/planeshift/ChangeLog6
-rw-r--r--games-rpg/planeshift/Manifest4
-rw-r--r--games-rpg/planeshift/planeshift-0.2.010-r1.ebuild7
3 files changed, 13 insertions, 4 deletions
diff --git a/games-rpg/planeshift/ChangeLog b/games-rpg/planeshift/ChangeLog
index 59f0325ff896..2f5ef9915274 100644
--- a/games-rpg/planeshift/ChangeLog
+++ b/games-rpg/planeshift/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-rpg/planeshift
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/planeshift/ChangeLog,v 1.5 2004/06/24 23:16:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/planeshift/ChangeLog,v 1.6 2004/12/20 23:53:29 mr_bones_ Exp $
+
+ 20 Dec 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ planeshift-0.2.010-r1.ebuild:
+ fix curl include - bug #75104
21 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org>
planeshift-0.2.010-r1.ebuild:
diff --git a/games-rpg/planeshift/Manifest b/games-rpg/planeshift/Manifest
index ab605d775605..90679c3fd363 100644
--- a/games-rpg/planeshift/Manifest
+++ b/games-rpg/planeshift/Manifest
@@ -1,5 +1,5 @@
-MD5 f82fe312713b1576dce79a607977c061 ChangeLog 1184
-MD5 cb4b4e3e77b93f9332e199d857dd107d planeshift-0.2.010-r1.ebuild 1620
+MD5 3d733d693c2a111e07840dee5c7ae236 ChangeLog 1305
+MD5 c95b0b4f0b99ff8ba732a2028c14af2d planeshift-0.2.010-r1.ebuild 1738
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 a6b3c03bb00760172f490ae59e50cd32 files/digest-planeshift-0.2.010-r1 73
MD5 b8b8a31f70400cd54c5b8cfea9af368a files/planeshift 116
diff --git a/games-rpg/planeshift/planeshift-0.2.010-r1.ebuild b/games-rpg/planeshift/planeshift-0.2.010-r1.ebuild
index cf890c77c911..09d9babf510b 100644
--- a/games-rpg/planeshift/planeshift-0.2.010-r1.ebuild
+++ b/games-rpg/planeshift/planeshift-0.2.010-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/planeshift/planeshift-0.2.010-r1.ebuild,v 1.10 2004/11/05 20:06:18 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/planeshift/planeshift-0.2.010-r1.ebuild,v 1.11 2004/12/20 23:53:29 mr_bones_ Exp $
inherit eutils games
@@ -28,7 +28,12 @@ export CEL_PREFIX=${CEL_PREFIX:-${CRYSTAL_PREFIX}}
src_unpack() {
unpack ${A}
+ cd "${S}"
epatch "${FILESDIR}/${P}-fix-cast.diff"
+ sed -i \
+ -e 's:curl/types.h:curl/curl.h:' \
+ src/updater/httpclient/download.h \
+ || die "sed failed"
}
src_compile() {