summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-03 21:55:52 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-03 21:55:52 +0000
commit398040e6e3eafb0d3db76530255e9d2ae576747f (patch)
tree24b17ed40fc57b095b064d0623427d7373211fab /games-rpg/nwn
parentver bump #35961 (diff)
downloadhistorical-398040e6e3eafb0d3db76530255e9d2ae576747f.tar.gz
historical-398040e6e3eafb0d3db76530255e9d2ae576747f.tar.bz2
historical-398040e6e3eafb0d3db76530255e9d2ae576747f.zip
ver bump #36007
Diffstat (limited to 'games-rpg/nwn')
-rw-r--r--games-rpg/nwn/ChangeLog7
-rw-r--r--games-rpg/nwn/files/digest-nwn-1.613
-rw-r--r--games-rpg/nwn/nwn-1.61.ebuild85
3 files changed, 94 insertions, 1 deletions
diff --git a/games-rpg/nwn/ChangeLog b/games-rpg/nwn/ChangeLog
index d5a6e31055be..39f38b7a85b8 100644
--- a/games-rpg/nwn/ChangeLog
+++ b/games-rpg/nwn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-rpg/nwn
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn/ChangeLog,v 1.4 2003/10/14 00:14:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn/ChangeLog,v 1.5 2004/01/03 21:55:52 vapier Exp $
+
+*nwn-1.61 (03 Jan 2004)
+
+ 03 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bump #36007.
*nwn-1.32 (13 Oct 2003)
diff --git a/games-rpg/nwn/files/digest-nwn-1.61 b/games-rpg/nwn/files/digest-nwn-1.61
new file mode 100644
index 000000000000..f1ab2281661e
--- /dev/null
+++ b/games-rpg/nwn/files/digest-nwn-1.61
@@ -0,0 +1,3 @@
+MD5 73c6515fd6aa5f860802098a55000ae8 nwclient129.tar.gz 5504342
+MD5 28890d613a0ae78700fdc2190b3b25f4 linuxclientupdate129to161eng.tar.gz 69715126
+MD5 8222401efe25235b56d01b38ae880b5b nwresources129.tar.gz 1212356127
diff --git a/games-rpg/nwn/nwn-1.61.ebuild b/games-rpg/nwn/nwn-1.61.ebuild
new file mode 100644
index 000000000000..23f7c462dd28
--- /dev/null
+++ b/games-rpg/nwn/nwn-1.61.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/nwn/nwn-1.61.ebuild,v 1.1 2004/01/03 21:55:52 vapier Exp $
+
+inherit games
+
+UPDATEVER=${PV//.}
+DESCRIPTION="Never Winter Nights"
+HOMEPAGE="http://nwn.bioware.com/downloads/linuxclient.html"
+SRC_URI="http://nwdownloads.bioware.com/neverwinternights/linux/129/nwclient129.tar.gz
+ nowin? ( ftp://jeuxlinux.com/bioware/Neverwinter_Nights/nwresources129.tar.gz )
+ http://nwdownloads.bioware.com/neverwinternights/linux/161/linuxclientupdate129to${UPDATEVER}eng.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="nowin"
+RESTRICT="fetch nostrip nomirror"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl )
+ >=media-libs/libsdl-1.2.5"
+
+S=${WORKDIR}/nwn
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack nwclient129.tar.gz
+ cd ${WORKDIR}
+ use nowin && unpack nwresources129.tar.gz
+ cd ${S}
+ unpack linuxclientupdate129to${UPDATEVER}eng.tar.gz
+}
+
+src_install() {
+ dodir ${GAMES_PREFIX_OPT}
+ sed \
+ -e "s:GENTOO_USER:${GAMES_USER}:" \
+ -e "s:GENTOO_GROUP:${GAMES_GROUP}:" \
+ -e "s:GENTOO_DIR:${GAMES_PREFIX_OPT}:" \
+ ${FILESDIR}/${P}-fixinstall > ${WORKDIR}/nwn/fixinstall
+ mv ${WORKDIR}/nwn ${D}/${GAMES_PREFIX_OPT}
+ dogamesbin ${FILESDIR}/nwn
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if [ ! `use nowin` ] ; then
+ einfo "The NWN linux client is now installed."
+ einfo "Proceed with the following steps in order to get it working:"
+ einfo "1) Copy the following directories/files from your installed and"
+ einfo " patched (${PV}) Never Winter Nights to ${GAMES_PREFIX_OPT}/nwn:"
+ einfo " ambient/"
+ einfo " data/"
+ einfo " dmvault/"
+ einfo " hak/"
+ einfo " localvault/"
+ einfo " modules/"
+ einfo " music/"
+ einfo " nwm/"
+ einfo " override/"
+ einfo " portraits/"
+ einfo " saves/"
+ einfo " servervault/"
+ einfo " texturepacks/"
+ einfo " chitin.key"
+ einfo " patch.key"
+ einfo " dialog.tlk"
+ einfo " dialogF.tlk (French, German, Italian, and Spanish)"
+ einfo "2) Chown and chmod the files with the following commands"
+ einfo " chown -R ${GAMES_USER}:${GAMES_GROUP} ${GAMES_PREFIX_OPT}/nwn"
+ einfo " chmod -R g+rwX ${GAMES_PREFIX_OPT}/nwn"
+ einfo "3) Run ${GAMES_PREFIX_OPT}/nwn/fixinstall as root"
+ einfo "4) Make sure that you are in group ${GAMES_GROUP}"
+ einfo "5) Use ${GAMES_PREFIX_OPT}/nwn/nwn to run the game"
+ echo
+ einfo "Or try emerging with USE=nowin"
+ else
+ einfo "The NWN linux client is now installed."
+ einfo "Proceed with the following step in order to get it working:"
+ einfo "Run ${GAMES_PREFIX_OPT}/nwn/fixinstall as root"
+ fi
+}