summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-08-31 09:08:48 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-08-31 09:08:48 +0000
commita8e761f4e88bf81cf8e1be7e65a9d9e313a98b9b (patch)
treeaa6e76dd65b6367262c41d3f0471e465766f1dea /games-rpg/daimonin-client
parentadded get_libdir_override for overriding it's default behavior from inside an... (diff)
downloadhistorical-a8e761f4e88bf81cf8e1be7e65a9d9e313a98b9b.tar.gz
historical-a8e761f4e88bf81cf8e1be7e65a9d9e313a98b9b.tar.bz2
historical-a8e761f4e88bf81cf8e1be7e65a9d9e313a98b9b.zip
version bump
Diffstat (limited to 'games-rpg/daimonin-client')
-rw-r--r--games-rpg/daimonin-client/ChangeLog9
-rw-r--r--games-rpg/daimonin-client/Manifest5
-rw-r--r--games-rpg/daimonin-client/daimonin-client-0.96.5_beta3.ebuild54
-rw-r--r--games-rpg/daimonin-client/files/0.96.5_beta3-gentoo-paths.patch102
-rw-r--r--games-rpg/daimonin-client/files/digest-daimonin-client-0.96.5_beta31
5 files changed, 169 insertions, 2 deletions
diff --git a/games-rpg/daimonin-client/ChangeLog b/games-rpg/daimonin-client/ChangeLog
index 383217d460e7..cabab0931611 100644
--- a/games-rpg/daimonin-client/ChangeLog
+++ b/games-rpg/daimonin-client/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-rpg/daimonin-client
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/ChangeLog,v 1.7 2004/06/29 23:35:50 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/ChangeLog,v 1.8 2004/08/31 09:08:48 mr_bones_ Exp $
+
+*daimonin-client-0.96.5_beta3 (31 Aug 2004)
+
+ 31 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/0.96.5_beta3-gentoo-paths.patch,
+ +daimonin-client-0.96.5_beta3.ebuild:
+ version bump
*daimonin-client-0.96_beta2 (29 Jun 2004)
diff --git a/games-rpg/daimonin-client/Manifest b/games-rpg/daimonin-client/Manifest
index a23d6fd7ed69..e3f359633d26 100644
--- a/games-rpg/daimonin-client/Manifest
+++ b/games-rpg/daimonin-client/Manifest
@@ -1,9 +1,12 @@
-MD5 1b4e76774506f894edd04e3a8381f6a0 ChangeLog 1208
+MD5 6855ea6f8378d9cfc98aa0aa50c357b1 ChangeLog 1406
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 7d6247711b2e09655745a36d2606c00c daimonin-client-0.95b-r2.ebuild 1134
MD5 5f02949b8b24d3cc9c0e43b20043ea9b daimonin-client-0.96_beta2.ebuild 1514
+MD5 820e1cadafe394606ca00d515ba23874 daimonin-client-0.96.5_beta3.ebuild 1507
MD5 f0fea0494c9b50a88620443df60a150e files/0.95b-gcc3.patch 1664
MD5 49fc669e5a92e2d43091dbcb3f5afec2 files/0.95b-gentoo-paths.patch 2948
MD5 b7f58f6b5220a09dedb532eb977bd227 files/digest-daimonin-client-0.95b-r2 69
MD5 fff92cef909650f347db6cebfd2973dd files/digest-daimonin-client-0.96_beta2 81
MD5 8a41290909b2aa9cf1835f6aac36c738 files/0.96a_beta2-gentoo-paths.patch 3172
+MD5 1c6ea71495b869335ba165cc4600e07c files/digest-daimonin-client-0.96.5_beta3 82
+MD5 8a41290909b2aa9cf1835f6aac36c738 files/0.96.5_beta3-gentoo-paths.patch 3172
diff --git a/games-rpg/daimonin-client/daimonin-client-0.96.5_beta3.ebuild b/games-rpg/daimonin-client/daimonin-client-0.96.5_beta3.ebuild
new file mode 100644
index 000000000000..008d79e5c68a
--- /dev/null
+++ b/games-rpg/daimonin-client/daimonin-client-0.96.5_beta3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/daimonin-client-0.96.5_beta3.ebuild,v 1.1 2004/08/31 09:08:48 mr_bones_ Exp $
+
+inherit eutils flag-o-matic games
+
+MY_PV=${PV/_beta*}
+MY_PV=${MY_PV//.}
+DESCRIPTION="MMORPG with 2D isometric tiles grafik, true color and alpha blending effects"
+HOMEPAGE="http://daimonin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/daimonin/daimonin_client_src-BETA3-${MY_PV}a.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ virtual/x11"
+
+S="${WORKDIR}/daimonin/client"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-gentoo-paths.patch"
+ chmod a+x make/linux/configure
+}
+
+src_compile() {
+ append-flags \
+ -DGENTOO_DATADIR="'\"${GAMES_DATADIR}/${PN}\"'" \
+ -DGENTOO_STATEDIR="'\"${GAMES_STATEDIR}/${PN}\"'"
+
+ cd make/linux
+ egamesconf || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin src/daimonin || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}" "${GAMES_STATEDIR}/${PN}"
+ cp -r bitmaps icons media sfx "${D}/${GAMES_DATADIR}/${PN}/" \
+ || die "cp failed"
+ cp -r cache gfx_user srv_files "${D}/${GAMES_STATEDIR}/${PN}/" \
+ || die "cp failed"
+ insinto "${GAMES_STATEDIR}/${PN}"
+ doins *.{dat,p0} || die "doins failed"
+ prepgamesdirs
+ find "${D}/${GAMES_STATEDIR}/${PN}/" -type d -print0 | xargs -0 \
+ chmod g+w
+}
diff --git a/games-rpg/daimonin-client/files/0.96.5_beta3-gentoo-paths.patch b/games-rpg/daimonin-client/files/0.96.5_beta3-gentoo-paths.patch
new file mode 100644
index 000000000000..94022939b3a9
--- /dev/null
+++ b/games-rpg/daimonin-client/files/0.96.5_beta3-gentoo-paths.patch
@@ -0,0 +1,102 @@
+diff -urN client/src/include/config.h client-new/src/include/config.h
+--- client/src/include/config.h 2004-05-13 19:14:52.000000000 +0100
++++ client-new/src/include/config.h 2004-06-13 13:23:55.408837640 +0100
+@@ -26,11 +26,11 @@
+ #define VERSION_CS 991016
+ #define VERSION_SC 991016
+
+-#define KEYBIND_FILE "./keys.dat"
+-#define OPTION_FILE "./options.dat"
+-#define ARCHDEF_FILE "./archdef.dat"
++#define KEYBIND_FILE GENTOO_STATEDIR "/keys.dat"
++#define OPTION_FILE GENTOO_STATEDIR "/options.dat"
++#define ARCHDEF_FILE GENTOO_STATEDIR "/archdef.dat"
+
+-#define LOG_FILE "./client.log"
++#define LOG_FILE GENTOO_STATEDIR "/client.log"
+
+ #define CLIENT_ICON_NAME "icon.png"
+
+diff -urN client/src/include/main.h client-new/src/include/main.h
+--- client/src/include/main.h 2004-05-13 19:14:52.000000000 +0100
++++ client-new/src/include/main.h 2004-06-13 13:33:36.773456784 +0100
+@@ -103,16 +103,16 @@
+
+ extern int bmaptype_table_size;
+
+-#define FILE_DAIMONIN_P0 "./daimonin.p0"
+-#define FILE_BMAPS_P0 "./bmaps.p0"
+-#define FILE_BMAPS_TMP "./srv_files/bmaps.tmp"
+-#define FILE_ANIMS_TMP "./srv_files/anims.tmp"
+-
+-#define FILE_CLIENT_SPELLS "./srv_files/client_spells"
+-#define FILE_CLIENT_SKILLS "./srv_files/client_skills"
+-#define FILE_CLIENT_SETTINGS "./srv_files/client_settings"
+-#define FILE_CLIENT_BMAPS "./srv_files/client_bmap"
+-#define FILE_CLIENT_ANIMS "./srv_files/client_anims"
++#define FILE_DAIMONIN_P0 GENTOO_STATEDIR "/daimonin.p0"
++#define FILE_BMAPS_P0 GENTOO_STATEDIR "/bmaps.p0"
++#define FILE_BMAPS_TMP GENTOO_STATEDIR "/srv_files/bmaps.tmp"
++#define FILE_ANIMS_TMP GENTOO_STATEDIR "/srv_files/anims.tmp"
++
++#define FILE_CLIENT_SPELLS GENTOO_STATEDIR "/srv_files/client_spells"
++#define FILE_CLIENT_SKILLS GENTOO_STATEDIR "/srv_files/client_skills"
++#define FILE_CLIENT_SETTINGS GENTOO_STATEDIR "/srv_files/client_settings"
++#define FILE_CLIENT_BMAPS GENTOO_STATEDIR "/srv_files/client_bmap"
++#define FILE_CLIENT_ANIMS GENTOO_STATEDIR "/srv_files/client_anims"
+
+ enum {
+ SRV_CLIENT_SKILLS,
+diff -urN client/src/wrapper.c client-new/src/wrapper.c
+--- client/src/wrapper.c 2004-05-13 19:14:52.000000000 +0100
++++ client-new/src/wrapper.c 2004-06-13 13:45:34.944278224 +0100
+@@ -84,35 +84,35 @@
+ char * GetBitmapDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./bitmaps/");
++ return(GENTOO_DATADIR "/bitmaps/");
+ #endif
+ }
+
+ char * GetIconDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./icons/");
++ return(GENTOO_DATADIR "/icons/");
+ #endif
+ }
+
+ char * GetSfxDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./sfx/");
++ return(GENTOO_DATADIR "/sfx/");
+ #endif
+ }
+
+ char * GetCacheDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./cache/");
++ return(GENTOO_STATEDIR "/cache/");
+ #endif
+ }
+
+ char * GetGfxUserDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./gfx_user/");
++ return(GENTOO_STATEDIR "/gfx_user/");
+ #endif
+ }
+
+@@ -120,7 +120,7 @@
+ char * GetMediaDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./media/");
++ return(GENTOO_DATADIR "/media/");
+ #endif
+ }
+
diff --git a/games-rpg/daimonin-client/files/digest-daimonin-client-0.96.5_beta3 b/games-rpg/daimonin-client/files/digest-daimonin-client-0.96.5_beta3
new file mode 100644
index 000000000000..248137725686
--- /dev/null
+++ b/games-rpg/daimonin-client/files/digest-daimonin-client-0.96.5_beta3
@@ -0,0 +1 @@
+MD5 c7dea1391ba8771ee182e0faccc8b499 daimonin_client_src-BETA3-0965a.tgz 14444070