summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-09-11 06:52:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-09-11 06:52:00 +0000
commit7bc5fb8c32ca5618bf0c6795a64292e3fd956545 (patch)
tree6328bd5631ce80de2779e1c8f39ca7db0435785f /games-roguelike
parentMask media-plugins/audacious-xosd (diff)
downloadhistorical-7bc5fb8c32ca5618bf0c6795a64292e3fd956545.tar.gz
historical-7bc5fb8c32ca5618bf0c6795a64292e3fd956545.tar.bz2
historical-7bc5fb8c32ca5618bf0c6795a64292e3fd956545.zip
sed patch from Kevin Pyle to fix buffer overflow (bug #336603)
Package-Manager: portage-2.1.8.3/cvs/Linux i686
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/scourge/ChangeLog6
-rw-r--r--games-roguelike/scourge/scourge-0.21.1.ebuild5
2 files changed, 9 insertions, 2 deletions
diff --git a/games-roguelike/scourge/ChangeLog b/games-roguelike/scourge/ChangeLog
index 9c17fbae333c..8201631a52ef 100644
--- a/games-roguelike/scourge/ChangeLog
+++ b/games-roguelike/scourge/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-roguelike/scourge
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/ChangeLog,v 1.35 2010/01/22 20:10:21 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/ChangeLog,v 1.36 2010/09/11 06:51:59 mr_bones_ Exp $
+
+ 11 Sep 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ scourge-0.21.1.ebuild:
+ sed patch from Kevin Pyle to fix buffer overflow (bug #336603)
22 Jan 2010; Brent Baude <ranger@gentoo.org> scourge-0.21.1.ebuild:
stable ppc, bug 289117
diff --git a/games-roguelike/scourge/scourge-0.21.1.ebuild b/games-roguelike/scourge/scourge-0.21.1.ebuild
index 027a1182d5a2..b2f21fa9127f 100644
--- a/games-roguelike/scourge/scourge-0.21.1.ebuild
+++ b/games-roguelike/scourge/scourge-0.21.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/scourge-0.21.1.ebuild,v 1.4 2010/01/22 20:10:21 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/scourge-0.21.1.ebuild,v 1.5 2010/09/11 06:52:00 mr_bones_ Exp $
EAPI=2
inherit autotools eutils wxwidgets games
@@ -34,6 +34,9 @@ src_prepare() {
-e '/AC_CHECK_HEADERS.*glext/ s:):, [#include <GL/gl.h>] ):' \
configure.in \
|| die "sed failed"
+ sed -i \
+ -e '/snprintf/s/tmp, 256/tmp, sizeof(tmp)/' \
+ src/scourgehandler.cpp || die
eautoreconf
}