summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-06-01 20:39:10 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-06-01 20:39:10 +0000
commitec058048f34248d37848cee9bbf9067553b30b30 (patch)
tree1ebe3800ff1993d92be2000cc9ea0186c1229f4b /games-puzzle
parentAdd patch for building with gcc-4.1. (diff)
downloadhistorical-ec058048f34248d37848cee9bbf9067553b30b30.tar.gz
historical-ec058048f34248d37848cee9bbf9067553b30b30.tar.bz2
historical-ec058048f34248d37848cee9bbf9067553b30b30.zip
Fixing compiler flags, bug #130504
Package-Manager: portage-2.1_rc3-r1
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/ngstar/ChangeLog8
-rw-r--r--games-puzzle/ngstar/files/digest-ngstar-2.1.8-r23
-rw-r--r--games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild40
3 files changed, 50 insertions, 1 deletions
diff --git a/games-puzzle/ngstar/ChangeLog b/games-puzzle/ngstar/ChangeLog
index 8c9b405d503f..4631bcdaac38 100644
--- a/games-puzzle/ngstar/ChangeLog
+++ b/games-puzzle/ngstar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/ngstar
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ngstar/ChangeLog,v 1.3 2006/04/23 02:37:22 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ngstar/ChangeLog,v 1.4 2006/06/01 20:39:10 tupone Exp $
+
+*ngstar-2.1.8-r2 (01 Jun 2006)
+
+ 01 Jun 2006; <Tupone@gentoo.org> -ngstar-2.1.8-r1.ebuild,
+ +ngstar-2.1.8-r2.ebuild:
+ Fixing compiler flags, bug 130504 by Alexandru Toma
23 Apr 2006; <Tupone@gentoo.org> ngstar-2.1.8-r1.ebuild:
Forgot to inherit eutils.
diff --git a/games-puzzle/ngstar/files/digest-ngstar-2.1.8-r2 b/games-puzzle/ngstar/files/digest-ngstar-2.1.8-r2
new file mode 100644
index 000000000000..460c87d186fc
--- /dev/null
+++ b/games-puzzle/ngstar/files/digest-ngstar-2.1.8-r2
@@ -0,0 +1,3 @@
+MD5 9b4866b16f32e670f8b97e477dcd62fe ngstar-2.1.8-src.tar.bz2 45851
+RMD160 6b31bcbf0c5bcf385bca391fd9dea92e207e7321 ngstar-2.1.8-src.tar.bz2 45851
+SHA256 c8a2cf84d2a4bb40280d4ce307ceaed8f97d2183f79f7a82b38b78aaedb73fb3 ngstar-2.1.8-src.tar.bz2 45851
diff --git a/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild b/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild
new file mode 100644
index 000000000000..80ff580f9b3d
--- /dev/null
+++ b/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ngstar/ngstar-2.1.8-r2.ebuild,v 1.1 2006/06/01 20:39:10 tupone Exp $
+
+inherit eutils games
+
+DESCRIPTION="NGStar is a clone of a HP48 game called dstar"
+HOMEPAGE="http://cycojesus.free.fr/faire/coder/jouer/ng-star/"
+SRC_URI="http://cycojesus.free.fr/faire/coder/jouer/ng-star/files/${P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}"-gentoo-path.patch
+ sed -i \
+ -e "s:@GENTOO_DATA@:${GAMES_DATADIR}:" \
+ -e "s:@GENTOO_BIN@:${GAMES_BINDIR}:" \
+ -e "/^CPPFLAGS/s:+=:+= ${CXXFLAGS}:" \
+ configure
+}
+
+src_compile() {
+ ./configure \
+ --prefix "" \
+ --without-fltk2 || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS Changelog README TODO
+ prepgamesdirs
+}