summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-10-06 05:33:21 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-10-06 05:33:21 +0000
commit146e5a55f670a53ecfa075665b0a5443d87b6a8d (patch)
tree3391d27d145a763ddb073e120f1a2116231d0876 /games-puzzle
parentversion bump (diff)
downloadhistorical-146e5a55f670a53ecfa075665b0a5443d87b6a8d.tar.gz
historical-146e5a55f670a53ecfa075665b0a5443d87b6a8d.tar.bz2
historical-146e5a55f670a53ecfa075665b0a5443d87b6a8d.zip
fix compile error with gcc34 (bug #66142) (again)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/atomix/ChangeLog7
-rw-r--r--games-puzzle/atomix/Manifest4
-rw-r--r--games-puzzle/atomix/atomix-1.0.1.ebuild6
3 files changed, 12 insertions, 5 deletions
diff --git a/games-puzzle/atomix/ChangeLog b/games-puzzle/atomix/ChangeLog
index 5114d8969729..3a26348c719d 100644
--- a/games-puzzle/atomix/ChangeLog
+++ b/games-puzzle/atomix/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-puzzle/atomix
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/atomix/ChangeLog,v 1.6 2004/10/03 07:08:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/atomix/ChangeLog,v 1.7 2004/10/06 05:33:21 mr_bones_ Exp $
+
+ 05 Oct 2004; Michael Sterrett <mr_bones_@gentoo.org> atomix-1.0.1.ebuild:
+ fix compile error with gcc34 (bug #66142) (again)
03 Oct 2004; Michael Sterrett <mr_bones_@gentoo.org> atomix-1.0.1.ebuild:
fix compile error with gcc34 (bug #66142)
@@ -17,4 +20,4 @@
28 Jul 2002; Gabriele Giorgetti <stroke@gentoo.org> atomix-0.9.4.ebuild :
- Initial cvs import. A mind game for GNOME2 \ No newline at end of file
+ Initial cvs import. A mind game for GNOME2
diff --git a/games-puzzle/atomix/Manifest b/games-puzzle/atomix/Manifest
index f665b83c693c..07f7bc230858 100644
--- a/games-puzzle/atomix/Manifest
+++ b/games-puzzle/atomix/Manifest
@@ -1,4 +1,4 @@
-MD5 170c22e751eb4640d6dadd8b909294ff ChangeLog 757
+MD5 a43b385e48a3833f7c70589b8d8d7d2f ChangeLog 887
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 d0bd0ccd8994e534865accdd72442acb atomix-1.0.1.ebuild 1198
+MD5 814f92801392a9737981714ecf7301aa atomix-1.0.1.ebuild 1286
MD5 856b6bd13d4c9efac37f882d6eef9425 files/digest-atomix-1.0.1 64
diff --git a/games-puzzle/atomix/atomix-1.0.1.ebuild b/games-puzzle/atomix/atomix-1.0.1.ebuild
index bc9fd889358a..96f2d19be129 100644
--- a/games-puzzle/atomix/atomix-1.0.1.ebuild
+++ b/games-puzzle/atomix/atomix-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/atomix/atomix-1.0.1.ebuild,v 1.6 2004/10/03 07:08:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/atomix/atomix-1.0.1.ebuild,v 1.7 2004/10/06 05:33:21 mr_bones_ Exp $
inherit gnome2
@@ -38,6 +38,10 @@ src_unpack() {
-e 's/default:/default:;/' src/goal-view.c \
|| die "sed failed"
sed -i \
+ -e '581 s/default:/default:;/' src/level-convert.c \
+ || die "sed failed"
+
+ sed -i \
-e 's/games.games/games:games/' Makefile.in \
|| die "sed failed"
}