summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-07 16:32:38 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-07 16:32:38 +0000
commit482e947a4d72cd81d0fc61ba0849d7be61b96db7 (patch)
tree778049e41be36b004b6e6ce07b8b39ec107af62e /games-kids
parentadded ~mips and ~alpha, changed HOMEPAGE (diff)
downloadhistorical-482e947a4d72cd81d0fc61ba0849d7be61b96db7.tar.gz
historical-482e947a4d72cd81d0fc61ba0849d7be61b96db7.tar.bz2
historical-482e947a4d72cd81d0fc61ba0849d7be61b96db7.zip
ver bump
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/gcompris/ChangeLog7
-rw-r--r--games-kids/gcompris/files/digest-gcompris-4.11
-rw-r--r--games-kids/gcompris/gcompris-4.1.ebuild60
3 files changed, 67 insertions, 1 deletions
diff --git a/games-kids/gcompris/ChangeLog b/games-kids/gcompris/ChangeLog
index 950463a2f40f..8402cc67f2ee 100644
--- a/games-kids/gcompris/ChangeLog
+++ b/games-kids/gcompris/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-kids/gcompris
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/ChangeLog,v 1.2 2003/09/10 15:57:25 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/ChangeLog,v 1.3 2003/11/07 16:32:38 vapier Exp $
+
+*gcompris-4.1 (07 Nov 2003)
+
+ 07 Nov 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump.
*gcompris-3.2 (18 Aug 2003)
diff --git a/games-kids/gcompris/files/digest-gcompris-4.1 b/games-kids/gcompris/files/digest-gcompris-4.1
new file mode 100644
index 000000000000..899015a13cd7
--- /dev/null
+++ b/games-kids/gcompris/files/digest-gcompris-4.1
@@ -0,0 +1 @@
+MD5 f3bd7497af6b044c98d21ce238d9af7b gcompris-4.1.tar.gz 32551839
diff --git a/games-kids/gcompris/gcompris-4.1.ebuild b/games-kids/gcompris/gcompris-4.1.ebuild
new file mode 100644
index 000000000000..a984f29a560f
--- /dev/null
+++ b/games-kids/gcompris/gcompris-4.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: initial version by Ron Simpkin doobedoobedo@quake3world.com
+
+inherit games
+
+DESCRIPTION="full featured educational application for children from 3 to 10"
+HOMEPAGE="http://ofset.sourceforge.net/gcompris/"
+SRC_URI="mirror://sourceforge/gcompris/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="oggvorbis nls python"
+
+DEPEND="virtual/x11
+ >=sys-apps/sed-4
+ >=gnome-base/libgnome-1.96.0
+ >=gnome-base/libgnomeui-1.96.0
+ >=gnome-base/libgnomecanvas-2.0.2
+ >=dev-libs/glib-2.0
+ =x11-libs/gtk+-2*
+ dev-libs/libxml2
+ games-board/gnuchess
+ sys-apps/texinfo
+ app-text/texi2html
+ python? ( dev-lang/python )
+ oggvorbis? ( media-libs/libogg
+ media-libs/libvorbis
+ media-libs/libao )"
+
+src_compile() {
+ export GNUCHESS="${GAMES_BINDIR}/gnuchess"
+
+ local myconf=""
+ use oggvorbis && myconf="${myconf} --with-ogg=/usr --with-vorbis=/usr --with-ao=/usr"
+ use python && myconf="${myconf} --with-python=`which python`"
+ egamesconf ${myconf} || die
+ for f in `grep -Rl /usr/games/share *` ; do
+ sed -i \
+ -e "s:${GAMES_PREFIX}/share/gnome:/usr/share/gnome:g" \
+ -e "s:${GAMES_PREFIX}/share:${GAMES_DATADIR}:g" \
+ ${f} || die "sed ${f} failed"
+ done
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ mv ${D}/${GAMES_DATADIR}/{locale,gnome,pixmaps} ${D}/usr/share/
+ rm -rf ${D}/${GAMES_LIBDIR}/menu
+ if [ ! `use nls` ] ; then
+ rm -rf ${D}/usr/share/locale
+ cd ${D}/${GAMES_DATADIR}/gcompris/boards/sounds
+ rm -rf `find -type d -maxdepth 1 -mindepth 1 ! -name en`
+ fi
+ prepgamesdirs
+}