summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-13 00:39:18 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-13 00:39:18 +0000
commit3de498b7da396bf4b1d83f3c31fb89fbf945b118 (patch)
tree83a020f05d9442a41e5a6919bf3844a054b71023 /games-fps
parentRevision bump to add the new revdep-rebuild from bug #62644 for arch testing. (diff)
downloadhistorical-3de498b7da396bf4b1d83f3c31fb89fbf945b118.tar.gz
historical-3de498b7da396bf4b1d83f3c31fb89fbf945b118.tar.bz2
historical-3de498b7da396bf4b1d83f3c31fb89fbf945b118.zip
fix duplicated typedefs properly #71841
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/industri/Manifest3
-rw-r--r--games-fps/industri/files/1.01-nvidia-opengl.patch20
-rw-r--r--games-fps/industri/industri-1.01.ebuild26
3 files changed, 18 insertions, 31 deletions
diff --git a/games-fps/industri/Manifest b/games-fps/industri/Manifest
index 82e53c626aee..5d06c4a1587c 100644
--- a/games-fps/industri/Manifest
+++ b/games-fps/industri/Manifest
@@ -1,6 +1,5 @@
-MD5 72259eafed6f23926c668e7e9ac12be8 industri-1.01.ebuild 1451
MD5 4d022ffdc36f8c015a33c5b7b953491a ChangeLog 430
+MD5 1fdcbe2e8b4a91306cca265a469ddea5 industri-1.01.ebuild 1600
MD5 97d0c324ee72786e94f04f1bc052cc63 metadata.xml 669
MD5 c85d9088fac1afff8639c4e07123c098 files/digest-industri-1.01 138
MD5 5c2c277e6fc318889a5bc2bf4f26c473 files/industri.pretty 42
-MD5 a49d2e91753fb140005919f4de2eb3c6 files/1.01-nvidia-opengl.patch 1078
diff --git a/games-fps/industri/files/1.01-nvidia-opengl.patch b/games-fps/industri/files/1.01-nvidia-opengl.patch
deleted file mode 100644
index 1bbd5f1e585b..000000000000
--- a/games-fps/industri/files/1.01-nvidia-opengl.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- glquake.h 2003-07-14 17:06:01.000000000 -0400
-+++ ../../glquake.h 2003-07-15 02:24:09.000000000 -0400
-@@ -657,7 +657,7 @@
- #endif /* !__APPLE__ && !MACOSX */
-
- // - DC -
--#if !defined(SDL) && !defined (__glx__)
-+//#if !defined(SDL) && !defined (__glx__)
- typedef void (APIENTRY * PFNGLCOMBINERPARAMETERFVNVPROC) (GLenum pname, const GLfloat *params);
- typedef void (APIENTRY * PFNGLCOMBINERPARAMETERFNVPROC) (GLenum pname, GLfloat param);
- typedef void (APIENTRY * PFNGLCOMBINERPARAMETERIVNVPROC) (GLenum pname, const GLint *params);
-@@ -671,7 +671,7 @@
- typedef void (APIENTRY * PFNGLGETCOMBINEROUTPUTPARAMETERIVNVPROC) (GLenum stage, GLenum portion, GLenum pname, GLint *params);
- typedef void (APIENTRY * PFNGLGETFINALCOMBINERINPUTPARAMETERFVNVPROC) (GLenum variable, GLenum pname, GLfloat *params);
- typedef void (APIENTRY * PFNGLGETFINALCOMBINERINPUTPARAMETERIVNVPROC) (GLenum variable, GLenum pname, GLint *params);
--#endif
-+//#endif
-
- extern PFNGLCOMBINERPARAMETERFVNVPROC qglCombinerParameterfvNV;
- extern PFNGLCOMBINERPARAMETERIVNVPROC qglCombinerParameterivNV;
diff --git a/games-fps/industri/industri-1.01.ebuild b/games-fps/industri/industri-1.01.ebuild
index 95a6543643d2..4bde393219fd 100644
--- a/games-fps/industri/industri-1.01.ebuild
+++ b/games-fps/industri/industri-1.01.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/industri-1.01.ebuild,v 1.7 2004/06/25 03:23:01 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/industri/industri-1.01.ebuild,v 1.8 2005/06/13 00:39:18 vapier Exp $
-inherit eutils games
+inherit games toolchain-funcs
DESCRIPTION="Quake/Tenebrae based, single player game"
HOMEPAGE="http://industri.sourceforge.net/"
@@ -19,16 +19,24 @@ DEPEND="virtual/opengl
media-libs/libpng
sys-libs/zlib"
-S="${WORKDIR}/industri_BIN"
+S=${WORKDIR}/industri_BIN
src_unpack() {
unpack ${A}
- cd ${S}/linux
+ cd "${S}"/linux
mv Makefile.i386linux Makefile
- local gl="`ls -al /usr/include/GL/gl.h | awk '{print $NF}' | cut -d/ -f5`"
- [ "${gl}" == "nvidia" ] && epatch ${FILESDIR}/${PV}-nvidia-opengl.patch
sed -i "s:-mpentiumpro.*:${CFLAGS} \\\\:" Makefile
+
+ # Remove duplicated typedefs #71841
+ cd "${S}"
+ for typ in PFNGLFLUSHVERTEXARRAYRANGEAPPLEPROC PFNGLVERTEXARRAYRANGEAPPLEPROC ; do
+ if echo '#include <GL/gl.h>' | $(tc-getCC) -E - 2>/dev/null | grep -sq ${typ} ; then
+ sed -i \
+ -e "/^typedef.*${typ}/d" \
+ glquake.h
+ fi
+ done
}
src_compile() {
@@ -38,11 +46,11 @@ src_compile() {
src_install() {
newgamesbin linux/release*/bin/industri.run industri || die
- dogamesbin ${FILESDIR}/industri.pretty || die
+ dogamesbin "${FILESDIR}"/industri.pretty || die
insinto /usr/share/icons
doins industri.ico quake.ico
dodoc linux/README
- cd ${WORKDIR}/industri
+ cd "${WORKDIR}"/industri
dodoc *.txt && rm *.txt
insinto ${GAMES_DATADIR}/quake-data/industri
doins *