summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-16 23:37:26 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-16 23:37:26 +0000
commit3645896727079b79ed1ebd257499f29c2bbc3f3e (patch)
tree676d8abcd13b9c989fe024a8fd4b3f3e8bce3f53 /games-fps/quake1-ctf/quake1-ctf-4.0.ebuild
parentStable on x86 (diff)
downloadhistorical-3645896727079b79ed1ebd257499f29c2bbc3f3e.tar.gz
historical-3645896727079b79ed1ebd257499f29c2bbc3f3e.tar.bz2
historical-3645896727079b79ed1ebd257499f29c2bbc3f3e.zip
initial import
Package-Manager: portage-2.0.51-r13
Diffstat (limited to 'games-fps/quake1-ctf/quake1-ctf-4.0.ebuild')
-rw-r--r--games-fps/quake1-ctf/quake1-ctf-4.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/games-fps/quake1-ctf/quake1-ctf-4.0.ebuild b/games-fps/quake1-ctf/quake1-ctf-4.0.ebuild
new file mode 100644
index 000000000000..43018af3976b
--- /dev/null
+++ b/games-fps/quake1-ctf/quake1-ctf-4.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake1-ctf/quake1-ctf-4.0.ebuild,v 1.1 2005/01/16 23:37:26 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="The original Three Wave Capture The Flag"
+HOMEPAGE="http://www.threewave.com/"
+SRC_URI="http://www.threewave.com/quake1/files/3wctf301.zip
+ http://www.threewave.com/quake1/files/3wctfc40.zip
+ http://www.threewave.com/quake1/files/ctfepc14.zip
+ http://www.threewave.com/quake1/files/alst101c.zip
+ http://www.threewave.com/quake1/files/alst110u.zip"
+# dedicated? ( http://www.threewave.com/quake1/files/alst110s.zip )
+# dedicated? ( http://www.threewave.com/quake1/files/3wave421d.zip )
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+
+src_unpack() {
+ mkdir ctf
+ cd ctf
+ echo ">>> Unpacking 3wctf301.zip to ${PWD}"
+ unzip -qoL "${DISTDIR}"/3wctf301.zip || die "unpacking 3wctf301.zip failed"
+ mv readme.txt readme-301.txt
+ echo ">>> Unpacking 3wctfc40.zip to ${PWD}"
+ unzip -qoL "${DISTDIR}"/3wctfc40.zip || die "unpacking 3wctfc40.zip failed"
+ mv readme.txt readme-40.txt
+ echo ">>> Unpacking ctfepc14.zip to ${PWD}"
+ unzip -qoL "${DISTDIR}"/ctfepc14.zip || die "unpacking ctfepc14.zip failed"
+ cd ..
+ echo ">>> Unpacking alst101c.zip to ${PWD}"
+ unzip -qoL "${DISTDIR}"/alst101c.zip || die "unpacking alst101c.zip failed"
+ mv ctf/readme.txt ctf/readme-alst101c.txt
+ echo ">>> Unpacking alst110u.zip to ${PWD}"
+ unzip -qoL "${DISTDIR}"/alst110u.zip || die "unpacking alst110u.zip failed"
+ mv ctf/readme.txt ctf/readme-alst110u.txt
+ rmdir maps progs readme
+}
+
+src_install() {
+ local dir=${GAMES_DATADIR}/quake-data
+ dodir "${dir}"
+ insinto "${dir}"
+ doins -r *
+ prepgamesdirs
+}