summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-07-07 19:17:54 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-07-07 19:17:54 +0000
commit5838b6a55f46707429f6ea4d9ee5ceb931399d2d (patch)
treebb67d6d409fa93b980e133ecf5d09b775ac59448 /games-fps/glxquake-bin/glxquake-bin-0-r2.ebuild
parentRemove old (diff)
downloadhistorical-5838b6a55f46707429f6ea4d9ee5ceb931399d2d.tar.gz
historical-5838b6a55f46707429f6ea4d9ee5ceb931399d2d.tar.bz2
historical-5838b6a55f46707429f6ea4d9ee5ceb931399d2d.zip
Bumped EAPI to 5, adjusted deps for gx86-multilib
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0x2B6559ED
Diffstat (limited to 'games-fps/glxquake-bin/glxquake-bin-0-r2.ebuild')
-rw-r--r--games-fps/glxquake-bin/glxquake-bin-0-r2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-fps/glxquake-bin/glxquake-bin-0-r2.ebuild b/games-fps/glxquake-bin/glxquake-bin-0-r2.ebuild
new file mode 100644
index 000000000000..ed1bd7cfed9a
--- /dev/null
+++ b/games-fps/glxquake-bin/glxquake-bin-0-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/glxquake-bin/glxquake-bin-0-r2.ebuild,v 1.1 2014/07/07 19:17:50 axs Exp $
+
+EAPI=5
+inherit games
+
+DESCRIPTION="a binary that works with every 3D-graphics-card that supports the glx X-extension"
+HOMEPAGE="http://mfcn.ilo.de/glxquake/"
+SRC_URI="http://www.wh-hms.uni-ulm.de/~mfcn/shared/glxquake/glxquake.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="strip"
+IUSE=""
+
+RDEPEND="sys-libs/glibc
+ amd64? ( sys-libs/glibc[multilib] )
+ || (
+ (
+ virtual/opengl[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libXxf86vm[abi_x86_32(-)]
+ x11-libs/libXxf86dga[abi_x86_32(-)]
+ )
+ (
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)]
+ ) )"
+
+S=${WORKDIR}/glxquake
+
+QA_PREBUILT="${GAMES_BINDIR:1}/glquake"
+
+src_install() {
+ dogamesbin glquake
+ dodoc README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "To play with it, create a subdirectory called id1"
+ elog "Copy the pak0.pak, and eventually pak1.pak into this subdirectory"
+ elog "You can eventually get pak0.pak emerging games-fps/quake1-demodata"
+ elog "The file pak0.pak will be on the ${GAMES_DATADIR}/quake1/demo/"
+ elog "You can now run glxquake by executing glquake"
+}