summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-02-23 05:45:35 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-02-23 05:45:35 +0000
commit038113285b88cceaaac1c0407e356b3517672079 (patch)
tree119ac7ebedc906f0102bcfddc8f1bca96facdc4b /games-fps/alephone
parentVersion bump to 0.6.11 (diff)
downloadhistorical-038113285b88cceaaac1c0407e356b3517672079.tar.gz
historical-038113285b88cceaaac1c0407e356b3517672079.tar.bz2
historical-038113285b88cceaaac1c0407e356b3517672079.zip
version bump (bug #82906) - patch from David Bailey
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'games-fps/alephone')
-rw-r--r--games-fps/alephone/ChangeLog8
-rw-r--r--games-fps/alephone/Manifest16
-rw-r--r--games-fps/alephone/alephone-20050118.ebuild59
-rw-r--r--games-fps/alephone/files/digest-alephone-200501181
4 files changed, 71 insertions, 13 deletions
diff --git a/games-fps/alephone/ChangeLog b/games-fps/alephone/ChangeLog
index 72de3f2d29e3..52f5c89c6f05 100644
--- a/games-fps/alephone/ChangeLog
+++ b/games-fps/alephone/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/alephone
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.1 2005/01/03 02:47:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.2 2005/02/23 05:45:35 mr_bones_ Exp $
+
+*alephone-20050118 (23 Feb 2005)
+
+ 23 Feb 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +alephone-20050118.ebuild:
+ version bump (bug #82906) - patch from David Bailey
*alephone-20040417 (02 Jan 2004)
diff --git a/games-fps/alephone/Manifest b/games-fps/alephone/Manifest
index 43d77291b1a4..253303e06556 100644
--- a/games-fps/alephone/Manifest
+++ b/games-fps/alephone/Manifest
@@ -1,15 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 e9741acebc0caec5efaa092f3641993c ChangeLog 373
+MD5 f5ba352e0b9e26666cf877eeeee8d562 ChangeLog 549
MD5 e609b79879668d1ba862a11bcb26daf4 alephone-20040417.ebuild 1166
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 d066c158a9be84eb6b74e20a66370581 files/digest-alephone-20040417 68
+MD5 5866f31254d39b8ae0d0440fdcaa4474 alephone-20050118.ebuild 1453
MD5 7c6943e706d040641031e7d8325b4e74 files/20040417-gcc34.patch 1567
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFB2LJrroRuSHgZdywRAnmwAJ9RSOnnhvmQu3WKlqizX3R8TxW/MQCeNVv0
-36jLKtqle20013YBTbmqHLc=
-=vdcg
------END PGP SIGNATURE-----
+MD5 d066c158a9be84eb6b74e20a66370581 files/digest-alephone-20040417 68
+MD5 adc3c7e48da56c50654521b80fe2f0e2 files/digest-alephone-20050118 68
diff --git a/games-fps/alephone/alephone-20050118.ebuild b/games-fps/alephone/alephone-20050118.ebuild
new file mode 100644
index 000000000000..8ec04b1a91d9
--- /dev/null
+++ b/games-fps/alephone/alephone-20050118.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20050118.ebuild,v 1.1 2005/02/23 05:45:35 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
+HOMEPAGE="http://source.bungie.org/"
+SRC_URI="mirror://sourceforge/marathon/aleph-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="opengl lua"
+
+DEPEND="opengl? ( virtual/opengl )
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-net
+ lua? ( dev-lang/lua )"
+
+S=${WORKDIR}/aleph-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ NO_CONFIGURE=bah ./autogen.sh || die "autogen failed"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable opengl) || die
+ if ! use lua ; then
+ # stupid configure script doesnt have an option
+ sed -i \
+ -e '/HAVE_LUA/d' config.h \
+ || die "sed HAVE_LUA"
+ sed -i \
+ -e '/^LIBS/s:-llua -llualib::' $(find -name Makefile) \
+ || die "sed -llua"
+ fi
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ keepdir "${GAMES_DATADIR}/AlephOne/"{Images,Map,Shapes,Sounds}
+ dodoc AUTHORS INSTALL.Unix README docs/Cheat_Codes
+ dohtml docs/MML.html
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "Read the docs and install the data files accordingly to play."
+ echo
+}
diff --git a/games-fps/alephone/files/digest-alephone-20050118 b/games-fps/alephone/files/digest-alephone-20050118
new file mode 100644
index 000000000000..9e044d5d5151
--- /dev/null
+++ b/games-fps/alephone/files/digest-alephone-20050118
@@ -0,0 +1 @@
+MD5 789f7fe1f67b60f31aab75bb48ecf552 aleph-20050118.tar.bz2 2324962