summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-12-04 20:46:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-12-04 20:46:52 +0000
commitf0c130cb7968e6b0248a41ad075331099dba5dc1 (patch)
treef1c9632d22bfabbffef3d7d35a79b6c583205ebe /games-emulation
parentBump for 7.0RC3. (diff)
downloadhistorical-f0c130cb7968e6b0248a41ad075331099dba5dc1.tar.gz
historical-f0c130cb7968e6b0248a41ad075331099dba5dc1.tar.bz2
historical-f0c130cb7968e6b0248a41ad075331099dba5dc1.zip
version bump
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/advancemame/ChangeLog8
-rw-r--r--games-emulation/advancemame/Manifest4
-rw-r--r--games-emulation/advancemame/advancemame-0.102.0.ebuild83
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.102.01
4 files changed, 94 insertions, 2 deletions
diff --git a/games-emulation/advancemame/ChangeLog b/games-emulation/advancemame/ChangeLog
index fb92708aee84..c545b799682c 100644
--- a/games-emulation/advancemame/ChangeLog
+++ b/games-emulation/advancemame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/advancemame
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.35 2005/10/17 03:37:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.36 2005/12/04 20:46:52 mr_bones_ Exp $
+
+*advancemame-0.102.0 (04 Dec 2005)
+
+ 04 Dec 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +advancemame-0.102.0.ebuild:
+ version bump
*advancemame-0.101.0 (17 Oct 2005)
diff --git a/games-emulation/advancemame/Manifest b/games-emulation/advancemame/Manifest
index 679912283862..92d933a76cfc 100644
--- a/games-emulation/advancemame/Manifest
+++ b/games-emulation/advancemame/Manifest
@@ -1,5 +1,7 @@
MD5 972b8c9f939a33a7074e0819fb55455c metadata.xml 962
+MD5 2e2abcc68d28c90fa326f5e70eaa60bb advancemame-0.102.0.ebuild 1983
MD5 6276350b3d70cb9387fb7adceeb59094 advancemame-0.101.0.ebuild 1983
-MD5 344ace28d61275a09d042192d71f3993 ChangeLog 6515
+MD5 b850752140903469a0997cd83036462b ChangeLog 6653
MD5 893791a430019a7eb1c0eaf15758a93f files/0.101.0-pic.patch 344
+MD5 e0c328f570afb381666eb2e0c88f913b files/digest-advancemame-0.102.0 73
MD5 6cb88ba34b78dc9a265b2b68bf084a66 files/digest-advancemame-0.101.0 73
diff --git a/games-emulation/advancemame/advancemame-0.102.0.ebuild b/games-emulation/advancemame/advancemame-0.102.0.ebuild
new file mode 100644
index 000000000000..4fc5d9e468e1
--- /dev/null
+++ b/games-emulation/advancemame/advancemame-0.102.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.102.0.ebuild,v 1.1 2005/12/04 20:46:52 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
+HOMEPAGE="http://advancemame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
+
+LICENSE="GPL-2 XMAME"
+SLOT="0"
+KEYWORDS="~amd64 -ppc x86"
+IUSE="alsa expat fbcon oss sdl slang static svga truetype zlib"
+
+RDEPEND="app-arch/unzip
+ app-arch/zip
+ sdl? ( media-libs/libsdl )
+ slang? ( sys-libs/slang )
+ alsa? ( media-libs/alsa-lib )
+ expat? ( >=dev-libs/expat-1.95.6 )
+ zlib? ( sys-libs/zlib )
+ truetype? ( media-libs/freetype )
+ svga? ( >=media-libs/svgalib-1.9 )"
+DEPEND="${RDEPEND}
+ x86? ( >=dev-lang/nasm-0.98 )
+ virtual/os-headers"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #epatch "${FILESDIR}/${PV}-pic.patch" #74899
+
+ use x86 && \
+ ln -s $(which nasm) "${T}/${CHOST}-nasm"
+ use sdl && \
+ ln -s $(which sdl-config) "${T}/${CHOST}-sdl-config"
+ use truetype && \
+ ln -s $(which freetype-config) "${T}/${CHOST}-freetype-config"
+}
+
+src_compile() {
+ PATH="${PATH}:${T}"
+ egamesconf \
+ $(use_enable alsa) \
+ $(use_enable expat) \
+ $(use_enable fbcon fb) \
+ $(use_enable oss) \
+ $(use_enable sdl) \
+ $(use_enable slang) \
+ $(use_enable static) \
+ $(use_enable svga svgalib) \
+ $(use_enable truetype freetype) \
+ $(use_enable zlib) \
+ $(use_enable x86 asm) \
+ --with-emu=${PN/advance} \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ local f
+
+ for f in adv* ; do
+ if [ -L "${f}" ] ; then
+ dogamesbin "${f}" || die "dogamesbin failed"
+ fi
+ done
+
+ insinto "${GAMES_DATADIR}/advance"
+ doins support/event.dat
+ keepdir "${GAMES_DATADIR}/advance/"{artwork,diff,image,rom,sample,snap}
+
+ dodoc HISTORY README RELEASE
+ cd doc
+ dodoc *.txt
+ dohtml *.html
+ for f in *.1 ; do
+ newman ${f} ${f/1/6}
+ done
+
+ prepgamesdirs
+}
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.102.0 b/games-emulation/advancemame/files/digest-advancemame-0.102.0
new file mode 100644
index 000000000000..1b2f49d61839
--- /dev/null
+++ b/games-emulation/advancemame/files/digest-advancemame-0.102.0
@@ -0,0 +1 @@
+MD5 7176260670c5a7b3732bbfb258f2e0ef advancemame-0.102.0.tar.gz 15776947