summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-28 00:50:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-28 00:50:17 +0000
commit2818c63a99bf148f8648c2abdb4380ff9163bbe3 (patch)
tree09f3933f72f8a5288636c6d6b29af649d664d949 /games-emulation
parentversion bump (bug 34548) (diff)
downloadhistorical-2818c63a99bf148f8648c2abdb4380ff9163bbe3.tar.gz
historical-2818c63a99bf148f8648c2abdb4380ff9163bbe3.tar.bz2
historical-2818c63a99bf148f8648c2abdb4380ff9163bbe3.zip
version bump (bug 34548)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/psemu-padjoy/Manifest5
-rw-r--r--games-emulation/psemu-padjoy/files/digest-psemu-padjoy-0.821
-rw-r--r--games-emulation/psemu-padjoy/metadata.xml9
-rw-r--r--games-emulation/psemu-padjoy/psemu-padjoy-0.82.ebuild34
4 files changed, 47 insertions, 2 deletions
diff --git a/games-emulation/psemu-padjoy/Manifest b/games-emulation/psemu-padjoy/Manifest
index 1fbc6de94a2d..141caab3a1e0 100644
--- a/games-emulation/psemu-padjoy/Manifest
+++ b/games-emulation/psemu-padjoy/Manifest
@@ -1,6 +1,7 @@
-MD5 ed48b1c856aac4ed3b91bcd6592f2330 ChangeLog 1347
+MD5 f2c79770c9e06912a7f7812b42c42ad5 ChangeLog 1495
MD5 96c4c3cf4a17dd2af92a4ed7be79187c psemu-padjoy-0.81.ebuild 858
-MD5 49015ba4d9097e71d0291b377b1a67ee psemu-padjoy-0.82.ebuild 944
+MD5 c336ea4bb7a19d251848c7cac6ee4f85 psemu-padjoy-0.82.ebuild 947
+MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
MD5 e4171d0010309486d615bb721570a2ff files/0.81-makefile-cflags.patch 386
MD5 9854361bcecd3f8f3c4a3f6b4820b9f8 files/digest-psemu-padjoy-0.81 57
MD5 972e128aa872de9aaf74ecbec368a9cb files/digest-psemu-padjoy-0.82 57
diff --git a/games-emulation/psemu-padjoy/files/digest-psemu-padjoy-0.82 b/games-emulation/psemu-padjoy/files/digest-psemu-padjoy-0.82
new file mode 100644
index 000000000000..fefcdbef75b9
--- /dev/null
+++ b/games-emulation/psemu-padjoy/files/digest-psemu-padjoy-0.82
@@ -0,0 +1 @@
+MD5 510fde521e641f002f39d132e56b6811 padJoy082.tgz 48399
diff --git a/games-emulation/psemu-padjoy/metadata.xml b/games-emulation/psemu-padjoy/metadata.xml
new file mode 100644
index 000000000000..1cef6e243af3
--- /dev/null
+++ b/games-emulation/psemu-padjoy/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+<email>games@gentoo.org</email>
+<name>Games Team</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-emulation/psemu-padjoy/psemu-padjoy-0.82.ebuild b/games-emulation/psemu-padjoy/psemu-padjoy-0.82.ebuild
new file mode 100644
index 000000000000..562c7db5408e
--- /dev/null
+++ b/games-emulation/psemu-padjoy/psemu-padjoy-0.82.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-padjoy/psemu-padjoy-0.82.ebuild,v 1.1 2003/11/28 00:50:15 mr_bones_ Exp $
+
+inherit games eutils
+
+S="${WORKDIR}/padJoy/src"
+DESCRIPTION="PSEmu plugin to use joysticks/gamepads in PSX-emulators"
+HOMEPAGE="http://www.ammoq.com/"
+SRC_URI="http://members.chello.at/erich.kitzmueller/ammoq/padJoy${PV//.}.tgz"
+
+KEYWORDS="x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="=x11-libs/gtk+-1*
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:-O2 -fomit-frame-pointer:${CFLAGS}:" Makefile || \
+ die "sed Makefile failed"
+}
+
+src_install() {
+ exeinto "${GAMES_LIBDIR}/psemu/plugins"
+ doexe libpadJoy-* || die "doexe failed"
+ exeinto "${GAMES_LIBDIR}/psemu/cfg"
+ doexe cfgPadJoy || die "doexe failed (2)"
+ dodoc ../readme.txt || die "dodoc failed"
+ prepgamesdirs
+}