summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-24 06:47:34 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-24 06:47:34 +0000
commit0ce8b4f8cef6dfd154520d6051da22db72883a04 (patch)
tree7d2d0963803af38ea10a1d5698dae760eaa0006b /games-emulation
parentdon't rdepend on sed (diff)
downloadhistorical-0ce8b4f8cef6dfd154520d6051da22db72883a04.tar.gz
historical-0ce8b4f8cef6dfd154520d6051da22db72883a04.tar.bz2
historical-0ce8b4f8cef6dfd154520d6051da22db72883a04.zip
don't rdepend on sed, nasm and unzip
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/gens/ChangeLog7
-rw-r--r--games-emulation/gens/gens-2.12a.ebuild14
2 files changed, 13 insertions, 8 deletions
diff --git a/games-emulation/gens/ChangeLog b/games-emulation/gens/ChangeLog
index b15cc408bc60..946753f46710 100644
--- a/games-emulation/gens/ChangeLog
+++ b/games-emulation/gens/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/gens
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/ChangeLog,v 1.5 2003/09/29 06:09:22 mr_bones_ Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/ChangeLog,v 1.6 2004/03/24 06:47:34 mr_bones_ Exp $
+
+ 23 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> gens-2.12a.ebuild:
+ don't rdepend on sed, nasm and unzip
28 Sep 2003; Michael Sterrett <mr_bones_@gentoo.org> gens-2.12a.ebuild:
don't use emake for install; add error message
diff --git a/games-emulation/gens/gens-2.12a.ebuild b/games-emulation/gens/gens-2.12a.ebuild
index e50431f1c11d..f11a96b31495 100644
--- a/games-emulation/gens/gens-2.12a.ebuild
+++ b/games-emulation/gens/gens-2.12a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/gens-2.12a.ebuild,v 1.3 2004/02/20 06:26:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gens/gens-2.12a.ebuild,v 1.4 2004/03/24 06:47:34 mr_bones_ Exp $
inherit games
@@ -13,16 +13,18 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-DEPEND=">=media-libs/libsdl-1.2
+RDEPEND="virtual/glibc
+ >=media-libs/libsdl-1.2
+ >=x11-libs/gtk+-2.0*"
+DEPEND="${RDEPEND}
app-arch/unzip
>=dev-lang/nasm-0.98
- >=sys-apps/sed-4
- >=x11-libs/gtk+-2.0*"
+ >=sys-apps/sed-4"
-S=${WORKDIR}/gens-linux-${PV}
+S="${WORKDIR}/gens-linux-${PV}"
src_install() {
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS BUGS README
prepgamesdirs
}