summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-03-21 08:10:09 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-03-21 08:10:09 +0000
commite25655771b17a155f49c2fe7f7e2d8fa1df5f1a7 (patch)
tree2798ae34f4cd7d56d37e3024d8f0ed0e2feb8e20 /games-emulation/nestra
parentAdded zsnes and nestra. (diff)
downloadhistorical-e25655771b17a155f49c2fe7f7e2d8fa1df5f1a7.tar.gz
historical-e25655771b17a155f49c2fe7f7e2d8fa1df5f1a7.tar.bz2
historical-e25655771b17a155f49c2fe7f7e2d8fa1df5f1a7.zip
Added support to build 32bit version on amd64.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-emulation/nestra')
-rw-r--r--games-emulation/nestra/ChangeLog8
-rw-r--r--games-emulation/nestra/Manifest14
-rw-r--r--games-emulation/nestra/nestra-0.66-r1.ebuild36
3 files changed, 48 insertions, 10 deletions
diff --git a/games-emulation/nestra/ChangeLog b/games-emulation/nestra/ChangeLog
index e63effe5848b..7c8dac93de78 100644
--- a/games-emulation/nestra/ChangeLog
+++ b/games-emulation/nestra/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/nestra
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/ChangeLog,v 1.4 2004/06/24 22:31:37 agriffis Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/ChangeLog,v 1.5 2005/03/21 08:10:09 eradicator Exp $
+
+ 21 Mar 2005; Jeremy Huddleston <eradicator@gentoo.org>
+ nestra-0.66-r1.ebuild:
+ Added support to build 32bit version on amd64.
*nestra-0.66-r1 (27 Mar 2004)
diff --git a/games-emulation/nestra/Manifest b/games-emulation/nestra/Manifest
index d0e2f003b271..d88d5aeea817 100644
--- a/games-emulation/nestra/Manifest
+++ b/games-emulation/nestra/Manifest
@@ -1,4 +1,14 @@
-MD5 65955639a58e2bc3ee3146fc8ddceb2f ChangeLog 641
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 5dcf1e6d60c31b8b9f909d983cb2bfdc ChangeLog 775
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 f21bf4205a6f02c5a1115fffcefdc23c nestra-0.66-r1.ebuild 895
+MD5 7c0437c9970e4f82ee4aa228131096bf nestra-0.66-r1.ebuild 1606
MD5 1b72c901305b3f39e947ffbe00b7a13e files/digest-nestra-0.66-r1 126
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCPoFqArHZZzCEUG0RAil+AJ9KITtsLfZ4KT9BeWWDEOI4CntxpwCfQfuM
+Hm9eCWWZ69FR861Rio/L+LY=
+=30kT
+-----END PGP SIGNATURE-----
diff --git a/games-emulation/nestra/nestra-0.66-r1.ebuild b/games-emulation/nestra/nestra-0.66-r1.ebuild
index 3bb180ba65ae..e7f4bad00cd9 100644
--- a/games-emulation/nestra/nestra-0.66-r1.ebuild
+++ b/games-emulation/nestra/nestra-0.66-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/nestra-0.66-r1.ebuild,v 1.3 2004/11/24 08:03:16 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/nestra-0.66-r1.ebuild,v 1.4 2005/03/21 08:10:09 eradicator Exp $
-inherit eutils games
+inherit eutils games toolchain-funcs flag-o-matic
PATCH="${P/-/_}-7.diff"
DESCRIPTION="NES emulation for Linux/x86"
@@ -12,20 +12,44 @@ SRC_URI="http://nestra.linuxgames.com/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="~amd64 x86"
IUSE=""
-DEPEND="virtual/x11"
+RDEPEND="amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.2-r7 )"
+
+DEPEND="${RDEPEND}
+ virtual/x11"
S="${WORKDIR}/${PN}"
+pkg_setup() {
+ if use amd64; then
+ if has_multilib_profile; then
+ ABI_ALLOW="x86"
+
+ # And until we get a real multilib portage...
+ ABI="x86"
+
+ # Yeah, this is ugly, but so's their build system...
+ append-flags "-L/emul/linux/x86/usr/lib -L/emul/linux/x86/lib -L/usr/lib32 -L/lib32"
+ append-ldflags $(get_abi_LDFLAGS)
+ elif has_m32 ; then
+ einfo "multilib detected, adding -m32 to CFLAGS."
+ append-flags -m32
+ else
+ die "${PN} requires multilib support in gcc. please re-emerge gcc with multilib in USE and try again"
+ fi
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${WORKDIR}/${PATCH}"
sed -i \
-e 's:-O2 ::' \
- -e "s:gcc:gcc ${CFLAGS}:" Makefile \
+ -e "s:ld:$(tc-getLD) ${LDFLAGS}:" \
+ -e "s:gcc:$(tc-getCC) ${CFLAGS}:" Makefile \
|| die "sed Makefile failed"
}