summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-08 20:29:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-08 20:29:07 +0000
commitb39606ade74192ddc59f0974e8c7481ae3d5345b (patch)
tree6c0f70b1c4de976e15943e865015e351355dbad9 /games-emulation/advancemame
parentmplayer v4l and v4l2 local desc (diff)
downloadhistorical-b39606ade74192ddc59f0974e8c7481ae3d5345b.tar.gz
historical-b39606ade74192ddc59f0974e8c7481ae3d5345b.tar.bz2
historical-b39606ade74192ddc59f0974e8c7481ae3d5345b.zip
version bump; added freetype2 support (use truetype); added debug eclass support; use keepdir on empty directories in GAMES_DATADIR
Diffstat (limited to 'games-emulation/advancemame')
-rw-r--r--games-emulation/advancemame/ChangeLog8
-rw-r--r--games-emulation/advancemame/Manifest4
-rw-r--r--games-emulation/advancemame/advancemame-0.81.0.ebuild76
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.81.01
4 files changed, 86 insertions, 3 deletions
diff --git a/games-emulation/advancemame/ChangeLog b/games-emulation/advancemame/ChangeLog
index ffbe8c357699..a07d32914a1a 100644
--- a/games-emulation/advancemame/ChangeLog
+++ b/games-emulation/advancemame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/advancemame
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.7 2004/01/12 05:50:50 vapier Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.8 2004/04/08 20:29:07 mr_bones_ Exp $
+
+ 08 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> advancemame-0.81.0.ebuild:
+ version bump; added freetype2 support (use truetype); added debug eclass
+ support; use keepdir on empty directories in GAMES_DATADIR
*advancemame-0.78.0 (12 Jan 2004)
diff --git a/games-emulation/advancemame/Manifest b/games-emulation/advancemame/Manifest
index ff53ae8fcc9f..34930eeb4e79 100644
--- a/games-emulation/advancemame/Manifest
+++ b/games-emulation/advancemame/Manifest
@@ -1,6 +1,8 @@
-MD5 adc7a20f4cd0bf35ba924e5bb8dccd1e ChangeLog 2242
+MD5 0df8f6de2b661997cedea10b89a45890 ChangeLog 2464
MD5 8fdc3b80b152afdec14bd9018d024bc3 advancemame-0.77.2.ebuild 1527
MD5 9ad5b3665357db5e5bceb77f8631577f advancemame-0.78.0.ebuild 1527
MD5 972b8c9f939a33a7074e0819fb55455c metadata.xml 962
+MD5 f1bea5f34a59136d6f65cf81050321c1 advancemame-0.81.0.ebuild 1822
MD5 d5d580fd228271ce09bb83027f21a14b files/digest-advancemame-0.77.2 72
MD5 c5dd3cee0f731cccc30e89067f0e0777 files/digest-advancemame-0.78.0 72
+MD5 ee6170be60235d6f49882f80dadd122d files/digest-advancemame-0.81.0 72
diff --git a/games-emulation/advancemame/advancemame-0.81.0.ebuild b/games-emulation/advancemame/advancemame-0.81.0.ebuild
new file mode 100644
index 000000000000..8be6b0d50753
--- /dev/null
+++ b/games-emulation/advancemame/advancemame-0.81.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.81.0.ebuild,v 1.1 2004/04/08 20:29:07 mr_bones_ Exp $
+
+inherit eutils games
+use debug && inherit debug
+
+DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
+HOMEPAGE="http://advancemame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
+
+LICENSE="GPL-2 xmame"
+SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE="debug static svga truetype fbcon alsa oss slang sdl"
+
+RDEPEND="virtual/glibc
+ app-arch/unzip
+ app-arch/zip
+ x86? ( >=dev-lang/nasm-0.98 )
+ sdl? ( media-libs/libsdl )
+ slang? ( sys-libs/slang )
+ alsa? ( media-libs/alsa-lib )
+ truetype? ( media-libs/freetype )
+ svga? ( >=media-libs/svgalib-1.9 )"
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+src_unpack() {
+ unpack ${A}
+
+ use x86 && \
+ ln -s $(which nasm) "${T}/${CHOST}-nasm"
+ use sdl && \
+ ln -s $(which sdl-config) "${T}/${CHOST}-sdl-config"
+ use truetype && \
+ ln -s $(which freetype-config) "${T}/${CHOST}-freetype-config"
+}
+
+src_compile() {
+ PATH="${PATH}:${T}"
+ egamesconf \
+ $(use_enable debug) \
+ $(use_enable truetype freetype) \
+ $(use_enable static) \
+ $(use_enable x86 asm) \
+ $(use_enable svga svgalib) \
+ $(use_enable fbcon fb) \
+ $(use_enable alsa) \
+ $(use_enable oss) \
+ $(use_enable slang) \
+ $(use_enable sdl) \
+ --with-emu=${PN/advance} \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ local m
+
+ dogamesbin adv* || die "dogamesbin failed"
+
+ keepdir "${GAMES_DATADIR}"/advance/{artwork,diff,image,rom,sample,snap}
+ insinto "${GAMES_DATADIR}/advance"
+ doins support/event.dat
+
+ dodoc HISTORY README RELEASE
+ cd obj/doc
+ dodoc *.txt
+ dohtml *.html
+ for m in *.1 ; do
+ newman ${m} ${m/1/6}
+ done
+
+ prepgamesdirs
+}
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.81.0 b/games-emulation/advancemame/files/digest-advancemame-0.81.0
new file mode 100644
index 000000000000..b7c43b5063f4
--- /dev/null
+++ b/games-emulation/advancemame/files/digest-advancemame-0.81.0
@@ -0,0 +1 @@
+MD5 5615328533e4504b1e52c7bc21845c72 advancemame-0.81.0.tar.gz 11427892