summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-13 04:07:47 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-13 04:07:47 +0000
commit666c1a6ceac87fa561c0e7396cc26e60d39d3be5 (patch)
tree8a6c03dcf976c6ddd1d73b0faaa734f9b84db89f /games-board
parentFix patch. (diff)
downloadhistorical-666c1a6ceac87fa561c0e7396cc26e60d39d3be5.tar.gz
historical-666c1a6ceac87fa561c0e7396cc26e60d39d3be5.tar.bz2
historical-666c1a6ceac87fa561c0e7396cc26e60d39d3be5.zip
Sigh.
Package-Manager: portage-2.2_rc38/cvs/Linux x86_64
Diffstat (limited to 'games-board')
-rw-r--r--games-board/hexxagon/Manifest2
-rw-r--r--games-board/hexxagon/files/hexxagon-1.0-build.patch (renamed from games-board/hexxagon/files/hexxagon-1.0-toolchain.patch)293
2 files changed, 155 insertions, 140 deletions
diff --git a/games-board/hexxagon/Manifest b/games-board/hexxagon/Manifest
index 5a6f185a368f..433a86af9064 100644
--- a/games-board/hexxagon/Manifest
+++ b/games-board/hexxagon/Manifest
@@ -1,4 +1,4 @@
-AUX hexxagon-1.0-build.patch 4013 RMD160 771b8e301c78c5a95539209a4f8455d8025a5e91 SHA1 6b6951c25272409c88481b727264d2e11fcc144d SHA256 5ad8cdae1e8976a665061e31e74f8aa28529d306a1b92c95a318a402bed2da5a
+AUX hexxagon-1.0-build.patch 4061 RMD160 c12e331d661e07a2c46089ddd0e994f9fdfc07ba SHA1 0b86ebbac0a4ffd2a4c3aa73caf576994cd5f4c0 SHA256 8230f4e3d2fc7f2eec467a8f0ff52073d54a35ea8d0bc6325457dfe46ebcc58b
DIST hexxagon-1.0.tar.bz2 1245889 RMD160 d38b98db3a694818437c6dfc8916ff0ce338f1ea SHA1 1ffe2d6d64a79888c9e5b0dde476006e251afc21 SHA256 d38c6171550a2e10ece4ae655cbc417a1bdb86912cd5f141e2a19840d4cb5f5f
EBUILD hexxagon-1.0.ebuild 827 RMD160 4e0befea5aea339a166a1a0fce07881253d6902a SHA1 379edb3650a5a2b3b025b2ee604a23b7df8ebd43 SHA256 c475f2c447d58f79a56eb04c84e84de915c6038ae5364e31935c162d78aa80a6
MISC ChangeLog 2466 RMD160 aca72c0e7e8d7db2a84ea25f1870cc2ea12008ec SHA1 92f3f56a3812c5439b5132fbaded56286ea9e00a SHA256 78edb3accc4804361764c69ff2585029bb12dd2f75c6ad22d26bf4829cf49305
diff --git a/games-board/hexxagon/files/hexxagon-1.0-toolchain.patch b/games-board/hexxagon/files/hexxagon-1.0-build.patch
index d4d30913ad12..8aece9b47576 100644
--- a/games-board/hexxagon/files/hexxagon-1.0-toolchain.patch
+++ b/games-board/hexxagon/files/hexxagon-1.0-build.patch
@@ -1,139 +1,154 @@
-diff -ur hexxagon-1.0/src/libhexx/bitboard64.h ../BUILD/hexxagon-1.0/src/libhexx/bitboard64.h
---- hexxagon-1.0/src/libhexx/bitboard64.h 2005-01-13 13:19:07.000000000 -0800
-+++ ../BUILD/hexxagon-1.0/src/libhexx/bitboard64.h 2009-08-12 13:11:57.663180010 -0700
-@@ -19,12 +19,12 @@
- *
- */
-
--
- #ifndef _BITBOARD64_H
- #define _BITBOARD64_H
-
- #include <netinet/in.h>
- #include <iostream>
-+#include <cstdio>
-
- namespace libhexx
- {
-@@ -54,14 +54,12 @@
- {
- printf("0x%X, 0x%X\n", lowbits, highbits);
- };
--
-- friend std::ostream& operator<<(std::ostream &output, const class BitBoard64 &b);
-- friend std::istream& operator>>(std::istream &input, class BitBoard64 &b);
--
-- private:
--
-+
- uint32_t lowbits, highbits;
- };
-+
-+ std::ostream& operator<<(std::ostream &output, const class BitBoard64 &b);
-+ std::istream& operator>>(std::istream &input, class BitBoard64 &b);
- }
-
- #endif
-diff -ur hexxagon-1.0/src/libhexx/board.h ../BUILD/hexxagon-1.0/src/libhexx/board.h
---- hexxagon-1.0/src/libhexx/board.h 2005-01-16 03:12:23.000000000 -0800
-+++ ../BUILD/hexxagon-1.0/src/libhexx/board.h 2009-08-12 13:11:35.577180031 -0700
-@@ -33,8 +33,21 @@
-
- namespace libhexx
- {
-- class Move;
-- class MoveList;
-+ class Move
-+ {
-+ public:
-+ Move();
-+ Move(int t);
-+ Move(int f, int t);
-+
-+ operator bool() const;
-+
-+ char from, to;
-+ int score;
-+ };
-+
-+ bool scoreMoves(std::vector<Move> &moves, class Board board,
-+ const LookUp& lookUp, int depth, bool (*callback)(), int maxtime);
-
- enum
- {
-diff -ur hexxagon-1.0/src/libhexx/libhexx.h ../BUILD/hexxagon-1.0/src/libhexx/libhexx.h
---- hexxagon-1.0/src/libhexx/libhexx.h 2005-01-13 13:19:07.000000000 -0800
-+++ ../BUILD/hexxagon-1.0/src/libhexx/libhexx.h 2009-08-12 12:02:28.756180003 -0700
-@@ -19,7 +19,6 @@
- *
- */
-
--
- #include "bitboard64.h"
- #include "move.h"
- #include "board.h"
-diff -ur hexxagon-1.0/src/libhexx/lookup.h ../BUILD/hexxagon-1.0/src/libhexx/lookup.h
---- hexxagon-1.0/src/libhexx/lookup.h 2005-01-13 13:19:07.000000000 -0800
-+++ ../BUILD/hexxagon-1.0/src/libhexx/lookup.h 2009-08-12 11:58:08.758180417 -0700
-@@ -27,6 +27,8 @@
-
- namespace libhexx
- {
-+ class BitBoard64;
-+
- int getHexxagonIndex(int x, int y);
-
- class LookUp
-diff -ur hexxagon-1.0/src/libhexx/move.cpp ../BUILD/hexxagon-1.0/src/libhexx/move.cpp
---- hexxagon-1.0/src/libhexx/move.cpp 2005-01-16 03:12:23.000000000 -0800
-+++ ../BUILD/hexxagon-1.0/src/libhexx/move.cpp 2009-08-12 13:12:27.140180083 -0700
-@@ -114,4 +114,11 @@
- return true;
- }
-
--
-+Move::Move() { from = 99; to = 99;};
-+Move::Move(int t) { from = t; to = t; };
-+Move::Move(int f, int t) { from = f; to = t; };
-+
-+Move::operator bool() const
-+{
-+ return from != 99 && to != 99;
-+}
-diff -ur hexxagon-1.0/src/libhexx/move.h ../BUILD/hexxagon-1.0/src/libhexx/move.h
---- hexxagon-1.0/src/libhexx/move.h 2005-01-13 13:19:07.000000000 -0800
-+++ ../BUILD/hexxagon-1.0/src/libhexx/move.h 2009-08-12 13:12:50.146179982 -0700
-@@ -23,19 +23,19 @@
- #ifndef _MOVE_H
- #define _MOVE_H
-
--#include "board.h"
--
- #include <list>
- #include <vector>
-
- namespace libhexx
- {
-+ class Board;
-+
- class Move
- {
- public:
-- Move() { from = 99; to = 99;};
-- Move(int t) { from = t; to = t; };
-- Move(int f, int t) { from = f; to = t; };
-+ Move();
-+ Move(int t);
-+ Move(int f, int t);
-
- inline bool operator<(const Move &r) const
- {
-@@ -47,7 +47,7 @@
- return (score != r.score);
- };
-
-- operator bool() const { return from != 99 && to != 99; };
-+ operator bool() const;
-
- char from, to;
- int score;
+diff -ur hexxagon-1.0.original/src/libhexx/bitboard64.h hexxagon-1.0/src/libhexx/bitboard64.h
+--- hexxagon-1.0.original/src/libhexx/bitboard64.h 2005-01-13 23:19:07.000000000 +0200
++++ hexxagon-1.0/src/libhexx/bitboard64.h 2009-08-13 06:51:10.000000000 +0300
+@@ -19,12 +19,12 @@
+ *
+ */
+
+-
+ #ifndef _BITBOARD64_H
+ #define _BITBOARD64_H
+
+ #include <netinet/in.h>
+ #include <iostream>
++#include <cstdio>
+
+ namespace libhexx
+ {
+@@ -54,14 +54,12 @@
+ {
+ printf("0x%X, 0x%X\n", lowbits, highbits);
+ };
+-
+- friend std::ostream& operator<<(std::ostream &output, const class BitBoard64 &b);
+- friend std::istream& operator>>(std::istream &input, class BitBoard64 &b);
+-
+- private:
+-
++
+ uint32_t lowbits, highbits;
+ };
++
++ std::ostream& operator<<(std::ostream &output, const class BitBoard64 &b);
++ std::istream& operator>>(std::istream &input, class BitBoard64 &b);
+ }
+
+ #endif
+diff -ur hexxagon-1.0.original/src/libhexx/board.h hexxagon-1.0/src/libhexx/board.h
+--- hexxagon-1.0.original/src/libhexx/board.h 2005-01-16 13:12:23.000000000 +0200
++++ hexxagon-1.0/src/libhexx/board.h 2009-08-13 07:03:48.000000000 +0300
+@@ -25,7 +25,6 @@
+
+ #include "bitboard64.h"
+ #include "lookup.h"
+-#include "move.h"
+ #include "layout.h"
+
+ #include <iostream>
+@@ -33,8 +32,21 @@
+
+ namespace libhexx
+ {
+- class Move;
+- class MoveList;
++ class Move
++ {
++ public:
++ Move();
++ Move(int t);
++ Move(int f, int t);
++
++ operator bool() const;
++
++ char from, to;
++ int score;
++ };
++
++ bool scoreMoves(std::vector<Move> &moves, class Board board,
++ const LookUp& lookUp, int depth, bool (*callback)(), int maxtime);
+
+ enum
+ {
+diff -ur hexxagon-1.0.original/src/libhexx/libhexx.h hexxagon-1.0/src/libhexx/libhexx.h
+--- hexxagon-1.0.original/src/libhexx/libhexx.h 2005-01-13 23:19:07.000000000 +0200
++++ hexxagon-1.0/src/libhexx/libhexx.h 2009-08-13 06:53:35.000000000 +0300
+@@ -19,6 +19,8 @@
+ *
+ */
+
++#ifndef _LIBHEXX_H
++#define _LIBHEXX_H
+
+ #include "bitboard64.h"
+ #include "move.h"
+@@ -27,3 +29,5 @@
+ #include "lookup.h"
+ #include "view.h"
+ #include "layout.h"
++
++#endif
+diff -ur hexxagon-1.0.original/src/libhexx/lookup.h hexxagon-1.0/src/libhexx/lookup.h
+--- hexxagon-1.0.original/src/libhexx/lookup.h 2005-01-13 23:19:07.000000000 +0200
++++ hexxagon-1.0/src/libhexx/lookup.h 2009-08-13 06:51:10.000000000 +0300
+@@ -27,6 +27,8 @@
+
+ namespace libhexx
+ {
++ class BitBoard64;
++
+ int getHexxagonIndex(int x, int y);
+
+ class LookUp
+diff -ur hexxagon-1.0.original/src/libhexx/move.cpp hexxagon-1.0/src/libhexx/move.cpp
+--- hexxagon-1.0.original/src/libhexx/move.cpp 2005-01-16 13:12:23.000000000 +0200
++++ hexxagon-1.0/src/libhexx/move.cpp 2009-08-13 06:51:10.000000000 +0300
+@@ -114,4 +114,11 @@
+ return true;
+ }
+
+-
++Move::Move() { from = 99; to = 99;};
++Move::Move(int t) { from = t; to = t; };
++Move::Move(int f, int t) { from = f; to = t; };
++
++Move::operator bool() const
++{
++ return from != 99 && to != 99;
++}
+diff -ur hexxagon-1.0.original/src/libhexx/move.h hexxagon-1.0/src/libhexx/move.h
+--- hexxagon-1.0.original/src/libhexx/move.h 2005-01-13 23:19:07.000000000 +0200
++++ hexxagon-1.0/src/libhexx/move.h 2009-08-13 06:51:10.000000000 +0300
+@@ -23,19 +23,19 @@
+ #ifndef _MOVE_H
+ #define _MOVE_H
+
+-#include "board.h"
+-
+ #include <list>
+ #include <vector>
+
+ namespace libhexx
+ {
++ class Board;
++
+ class Move
+ {
+ public:
+- Move() { from = 99; to = 99;};
+- Move(int t) { from = t; to = t; };
+- Move(int f, int t) { from = f; to = t; };
++ Move();
++ Move(int t);
++ Move(int f, int t);
+
+ inline bool operator<(const Move &r) const
+ {
+@@ -47,7 +47,7 @@
+ return (score != r.score);
+ };
+
+- operator bool() const { return from != 99 && to != 99; };
++ operator bool() const;
+
+ char from, to;
+ int score;